当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教subclipse问题
帖子发表于 : 2007-01-31 18:30 

注册: 2007-01-16 15:41
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
我己安装了subclipse和javahl,在eclipse 中的SVN选项不能选择javaHL接口,提示Loading javaHL Library错误,javaHL在java.library.path中不存在,如图所示,那位大侠帮我看看什么问题?
我在网上看到别人说要在$JAVA_HOME/jre/lib/i386/client/下建立到/usr/lib/jni/libsvnjavahl-1.so连接:
sundoctor@sundoctor-laptop:/usr/lib/jvm/java-6-sun/jre/lib/i386/client$ sudo ln -s /usr/lib/jni/libsvnjavahl-1.so libsvnjavahl-1.so
可是我建 完连接后,在ecplise中一点击SVN配置项就会出启动错误,eclipse自动关闭,只好把连接删除。


附件:
文件注释: 出错提示
Screenshot.png
Screenshot.png [ 78.48 KiB | 被浏览 774 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-16 11:30 

注册: 2006-04-24 14:07
帖子: 93
送出感谢: 0 次
接收感谢: 0 次
用javaSVN链接看看


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-16 13:43 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
在Windows底下也会出现这个错误,用JavaSVN没有问题的,我一直都是用JavaSVN


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-26 16:42 

注册: 2006-06-09 17:33
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
我的做法是:
sudo apt-get install libsvn-java libsvn-javahl
sudo ln -s /usr/lib/jni/libsvnjavahl-1.so /usr/lib/jvm/java-6-sun/jre/lib/i386/client/libsvnjavahl-1.so
然后就好用了


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-16 12:06 

注册: 2007-10-17 18:23
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上,我也遇到相同的问题,引用楼上方法已解决。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译