当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]关于Eclipse 显示问题。
帖子发表于 : 2007-02-08 11:48 

注册: 2005-12-28 16:23
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
我用的是 lomboz 版的 eclipse,在 win 下缩进正常,但是到了 linux 下感觉不太对劲,请问在哪里可以设置?


附件:
文件注释: linux 下四个空格表现为一个空格,缩进的距离也很小。
Screenshot.png
Screenshot.png [ 70.95 KiB | 被浏览 1768 次 ]

文件注释: windows 下缩进和格式都正常。
Eclipse_windows.png
Eclipse_windows.png [ 153.27 KiB | 被浏览 1739 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-02-09 2:10 
头像

注册: 2006-12-21 9:46
帖子: 137
送出感谢: 0 次
接收感谢: 0 次
这个可以在Window>Preferences里设置的。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-02-09 8:00 

注册: 2005-12-28 16:23
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
可以说得再具体一点吗?我想设置成 WIN 下的那种缩进效果。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-02-13 19:01 
头像

注册: 2007-01-31 23:01
帖子: 61
地址: 慕尼黑
送出感谢: 0 次
接收感谢: 0 次
yoshubom 写道:
可以说得再具体一点吗?我想设置成 WIN 下的那种缩进效果。


你调整Displayed tab width.


附件:
文件注释: Eclipse调整 Tab Width
Bildschirmfoto-Preferences .png
Bildschirmfoto-Preferences .png [ 50.72 KiB | 被浏览 1721 次 ]

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-02-14 7:57 

注册: 2005-12-28 16:23
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
其实我已经将 tab 设为 4 了。但是现在我发现按下 4 下空格光标移动的位置却只有一个字符的宽度,按下 tab 也才两个字符的宽度。也就是说我按下空格键的时候光标的移动是 1/4 个字符。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-02-16 23:14 
头像

注册: 2007-01-31 23:01
帖子: 61
地址: 慕尼黑
送出感谢: 0 次
接收感谢: 0 次
Linux下好像不是等宽字体,所以空格特别小。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-02-18 0:49 

注册: 2005-12-28 16:23
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
有办法显示等宽字体吗?redhat上面的eclipse 就是显示等宽的。望高手指点。


页首
 用户资料  
 
8 楼 
 文章标题 : 修改字体首选项
帖子发表于 : 2007-02-18 11:57 

注册: 2007-02-13 13:07
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
在字体首选项里设置一下等宽字体:


附件:
Font.jpg
Font.jpg [ 102.03 KiB | 被浏览 1709 次 ]

页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-02-20 5:45 
头像

注册: 2006-12-21 9:46
帖子: 137
送出感谢: 0 次
接收感谢: 0 次
frank7258 写道:
Linux下好像不是等宽字体,所以空格特别小。


应该是这个原因

我把Eclipse的基本字体设为雅黑的时候,就会出现这种情况。设为Courier 10 Pitch的时候就不会这样了。楼主试试把Eclipse里的基本文本字体设为Courier 10 Pitch看看。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-02-25 18:05 

注册: 2005-12-28 16:23
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
呵呵,问题解决了,相当不错。

window -》preferences -》General -》Appearance -》Colors and Fonts -》Basic -》Text Font

选择 change ... 然后选用 courier 10 pitch 显示就正常了。呵呵多谢各位帮忙。非常感谢!!!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-02-28 11:11 
头像

注册: 2006-10-04 21:52
帖子: 228
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
thanks . mark


_________________
本本Acer TravelMate 2403NWXM
xubuntu (feisty fawn)
我的blog:http://jdkcn.com


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-05-04 16:43 
头像

注册: 2007-11-23 7:20
帖子: 66
地址: 中国湖北省武汉市
送出感谢: 0 次
接收感谢: 0 次
我也有同样的问题,按照上面的方法解决了。
谢谢!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译