当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装build-essential出错
帖子发表于 : 2007-02-11 16:21 

注册: 2007-01-16 23:26
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
newrain@newrain-desktop:/$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包

在新立得中寻找到libc6-dev,安装,出现下面信息:
libc6-dev:
依赖: libc6 (=2.3.6-0ubuntu20.4) 但是将会安装 2.4-1ubuntu12

然后我在gun gcc中下载了:
libc6-dev_2.3.6.ds1-10_i386.deb
安装libc-dev出错,显示的信息:
Error: Dependency isnot satisfiable:libc6
我按提示又下载了
libc6_2.3.6.ds1-10_i386.deb
安装libc6时又出现错误:
Error:已经安装了更新的版本

依据上面的提示,我查看了新立得软件管理器中关于libc的内容:
新立得中显示依次为:
libc6 base main 2.4-lubuntu12 2.4-lubuntu12

也就是说我已经有libc的版本了,但是版本太高了,我想删除它,但是系统中其他很多软件都与其关联,如果删除了,系统中的其他软件好像也要删除了。

请求高手帮忙


:( :(


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-02-11 16:42 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo apt-get update; sudo aptitude install build-essential


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-09 11:30 

注册: 2007-03-05 23:16
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我败了

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
下列软件包是“破损”的:
libc6-dev
下列软件包将被自动安装:
cpp-4.0 dpkg-dev g++ g++-4.0 gcc-4.0 gcc-4.0-base libmudflap0
libmudflap0-dev libstdc++6-4.0-dev linux-kernel-headers
下列“新”软件包将被安装。
build-essential cpp-4.0 dpkg-dev g++ g++-4.0 gcc-4.0 gcc-4.0-base
libmudflap0 libmudflap0-dev libstdc++6-4.0-dev linux-kernel-headers
0 个软件包被升级,新安装12 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 10.7MB 的存档。 解包后将要使用 39.6MB。
下列软件包存在未满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.4) 但是 2.4-1ubuntu12.3 已安装
Resolving dependencies...
下列动作将解决这些依赖关系:

保持 下列软件包于其当前版本:
build-essential [未安装的]
g++ [未安装的]
g++-4.0 [未安装的]
gcc-4.0 [未安装的]
libc6-dev [未安装的]
libmudflap0-dev [未安装的]
libstdc++6-4.0-dev [未安装的]

分数是 53

是否接受该解决方案?[Y/n/q/?] n
Resolving dependencies...
下列动作将解决这些依赖关系:

保持 下列软件包于其当前版本:
build-essential [未安装的]
g++ [未安装的]
g++-4.0 [未安装的]
libc6-dev [未安装的]
libmudflap0-dev [未安装的]
libstdc++6-4.0-dev [未安装的]

保留下列未解决的依赖关系:
gcc-4.0 推荐 libc6-dev (>= 2.3.5-1ubuntu5)
gcc-4.0 推荐 libmudflap0-dev (>= 4.0.3-1ubuntu5)
分数是 -356

是否接受该解决方案?[Y/n/q/?] n
Resolving dependencies...
open: 5834; closed: 5005; defer: 0; conflict/break: 6 .在分配的时间内未找到解决方案。加把劲再试试?[Y/n]y
Resolving dependencies...
open: 11984; closed: 9998; defer: 0; conflict/break: 6 o在分配的时间内未找到解决方案。加把劲再试试?[Y/n]n
放弃解决这些依赖关系的全部努力。
放弃。


页首
 用户资料  
 
4 楼 
 文章标题 : 我和你的问题一模一样,郁闷……
帖子发表于 : 2008-07-05 16:49 
头像

注册: 2008-07-05 15:02
帖子: 8
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
aurum@aurum-laptop:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
依赖: dpkg-dev (>= 1.13.5) 但是它将不会被安装


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-05 16:50 
头像

注册: 2008-07-05 15:02
帖子: 8
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
aurum@aurum-laptop:~$ sudo aptitude install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
Reading extended state information
Initializing package states... 完成
Writing extended state information... 完成
Building tag database... 完成
The following packages are BROKEN:
dpkg libc6-dev
The following NEW packages will be automatically installed:
cpp-4.1 dpkg-dev g++ g++-4.1 gcc-4.1 gcc-4.1-base libmudflap0
libmudflap0-dev libstdc++6-4.1-dev linux-libc-dev patch
The following NEW packages will be installed:
build-essential cpp-4.1 dpkg-dev g++ g++-4.1 gcc-4.1 gcc-4.1-base
libmudflap0 libmudflap0-dev libstdc++6-4.1-dev linux-libc-dev patch
0 packages upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
Need to get 11.7MB of archives. After unpacking 42.3MB will be used.
The following packages have unmet dependencies:
dpkg: Breaks: dpkg-dev (< 1.14.6) but 1.13.24ubuntu6 is to be installed.
libc6-dev: 依赖: libc6 (= 2.5-0ubuntu14) but 2.7-10ubuntu3 is installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
build-essential [Not Installed]
dpkg-dev [Not Installed]
g++ [Not Installed]
g++-4.1 [Not Installed]
gcc-4.1 [Not Installed]
libc6-dev [Not Installed]
libmudflap0-dev [Not Installed]
libstdc++6-4.1-dev [Not Installed]

Score is -9818

Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
Reading extended state information
Initializing package states... 完成
Building tag database... 完成


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-05 18:35 
头像

注册: 2008-07-05 15:02
帖子: 8
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
http://forum.ubuntu.org.cn/viewtopic.ph ... 166#828166五楼有解决方案,供大家参考


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-16 18:47 

注册: 2007-10-28 21:34
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
我依照这个方法作一下试试,看是否可行


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译