[求助]:jdk安装不了,哪位达人指教

C、C++和Java语言
回复
leonne
帖子: 4
注册时间: 2007-03-13 13:52
送出感谢: 0
接收感谢: 0

[求助]:jdk安装不了,哪位达人指教

#1

帖子 leonne » 2007-03-13 14:08

初学ubuntu,折腾了半天jdk安装不上去。
第一步:
leon@leon:~$ sudo apt-get -f install sun-java6-jre
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
java-package: Depends: debhelper but it is not going to be installed
Depends: fakeroot but it is not going to be installed
sun-java6-jre: Depends: sun-java6-bin (= 6-00-0ubuntu1) but it is not going to be installed or
ia32-sun-java6-bin (= 6-00-0ubuntu1) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

根据提示,运行第二步:
leon@leon:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
debhelper dpkg-dev fakeroot html2text sun-java5-bin sun-java5-jre
Suggested packages:
dh-make debian-keyring sun-java5-plugin ia32-sun-java5-plugin
sun-java5-fonts ttf-sazanami-gothic ttf-sazanami-mincho
Recommended packages:
gsfonts-x11
The following NEW packages will be installed:
debhelper dpkg-dev fakeroot html2text
The following packages will be upgraded:
sun-java5-bin sun-java5-jre
2 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0B/30.6MB of archives.
After unpacking 85.7MB of additional disk space will be used.
Do you want to continue [Y/n]?

输入y,回车,出现满屏版本信息就不动了
Ubuntu Configuration

┌───────────────────────┤ Configuring sun-java5-bin ├───────────────────────┐
│ │
│ Operating System Distributor License for Java v1.1 (DLJ) ↑
│ ▮
│ Operating System Distributor License for Java version 1.1 (DLJ) ▒
│ ▒
│ SUN MICROSYSTEMS, INC. ("SUN") IS WILLING TO LICENSE THE JAVA PLATFORM ▒
│ STANDARD EDITION DEVELOPER KIT ("JDK" - THE "SOFTWARE") TO YOU ONLY UPON ▒
│ THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS LICENSE ▒
│ AGREEMENT (THE "AGREEMENT"). PLEASE READ THE AGREEMENT CAREFULLY. BY ▒
│ INSTALLING, USING, OR DISTRIBUTING THIS SOFTWARE, YOU ACCEPT ALL OF THE ▒
│ TERMS OF THE AGREEMENT. ▒
│ ▒
│ 1. DEFINITIONS. "Software" means the code identified above in binary ▒
│ form, any other machine readable materials including, but not ▒
│ limited to, libraries, source files, header files, and data files), ↓

│ <Ok>

运行多次都是这样,哪位达人指教,不胜感谢!
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2007-03-13 14:12

tab!!!
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
leonne
帖子: 4
注册时间: 2007-03-13 13:52
送出感谢: 0
接收感谢: 0

#3

帖子 leonne » 2007-03-13 14:15

2楼啥意思,能不能说清楚一点。
现在什么包都安装不了,都是一个错:
leon@leon:~$ sudo apt-get install acroread
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
java-package: Depends: debhelper but it is not going to be installed
Depends: fakeroot but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

leon@leon:~$ sudo apt-get install realplay
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
java-package: Depends: debhelper but it is not going to be installed
Depends: fakeroot but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2007-03-13 14:17

tab键,然后回车。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
leonne
帖子: 4
注册时间: 2007-03-13 13:52
送出感谢: 0
接收感谢: 0

#5

帖子 leonne » 2007-03-13 14:26

呵呵,本人的确菜鸟,多谢楼上指点
stephenmjm
帖子: 15
注册时间: 2007-07-18 18:53
来自: hnu
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 stephenmjm » 2007-08-05 14:50

原来如此,这东西一个星期以来都是我的心病
很多人都是回答的一大堆,又没到点上
高手就是高手啊,言简意赅
菜鸟我感激不尽
chee
帖子: 34
注册时间: 2005-05-16 21:24
来自: 广东茂名
送出感谢: 0
接收感谢: 0

#7

帖子 chee » 2007-08-05 16:46

虽然可以apt-get,但还是建议下载下来,再手工安装。
头像
bird
帖子: 765
注册时间: 2006-09-04 10:45
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 bird » 2007-08-10 11:11

我是从SUN的官方网站上下载JDK,一般是bin的包,比如:jdk-1_5_0_12-linux-i586.bin,放到你的home目录下面,再安装就可以了,代码如下:
sudo chmod +x ./jdk-1_5_0_12-linux-i586.bin
sudo ./jdk-1_5_0_12-linux-i586.bin

再从eclipse网站上下载eclipse,直接解压就可以用了,我一般是解压到/opt/eclipse/ 下面的,再在桌面做个eclipse的链接,就可以用了。

这个就是我的办法,比较简单,基本没有问题,除了swing的中文好像有点问题,正在解决。

netbeans的安装和jdk的安装十分类似,就不用再说了把。

还有不明白的,可以参考下面这个帖子:
viewtopic.php?t=43082

头像
redeggs
帖子: 6
注册时间: 2007-02-01 17:32
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 redeggs » 2007-08-15 17:04

tab键选中OK 按回车啊
回复

回到 “C/C++/Java”