当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 安装g++时遇到的问题,帮帮忙阿
帖子发表于 : 2007-03-21 8:29 

注册: 2007-03-20 10:18
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
ccrt@ccrt:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包
ccrt@ccrt:~$


搜遍了整个论坛都没有解决的办法,官方英文说明里也没提到这个问题。
还有,在安装nvidia驱动时遇到同样的问题,后来无奈的降低了内核版本才解决,这次是怎么样都不行了。
libc6-dev版本太高,又没办法强制版本,重装了n次n次都无法解决,不知道还有没人遇到过这个问题,指点一下。
编程无法进行,ubuntu变成娱乐工具了,郁闷!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-21 9:17 
头像

注册: 2006-12-02 12:25
帖子: 689
送出感谢: 0 次
接收感谢: 0 次
安装G++先


_________________
Titainium


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-21 9:33 

注册: 2007-03-20 10:18
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
都试过了,所有的问题总绕到一个地方

libc6 (=2.3.6-0ubuntu20.4) 但是将会安装 2.4-1ubuntu12

又不能强制版本。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-21 9:59 
头像

注册: 2006-12-02 12:25
帖子: 689
送出感谢: 0 次
接收感谢: 0 次
解决这种问题的终极方法:重装ubuntu。 :em39


_________________
Titainium


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-21 10:16 

注册: 2007-03-20 10:18
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
终极方法失败!!!
官方的源里和cn99的源都下过安装包,重装 了n次,都不见效


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-03-21 11:46 
头像

注册: 2006-12-02 12:25
帖子: 689
送出感谢: 0 次
接收感谢: 0 次
偶说的是重装系统,不然怎么叫终极 :em26


_________________
Titainium


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-03-21 13:23 

注册: 2007-03-20 10:18
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
没错阿,我从官方和cn99都下了iso镜像重装,很遗憾,不行。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-03-21 13:32 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
用aptitude


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-03-21 13:33 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
rpwt


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-03-21 14:01 
头像

注册: 2006-12-02 12:25
帖子: 689
送出感谢: 0 次
接收感谢: 0 次
g++就装不上吗?


_________________
Titainium


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-03-21 18:05 

注册: 2007-03-20 10:18
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
能请教一下aptitude怎样使用吗??


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-03-21 18:39 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo aptitude install ****


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-03-21 19:29 
头像

注册: 2006-12-02 12:25
帖子: 689
送出感谢: 0 次
接收感谢: 0 次
其实跟APT-GET是一个意思。


_________________
Titainium


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-03-21 19:33 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
titainium 写道:
其實跟APT-GET是一個意思。

不同的..aptitude可以自动解决依赖性问题


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-03-22 12:47 

注册: 2007-03-20 10:18
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
没用的,解决办法就是一个保持不变.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译