libavcodec-dev无法在ubuntu14.04下安装

C、C++和Java语言
回复
sarrow
帖子: 403
注册时间: 2007-10-27 1:04
送出感谢: 0
接收感谢: 1 次

libavcodec-dev无法在ubuntu14.04下安装

#1

帖子 sarrow » 2015-10-19 23:04

我想进行一些简单的视频处理;直接安装libavformat-dev;

> sudo apt-get install libavformat-dev
> 正在读取软件包列表... 完成
> 正在分析软件包的依赖关系树
> 正在读取状态信息... 完成
> 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
> 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
> 包尚未被创建或是它们已被从新到(Incoming)目录移出。
> 下列信息可能会对解决问题有所帮助:
>
> 下列软件包有未满足的依赖关系:
> libavformat-dev : 依赖: libavcodec-dev (= 6:9.18-0ubuntu0.14.04.1) 但是它将不会被安装
> 依赖: libavutil-dev (= 6:9.18-0ubuntu0.14.04.1) 但是它将不会被安装
> E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

于是 install libavcodec-dev

> sudo apt-get install libavcodec-dev
> ...
> libavcodec-dev : 依赖: libavutil-dev (= 6:9.18-0ubuntu0.14.04.1) 但是它将不会被安装

接着 libavutil-dev

> sudo apt-get install libavutil-dev
> ...
> libavutil-dev : 依赖: libavutil52 (= 6:9.18-0ubuntu0.14.04.1) 但是 7:1.2.5-1~trusty1 正要被安装
难道要先卸载 7:1.2.5-1~trusty1 ?

这个又是什么东西? 7:1.2.5-1~trusty1

我安装了某过时的软件?
bllli
帖子: 1
注册时间: 2017-04-27 9:02
系统: Ubuntu14.04
送出感谢: 0
接收感谢: 0

Re: libavcodec-dev无法在ubuntu14.04下安装

#2

帖子 bllli » 2017-04-27 9:08

我在编译安装GoldenDict时也遇到了相同的问题

我的具体错误信息:

代码: 全选

$ sudo apt install  libavutil-dev
[sudo] password for bllli: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:
下列软件包有未满足的依赖关系:
 libavutil-dev : 依赖: libavutil52 (= 6:9.20-0ubuntu0.14.04.1) 但是 7:1.2.5-1~trusty1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
我的解决办法是:

代码: 全选

	
$ sudo apt install libavutil52=6:9.20-0ubuntu0.14.04.1
我的博客中有更为详细的记录:https://bllli.github.io/2017/04/Ubuntu1 ... oldenDict/

希望对你有帮助
回复

回到 “C/C++/Java”