当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 重新安装编译环境失败
帖子发表于 : 2016-04-20 21:02 

注册: 2007-10-27 1:04
帖子: 403
送出感谢: 0 次
接收感谢: 1
系统 ubuntu 14.04;

因为不小心,把/usr/include/c++这个文件夹给删除了。我于是尝试重新安装编译环境——先删除,再安装。

结果安装失败。

卸载用到的语句:

sudo apt-get remove libstdc++-4.8-dev
sudo apt-get autoremove

重新安装用到的语句:

sudo apt-get install build-essential

结果提示:

The following packages have unmet dependencies:
build-essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 重新安装编译环境失败
帖子发表于 : 2016-04-21 11:23 
头像

注册: 2007-07-14 20:45
帖子: 1277
送出感谢: 68
接收感谢: 37
在出现这个错误提示之后,你试着运行
sudo apt-get install -f

运行完上面这条指令后,再安装


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 重新安装编译环境失败
帖子发表于 : 2016-04-27 22:40 

注册: 2007-10-27 1:04
帖子: 403
送出感谢: 0 次
接收感谢: 1
完结:

早已结局,忘记更新回复了。

说明,sudo apt-get install -f 无效;最后用的是sudo aptitude -f install 来解决的。然后,注意选择intall版的修改建议。系统会自动修复的。

至于 sudo apt-get install -f 为什么无效,就不清楚了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译