当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : eclipse安装之问题(奇怪的)
帖子发表于 : 2005-11-09 23:05 

注册: 2005-11-09 21:54
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
按照http://forum.ubuntu.org.cn/about1251.html
给的方法安装了eclipse,在输入命令eclipse后,无法运行。其错误信息为
Warning: -Xms40m option not implemented in java-sablevm wrapper.
Warning: -Xmx256m option not implemented in java-sablevm wrapper.

!SESSION Wed Nov 09 14:48:29 GMT 2005 ------------------------------------------!ENTRY org.eclipse.core.launcher 4 0 2005-11-09 14:48:29.918
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.RuntimeException: Could not find framework
at org.eclipse.core.launcher.Main.getBootPath (Main.java:639)
at org.eclipse.core.launcher.Main.basicRun (Main.java:276)
at org.eclipse.core.launcher.Main.run (Main.java:977)
at org.eclipse.core.launcher.Main.main (Main.java:952)
at java.lang.VirtualMachine.invokeMain (VirtualMachine.java)
at java.lang.VirtualMachine.main (VirtualMachine.java:92)

我跑道opt目录下直接运行,结果,启动画面跳了出来,但是半天没有下一步动作,郁闷至极。

我的java环境 root@ubuntu:/opt/eclipse # java -V
SableVM version 1.1.5
- compile date and time: 2004-08-13 00:47:21 UTC
- gcc version: 3.3.4 (Debian 1:3.3.4-5ubuntu2)
- 'real life brokenness' features enabled
- signal based exception detection
- copying garbage collection
- bidirectional object layout
- inline-threaded interpreter
呵呵,因为学校里没有jdk1.5。刚好mirror里有free-java
配置了一下,发现遍javac的也能用。

各位英雄,问题是处在我的jdk或jre上吗?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-11-10 10:05 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
源上不是有JDK1.5吗??


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-11-10 10:05 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
实在不行,你在干脆下载源上的Eclipse好了!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-11-10 20:16 

注册: 2005-11-09 21:54
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
firehare 写道:
实在不行,你在干脆下载源上的Eclipse好了!

呵呵,你有所不知了。ubuntu下非ie核心的浏览器不支持DHCP二次分配ip,上不了外网,只能在学校的局域网内逛。来这里是通过代理的。需要重新编写脚本才能连上源。学校内的mirror没有eclipse


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-11-10 22:06 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
我记得在论坛上有如何设置APT代理的贴子,好象是一叶兄写的!反正你下源里用的是apt,又不是浏览器!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-11-12 12:21 

注册: 2005-11-09 21:54
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
谢谢你的建议,我去找找看


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-11-21 21:30 

注册: 2005-11-16 9:40
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
我是单独下载安装的,你可以看看这个贴
http://forum.ubuntu.org.cn/viewtopic.php?t=6150


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-12-17 19:49 

注册: 2005-11-05 23:18
帖子: 142
送出感谢: 0 次
接收感谢: 1
CDDB 写道:
firehare 写道:
实在不行,你在干脆下载源上的Eclipse好了!

呵呵,你有所不知了。ubuntu下非ie核心的浏览器不支持DHCP二次分配ip,上不了外网,只能在学校的局域网内逛。来这里是通过代理的。需要重新编写脚本才能连上源。学校内的mirror没有eclipse

你们学校的论坛上看看吧,应该都有上外网的脚本的。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-01-06 13:39 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
Eclipse?下载了十几个东东,一个也不会用。 :twisted: 我是个Eclipse盲!


_________________
琴声如我


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-01-25 15:19 

注册: 2006-01-15 16:51
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
多动动手吧,多想想就没什么问题,这个eclipse就这样了,程序还更.........


页首
 用户资料  
 
11 楼 
 文章标题 : 是使用了gcj做编译器的问题
帖子发表于 : 2006-01-27 19:06 
头像

注册: 2005-04-07 20:15
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
解决方法,好像以前在论坛里看到过一篇翻的文章,找一下吧


_________________
试着用它来代替windows吧,你会重新找回当年的感动!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-01-27 20:04 

注册: 2005-10-21 11:36
帖子: 118
送出感谢: 0 次
接收感谢: 0 次
这东西不是解压就可以用吗?


_________________
Life would be much easier if I had the source code.


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-01-27 20:06 
头像

注册: 2005-04-07 20:15
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
前提是配置好java,ubuntu自带的是gcj,好像需要某些设置


_________________
试着用它来代替windows吧,你会重新找回当年的感动!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译