当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问ubuntu下编译gnome程序需要用什么包
帖子发表于 : 2007-06-09 0:11 

注册: 2006-08-26 22:33
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
一个很简单的gtk程序
#include <gnome.h>
int main (int argc, char *argv[])
{
GtkWidget *app;
gnome_program_init (“gnome1”, “1.0”, MODULE, argc, argv, NULL);
app = gnome_app_new (“gnome1”, “The Window Title”);
gtk_widget_show(app);
gtk_main ();
return 0;
}
编译命令:gcc gnome1.c –o gnome1 `pkg-config —cflags —libs libgnome-2.0 libgnomeui-2.0`
输入这条命令系统告诉我找不到libgnome-2.0和libgnomeui-2.0包
我想可能是gnome程序用到的包没有安装,但是找不到是那两个包


页首
 用户资料  
 
2 楼 
 文章标题 : OK 已经解决了 需要libgnome-desktop-dev和libgnomeui-dev
帖子发表于 : 2007-06-09 1:17 

注册: 2006-08-26 22:33
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
ok


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-06-10 12:07 

注册: 2006-04-22 5:05
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
和你遇到同样的问题,谢谢楼主自问自答,哈


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请问ubuntu下编译gnome程序需要用什么包
帖子发表于 : 2009-10-17 17:08 

注册: 2009-08-11 14:06
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我也遇到了同样的问题.谢谢楼主了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译