当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装java程序时遇到的无法找到库的错误,你们遇到过么?
帖子发表于 : 2007-06-10 22:27 

注册: 2007-04-30 9:48
帖子: 52
地址: 火星
送出感谢: 0 次
接收感谢: 0 次
类似下面这样的,即使使用了后来装的sun-6-java (jre1.6)也报同样的错误。
这些库文件其实都是在/lib下面有的,而且尝试过修改环境变量 CLASSPATH,加上了那个目录甚至是那些文件,安装时也报这样的错。

你们遇到过么?都是怎么解决的呢?
代码:
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
nawk: error while loading shared libraries: libm.so.6: cannot open shared object file: No such file or directory
dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
/bin/ls: error while loading shared libraries: librt.so.1: cannot open shared object file: No such file or directory
basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
hostname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

Launching installer...

grep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
/tmp/install.dir.18407/Linux/resource/jre/bin/java: error while loading shared libraries: libpthread.so.0: cannot open shared object file: No such file or directory
[/code]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-06-10 22:37 
头像

注册: 2006-05-19 21:23
帖子: 1277
送出感谢: 0 次
接收感谢: 0 次
你用什么样的 xxx.bin 去安装什么样的软件了?

这个问题是因为你用的那个.bin文件依赖使用Linux旧的线程库的问题!

参考这里的资料:在 Ubuntu Edgy 6.10 中成功安装 JBuilder 2006 Enterprise Edition !


_________________
其实我是一个演员!-http://blog.csdn.net/xport/


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-06-13 11:37 

注册: 2007-04-30 9:48
帖子: 52
地址: 火星
送出感谢: 0 次
接收感谢: 0 次
xport 写道:
你用什么样的 xxx.bin 去安装什么样的软件了?

这个问题是因为你用的那个.bin文件依赖使用Linux旧的线程库的问题!

参考这里的资料:在 Ubuntu Edgy 6.10 中成功安装 JBuilder 2006 Enterprise Edition !


是装 BEA tuxedo 9.1,用你给的参考资料上的做法装非常顺利。多谢了!

但是,太奇怪了。 这个安装包似乎是zip自解压文档,但是居然能用cat | sed方式去改掉,我用vi 自己去注释掉LD_ASSUME_KERNEL的设置,运行时却显示压缩包被破坏。

真难理解cat 是怎么工作的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-06-13 14:30 
头像

注册: 2006-05-19 21:23
帖子: 1277
送出感谢: 0 次
接收感谢: 0 次
cyberx 写道:
真难理解cat 是怎么工作的。


要深刻理解什么是 stream ...


_________________
其实我是一个演员!-http://blog.csdn.net/xport/


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-06-30 20:04 

注册: 2007-04-30 9:48
帖子: 52
地址: 火星
送出感谢: 0 次
接收感谢: 0 次
xport 写道:
cyberx 写道:
真难理解cat 是怎么工作的。


要深刻理解什么是 stream ...


为什么安装文件的ZIP格式在修改中未被伤害呢?这跟流有啥关系么?

为啥用vi修改就会破坏ZIP格式呢?


页首
 用户资料  
 
6 楼 
 文章标题 : ubuntu7.10安装JBuilder 2006成功!
帖子发表于 : 2007-11-04 20:43 

注册: 2007-11-02 23:43
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
1.创建文件夹
sudo mkdir /opt/JBE2006

2.将安装拷入/opt/JBE2006中
切换到/opt/JBE2006/Disk1/InstData/Linux/VM
cd /opt/JBE2006/Disk1/InstData/Linux/VM

3. 对安装文件进行备份
mv ./install.bin ./install.bin.borland

4.把原本安装文件中的LD_ASSUME_KERNEL操作注释掉,并写入新文件
cat ./install.bin.borland | sed "s/export LD_ASSUME_KERNEL/#xport LD_ASSUME_KERNEL/" > ./install.bin

5.赋予权限
chmod a+x ./install.bin

6.改写Shell提示符,以免Install AnyWhere报错
export PS1="> "

7.进行安装
sh /opt/JBE2006/Disk1/InstData/Linux/VM/install.bin LAX_VM /usr/lib/jvm/java-1.5.0-sun/jre/bin/java


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译