当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我在ubuntu下用的是eclipse3.2+jdk6.0,运行一段程序有错误,这是怎么回事?请帮助,谢过!
帖子发表于 : 2007-06-15 16:36 

注册: 2007-06-08 19:44
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
源程序如下:
package ni;
import java.awt.*;
public class ManualLayout {
public static void main(String args[]){
Frame f=new Frame("hello");
f.setLayout(null); //取消布局管理器
f.setSize(300,100); //宽300,高100
Button b=new Button("press me");
b.setSize(100,30); //宽100,高30
b.setLocation(40,60); //x坐标40,y坐标60
f.add(b);
f.setVisible(true);
}
}

提示的错误:
Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.7)
at java.awt.Window.<init>(libgcj.so.7)
at java.awt.Frame.<init>(libgcj.so.7)
at ni.ManualLayout.main(ManualLayout.java:5)
Caused by: java.lang.ClassNotFoundException: gnu.java.awt.peer.gtk.GtkToolkit
at java.lang.Class.forName(libgcj.so.7)
at java.lang.Class.forName(libgcj.so.7)
at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7)
...4 more


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-06-15 19:24 
头像

注册: 2006-06-27 16:37
帖子: 88
地址: china
送出感谢: 0 次
接收感谢: 0 次
你系统找到的jdk是gcj,换成sun的就好了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译