当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu下移植uClinux出现错误
帖子发表于 : 2007-06-19 11:20 

注册: 2007-06-19 11:04
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
各位高手好,小弟用的是ubuntu6.10版本。在移植uClinux时,不能使用make menuconfig和make xconfig进行配置,采用make config就可以,所有都采用默认配置后,使用make dep出错,出现以下信息:
** End of Linux kernel configuration.
*** Check the top-level Makefile for additional configuration.
*** Next, you must run 'make dep'.

root@zszz-desktop:/usr/src/uClinux-dist#make dep
make ARCH=armnommu CROSS_COMPLE=arm-elf- -c linux-2.4.x dep
make[1]:Enetering dictory'/usr/src/uClinux-dist/linux-2.4.x'
unset GCC_EXEC PREFIX:gcc-Wall-Wstrict-prototyes-02-fomit-frame-pointer -o scripts/mkdep scripts/mkdep.c
/bin/sh:gcc:command not found
make[1]:***[scripts/mkdep]Error 127
make[1]:Leaving dictory '/usr/src/uClinux-dist/linux-2.4.x'
make:***[dep]Error 2

我上网查了一下资料,有高手说修改了~/uClinux-dist/vendors/config/armnommu下的config.arch文件。把arm-linux都改成arm-elf就可以解决,但我试过,问题依然如故。不知道还有什么解决方法!
我是初学者,万望高手指点!(还有个比较弱智的问题,请问在这里发帖时怎么粘贴图片阿,我安了那个image好像没有什么反应)[/img]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-06-19 12:24 
头像

注册: 2007-06-12 17:22
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
引用:
/bin/sh:gcc:command not found
感觉好像是gcc命令找不到


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-06-19 20:48 

注册: 2007-06-19 11:04
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
那应该怎么解决呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译