[问题]为什么我的vi编辑c++程序时不能像红帽一样显示不同内容不同颜色?

C、C++和Java语言
回复
achen0001
帖子: 7
注册时间: 2007-05-29 10:52
送出感谢: 0
接收感谢: 0
联系:

[问题]为什么我的vi编辑c++程序时不能像红帽一样显示不同内容不同颜色?

#1

帖子 achen0001 » 2007-08-04 21:20

在红帽下,保留字等都是另外的鲜艳颜色显示的,我的ubuntu中vi为什么不能显示啊?是不是还是要设置什么啊?
头像
iblicf
帖子: 3766
注册时间: 2007-01-15 17:15
送出感谢: 0
接收感谢: 0

#2

帖子 iblicf » 2007-08-04 21:22

.vimrc

代码: 全选

set syn=cpp
syntax on


如果还是不亮,sudo apt-get install vim-full
上次由 iblicf 在 2007-08-04 21:26,总共编辑 1 次。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2007-08-04 21:23

先确定vim还是vim-tiny
● 鸣学
achen0001
帖子: 7
注册时间: 2007-05-29 10:52
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 achen0001 » 2007-08-05 17:39

怎么确定啊,我不知道啊,我用的是ubuntu7。04
那个设置能行不,我试试再贴上来吧!谢谢你们!
头像
titainium
帖子: 689
注册时间: 2006-12-02 12:25
送出感谢: 0
接收感谢: 0

#5

帖子 titainium » 2007-08-14 9:11

打开新立得,搜索VI,就知道你装的是什么了。
Titainium
fly520
帖子: 2
注册时间: 2007-10-18 19:03
送出感谢: 0
接收感谢: 0

#6

帖子 fly520 » 2007-10-21 21:47

要使用 Vim 的全部功能和关键字高亮显示,请在~/.vimrc 或/etc/vimrc 中添加如下内容:
set nocompatible
set nopaste
set pastetoggle=<f11>
syn on
cg19820811
帖子: 40
注册时间: 2007-04-09 15:30
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 cg19820811 » 2007-10-22 11:29

sudo apt-get install vim

:syntax enable
dotboy
帖子: 37
注册时间: 2006-11-01 15:10
送出感谢: 0
接收感谢: 0

#8

帖子 dotboy » 2007-10-23 23:06

是要在/etc/vim/下的文件vimrc中把syntax on前面的;给去掉
bdqx_007
帖子: 1
注册时间: 2007-10-30 21:45
送出感谢: 0
接收感谢: 0

#9

帖子 bdqx_007 » 2007-10-30 21:49

etc/vim/vimrc里面 加入 :

setsyn=cpp
syntax on
头像
AutumnHealth
帖子: 776
注册时间: 2006-12-20 18:41
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 AutumnHealth » 2007-10-30 22:31

代码: 全选

sudo apt-get install vim-full
尽情享受生活~

Welcome to AutumnHealth's blog:
http://forum.ubuntu.org.cn/weblog.php?w=1421
http://blog.csdn.net/autumnhealth
回复

回到 “C/C++/Java”