[问题]使用g++编译的通用性问题

C、C++和Java语言
回复
inputx
帖子: 4
注册时间: 2006-10-26 5:18
送出感谢: 0
接收感谢: 0

[问题]使用g++编译的通用性问题

#1

帖子 inputx » 2007-08-14 5:53

我在ubuntu6下用g++ 编译的helloworld 拿到 suse linux 10.2下无法运行,使用了chmod +x file 也不行 提示:

-bash: ./file: cannot execute binary file

都是linux怎么会这样, 应该如何用g++编译呢?
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 madoldman » 2007-08-14 9:31

gcc版本问题吧,用g++-3.4编译一下试试
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 nobrain » 2007-08-14 12:29

是不是程序要用到的库的问题?
爱喝真猪奶茶的夜鸣猪
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#4

帖子 stlxv » 2007-08-14 13:00

文件是否已损坏?具体完整的提示是什么?
PHP是最好的语言!不服来战!
回复

回到 “C/C++/Java”