当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装完成KDevelop后的错误,高手帮忙!!
帖子发表于 : 2007-08-30 19:02 

注册: 2007-08-28 20:59
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
安装完成后,在终端输入kdevelop,运行出错:
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 146
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 146
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 146
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 146
Minor opcode: 3
Resource id: 0x0
Failed to open device

该怎么解决阿?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-30 19:11 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
这个提示不是关键性的错误。。
只是由于 xorg.conf 里面的一段搞出来的,可以无视.....

如果真想改的话,要注释掉(似乎是一个手写板还是什么的设备....) :arrow:


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-08-30 21:13 

注册: 2007-08-28 20:59
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
安装xorg-dev后,现在错误为:
configure: error: Qt (>= Qt 3.2 and < 4.0) (headers and libraries) not found. Please check your installation!
天拉,编译一个程序这么复杂... 该怎么解决这个错误?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-08-30 21:19 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
wlxqy 写道:
安装xorg-dev后,现在错误为:
configure: error: Qt (>= Qt 3.2 and < 4.0) (headers and libraries) not found. Please check your installation!
天拉,编译一个程序这么复杂... 该怎么解决这个错误?


为什么你要去编译 KDevelop 呢?
直接用 apt 装不好么? :shock:


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-08-30 21:49 

注册: 2007-08-28 20:59
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
哈哈,编译成功拉........


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-08-30 21:54 

注册: 2007-08-28 20:59
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
编译成功,运行时候还是出现这个错误:
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 146
Minor opcode: 3
Resource id: 0x0
Failed to open device
但是,最后窗口还是可以显示出来...
这个问题怎么解决?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-08-30 22:01 
头像

注册: 2006-10-21 12:03
帖子: 1746
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
I figured out on some other threads that this is most likely due to some "wacom" devices in your xorg.conf. Be sure to comment them out in your xorg.conf (there were three such devices in mine). Also be sure to comment out the references to them in the ServerLayout section (one reference to each), otherwise X won't start up again. Here are the sections commented out:

其实可以无视~

编辑 /etc/X11/xorg.conf
注释掉关于“wacom”的部分。。。
代码:
# Section "InputDevice"
#  Driver        "wacom"
#  Identifier    "stylus"
#  Option        "Device"        "/dev/wacom"          # Change to
#                                                      # /dev/input/event
#                                                      # for USB
#  Option        "Type"          "stylus"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
#EndSection

#Section "InputDevice"
#  Driver        "wacom"
#  Identifier    "eraser"
#  Option        "Device"        "/dev/wacom"          # Change to
#                                                      # /dev/input/event
#                                                      # for USB
#  Option        "Type"          "eraser"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
#EndSection

#Section "InputDevice"
#  Driver        "wacom"
#  Identifier    "cursor"
#  Option        "Device"        "/dev/wacom"          # Change to
#                                                      # /dev/input/event
#                                                      # for USB
#  Option        "Type"          "cursor"
#  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
#EndSection

. . . and much farther down:
还有更加下面的:

代码:
Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
#       InputDevice     "stylus" "SendCoreEvents"
#       InputDevice     "cursor" "SendCoreEvents"
#       InputDevice     "eraser" "SendCoreEvents"
EndSection


_________________
.

私人空间
附有 Magic Linux 2.1 最新开发日志~
引用:


미안하다, 사랑한다




欢迎来 #xfce-cn 中文频道~~


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-08-31 8:56 

注册: 2007-08-15 8:45
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
WLXQY: 你好!
我也在试着使用KDevelop,但是到现在为止一个也没有成功。这是因为我在编译时出现了如下错误提示:configure: error: Can't find X libraries. Please check your installation and add the correct paths! 这个问题到现在没有解决。在此我想向你讨教你是如何设置你的编译环境的?能不能抽空帮我看看问题出在哪里? 谢谢!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-08-31 11:45 

注册: 2007-08-28 20:59
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
要装对应得库,你没安装吧,到网上搜索一下怎么安装.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译