当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]在线等 JAVA安装问题
帖子发表于 : 2007-08-31 21:09 

注册: 2007-08-31 21:00
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install java-*
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
注意,根据正则表达式“java-*”选中了 libhsqldb-java-doc
注意,根据正则表达式“java-*”选中了 libgnucrypto-java
注意,根据正则表达式“java-*”选中了 libmozillainterfaces-java
注意,根据正则表达式“java-*”选中了 libcommons-collections3-java
注意,根据正则表达式“java-*”选中了 libhsqldb-java-gcj
注意,根据正则表达式“java-*”选中了 libcommons-jxpath-java-doc
注意,根据正则表达式“java-*”选中了 libgnome-java
注意,根据正则表达式“java-*”选中了 libxml-im-exporter-java
注意,根据正则表达式“java-*”选中了 libkde3-java
注意,根据正则表达式“java-*”选中了 libvecmath1.2-java
注意,根据正则表达式“java-*”选中了 libsaxon-java
注意,根据正则表达式“java-*”选中了 libcairo-java-doc
注意,根据正则表达式“java-*”选中了 libjaxp1.2-java
注意,根据正则表达式“java-*”选中了 libjama-java
注意,根据正则表达式“java-*”选中了 lib-rxtx-java
注意,我选了 librxtx-java 而非 lib-rxtx-java
注意,根据正则表达式“java-*”选中了 libcommons-pool-java
注意,根据正则表达式“java-*”选中了 slice2javae
注意,根据正则表达式“java-*”选中了 libaxis-java
注意,根据正则表达式“java-*”选中了 libcairo-java-gcj
注意,根据正则表达式“java-*”选中了 libqt3-java
注意,根据正则表达式“java-*”选中了 liboro-java
注意,根据正则表达式“java-*”选中了 libdb4.3-java-dev
注意,根据正则表达式“java-*”选中了 libxpp3-java
注意,根据正则表达式“java-*”选中了 java2-runtime
注意,根据正则表达式“java-*”选中了 libsqlrelay-java
注意,根据正则表达式“java-*”选中了 vnc-java
注意,根据正则表达式“java-*”选中了 libtoolbar-java
注意,根据正则表达式“java-*”选中了 sun-java5-bin
注意,根据正则表达式“java-*”选中了 libdom1-java
注意,根据正则表达式“java-*”选中了 libwsdl4j-java-doc
注意,根据正则表达式“java-*”选中了 tightvnc-java
注意,根据正则表达式“java-*”选中了 libgconf-java-doc
注意,根据正则表达式“java-*”选中了 libbcmail-java
注意,根据正则表达式“java-*”选中了 libbackport-util-concurrent-java
注意,根据正则表达式“java-*”选中了 liblucene-java
注意,根据正则表达式“java-*”选中了 lib-readline-java-doc
注意,根据正则表达式“java-*”选中了 libgconf-java-gcj
注意,根据正则表达式“java-*”选中了 libbcprov-java-doc
注意,根据正则表达式“java-*”选中了 sun-java5-doc
注意,根据正则表达式“java-*”选中了 ia32-sun-java5-bin
注意,根据正则表达式“java-*”选中了 libpg-java
注意,根据正则表达式“java-*”选中了 libjunitperf-java
注意,根据正则表达式“java-*”选中了 liblasso-java
注意,根据正则表达式“java-*”选中了 ia32-sun-java5-plugin
注意,根据正则表达式“java-*”选中了 libbcprov-java-gcj
注意,根据正则表达式“java-*”选中了 libswt-gtk3-java
注意,根据正则表达式“java-*”选中了 libxt-java
注意,根据正则表达式“java-*”选中了 libgtk2-java
注意,根据正则表达式“java-*”选中了 libgetopt-java
注意,根据正则表达式“java-*”选中了 sun-java6-plugin
注意,根据正则表达式“java-*”选中了 openoffice.org-java-common
注意,根据正则表达式“java-*”选中了 libcommons-el-java
注意,根据正则表达式“java-*”选中了 java-runtime2
注意,根据正则表达式“java-*”选中了 sun-java6-demo
注意,根据正则表达式“java-*”选中了 libglib-java-doc
注意,根据正则表达式“java-*”选中了 libdtdparser-java
注意,根据正则表达式“java-*”选中了 libgtk0-java
注意,根据正则表达式“java-*”选中了 liblog4j1.2-java-doc
注意,根据正则表达式“java-*”选中了 sun-java5-jdk
注意,根据正则表达式“java-*”选中了 libglib-java-gcj
注意,根据正则表达式“java-*”选中了 libjcommon-java
注意,根据正则表达式“java-*”选中了 libconcurrent-java
注意,根据正则表达式“java-*”选中了 libxp-java
注意,根据正则表达式“java-*”选中了 liblog4j1.2-java-gcj
注意,根据正则表达式“java-*”选中了 libjfreechart-java-doc
注意,根据正则表达式“java-*”选中了 lib-xt-java
注意,根据正则表达式“java-*”选中了 libbcmail-java-doc
注意,根据正则表达式“java-*”选中了 libjaxme-java
注意,根据正则表达式“java-*”选中了 libgnujaxp-java
注意,根据正则表达式“java-*”选中了 libcommons-jexl-java
注意,根据正则表达式“java-*”选中了 libbcmail-java-gcj
注意,根据正则表达式“java-*”选中了 libeditline-java
注意,根据正则表达式“java-*”选中了 libocl-argo-java
注意,根据正则表达式“java-*”选中了 libjcalendar-java
注意,根据正则表达式“java-*”选中了 sun-java5-jre
注意,根据正则表达式“java-*”选中了 libjline-java-doc
注意,根据正则表达式“java-*”选中了 libregexp-java
注意,根据正则表达式“java-*”选中了 libdb-java
注意,根据正则表达式“java-*”选中了 libcommons-modeler-java
注意,根据正则表达式“java-*”选中了 libdb4.2-java-dev
注意,根据正则表达式“java-*”选中了 libjcalendar-java-doc
注意,根据正则表达式“java-*”选中了 libsvn-javahl
注意,根据正则表达式“java-*”选中了 libforms-java
注意,我选了 libjgoodies-forms-java 而非 libforms-java
注意,根据正则表达式“java-*”选中了 kdebindings-java
注意,根据正则表达式“java-*”选中了 libjaxp1.3-java-gcj
注意,根据正则表达式“java-*”选中了 libant1.6-java
注意,根据正则表达式“java-*”选中了 libcommons-discovery-java
注意,根据正则表达式“java-*”选中了 libcommons-io-java-doc
注意,根据正则表达式“java-*”选中了 libxt-java-gcj
注意,根据正则表达式“java-*”选中了 libavalon-framework-java-doc
注意,根据正则表达式“java-*”选中了 libsaxpath-java
注意,根据正则表达式“java-*”选中了 libxsltc-java-gcj
注意,根据正则表达式“java-*”选中了 libvte-java-doc
注意,根据正则表达式“java-*”选中了 java-runtime
注意,根据正则表达式“java-*”选中了 libvte-java-gcj
注意,根据正则表达式“java-*”选中了 libbuoy-java
注意,根据正则表达式“java-*”选中了 libbcpg-java-doc
注意,根据正则表达式“java-*”选中了 libdb4.4-java
注意,根据正则表达式“java-*”选中了 java-common
注意,根据正则表达式“java-*”选中了 liblog4j1.2-java
注意,根据正则表达式“java-*”选中了 libmx4j-java-gcj
注意,根据正则表达式“java-*”选中了 libbcpg-java-gcj
注意,根据正则表达式“java-*”选中了 libdcop3-java
注意,根据正则表达式“java-*”选中了 libdb4.2-java
注意,根据正则表达式“java-*”选中了 libbctsp-java
注意,根据正则表达式“java-*”选中了 libcommons-httpclient-java
注意,根据正则表达式“java-*”选中了 libjdom1-java
注意,根据正则表达式“java-*”选中了 openoffice.org-java
注意,根据正则表达式“java-*”选中了 libjlha-java-doc-ja
注意,根据正则表达式“java-*”选中了 libjcommon-java-doc
注意,根据正则表达式“java-*”选中了 liblogkit-java
注意,根据正则表达式“java-*”选中了 libswt3.2-gtk-java
注意,根据正则表达式“java-*”选中了 sun-java5-src
注意,根据正则表达式“java-*”选中了 libcommons-beanutils-java-doc
注意,根据正则表达式“java-*”选中了 libservlet2.4-java
注意,根据正则表达式“java-*”选中了 libfonts-java
注意,根据正则表达式“java-*”选中了 libcharva1-java
注意,根据正则表达式“java-*”选中了 libpixie-java
注意,根据正则表达式“java-*”选中了 libqdbm-java
注意,根据正则表达式“java-*”选中了 sun-java6-fonts
注意,根据正则表达式“java-*”选中了 java-gcj-compat-plugin
注意,根据正则表达式“java-*”选中了 libgtk-java-doc
注意,根据正则表达式“java-*”选中了 libswt2.1-gtk2-java
注意,根据正则表达式“java-*”选中了 libjfreechart-java
注意,根据正则表达式“java-*”选中了 libseda-java
注意,根据正则表达式“java-*”选中了 libglade-java
注意,根据正则表达式“java-*”选中了 libgtk-java-gcj
注意,根据正则表达式“java-*”选中了 libcommons-cli-java
注意,根据正则表达式“java-*”选中了 javalex
注意,根据正则表达式“java-*”选中了 java1-runtime1
注意,根据正则表达式“java-*”选中了 libtomcat5.5-java
注意,根据正则表达式“java-*”选中了 sun-java5-source
注意,根据正则表达式“java-*”选中了 libjgoodies-forms-java
注意,根据正则表达式“java-*”选中了 libxerces2-java-doc
注意,根据正则表达式“java-*”选中了 libpgjava
注意,根据正则表达式“java-*”选中了 glib-java
注意,根据正则表达式“java-*”选中了 libcrimson-java
注意,根据正则表达式“java-*”选中了 libxerces2-java-gcj
注意,根据正则表达式“java-*”选中了 coco-java
注意,根据正则表达式“java-*”选中了 libwerken.xpath-java
注意,根据正则表达式“java-*”选中了 libjcifs-java-doc
注意,根据正则表达式“java-*”选中了 libswt-gtk-3.2-java
注意,根据正则表达式“java-*”选中了 libmysql-java
注意,根据正则表达式“java-*”选中了 sun-java6-bin
注意,根据正则表达式“java-*”选中了 libjaxp1.2-java-gcj
注意,根据正则表达式“java-*”选中了 libxsltc-java
注意,根据正则表达式“java-*”选中了 ia32-sun-java6-plugin
注意,根据正则表达式“java-*”选中了 libpostgis-java
注意,根据正则表达式“java-*”选中了 libbcel-java
注意,根据正则表达式“java-*”选中了 javacc
注意,根据正则表达式“java-*”选中了 sun-java6-doc
注意,根据正则表达式“java-*”选中了 ia32-sun-java6-bin
注意,根据正则表达式“java-*”选中了 libpostgisjava
注意,根据正则表达式“java-*”选中了 libjavascript-rpc-perl
注意,根据正则表达式“java-*”选中了 monodevelop-java
注意,根据正则表达式“java-*”选中了 cairo-java
注意,根据正则表达式“java-*”选中了 libcairo-java
注意,根据正则表达式“java-*”选中了 libjunitperf-java-doc
注意,根据正则表达式“java-*”选中了 libcommons-io-java
注意,根据正则表达式“java-*”选中了 libjakarta-poi-java-doc
注意,根据正则表达式“java-*”选中了 libcommons-launcher-java
注意,根据正则表达式“java-*”选中了 java2html
注意,根据正则表达式“java-*”选中了 libjsch-java-doc
注意,根据正则表达式“java-*”选中了 libcommons-logging-java
注意,根据正则表达式“java-*”选中了 libsvn-java
注意,根据正则表达式“java-*”选中了 sun-java6-jdk
注意,根据正则表达式“java-*”选中了 libswt3.1-gtk-java
注意,根据正则表达式“java-*”选中了 libcommons-codec-java
注意,根据正则表达式“java-*”选中了 free-java-sdk
注意,根据正则表达式“java-*”选中了 libcommons-fileupload-java
注意,根据正则表达式“java-*”选中了 libgetenv-java
注意,根据正则表达式“java-*”选中了 liboscache-java
注意,根据正则表达式“java-*”选中了 libbcprov-java
注意,根据正则表达式“java-*”选中了 libitext-java
注意,根据正则表达式“java-*”选中了 libconcurrent-java-doc
注意,根据正则表达式“java-*”选中了 sun-java6-jre
注意,根据正则表达式“java-*”选中了 libgnumail-java
注意,根据正则表达式“java-*”选中了 openoffice.org2-java-common
注意,根据正则表达式“java-*”选中了 libjcifs-java
注意,根据正则表达式“java-*”选中了 libjaxp1.3-java
注意,根据正则表达式“java-*”选中了 libbsf-java
注意,根据正则表达式“java-*”选中了 libgef-java
注意,根据正则表达式“java-*”选中了 libtomcat5-java
注意,根据正则表达式“java-*”选中了 libjmock-java
注意,根据正则表达式“java-*”选中了 libreadline-java-doc
注意,根据正则表达式“java-*”选中了 libbcel-java-doc
注意,根据正则表达式“java-*”选中了 libicee-java
注意,根据正则表达式“java-*”选中了 libcommons-collections-java-doc
注意,根据正则表达式“java-*”选中了 libjgoodies-forms-java-doc
注意,根据正则表达式“java-*”选中了 libxml-commons-resolver1.1-java-doc
注意,根据正则表达式“java-*”选中了 libjts-java
注意,根据正则表达式“java-*”选中了 java-1-runtime
注意,根据正则表达式“java-*”选中了 libjgrapht-java
注意,根据正则表达式“java-*”选中了 libjdepend-java
注意,根据正则表达式“java-*”选中了 libextractor-java-dev
注意,根据正则表达式“java-*”选中了 libxpp2-java
注意,根据正则表达式“java-*”选中了 libxerces-java
注意,根据正则表达式“java-*”选中了 libcommons-net-java
注意,根据正则表达式“java-*”选中了 libextractor-java0
注意,根据正则表达式“java-*”选中了 slice2java
注意,根据正则表达式“java-*”选中了 libjline-java
注意,根据正则表达式“java-*”选中了 libcommons-dbcp-java
注意,根据正则表达式“java-*”选中了 entity-javascript
注意,根据正则表达式“java-*”选中了 libxerces2-java
注意,根据正则表达式“java-*”选中了 libbctsp-java-doc
注意,根据正则表达式“java-*”选中了 libjts-java-doc
注意,根据正则表达式“java-*”选中了 libestraier-java
注意,根据正则表达式“java-*”选中了 java-package
注意,根据正则表达式“java-*”选中了 libbctsp-java-gcj
注意,根据正则表达式“java-*”选中了 libslide-webdavclient-java
注意,根据正则表达式“java-*”选中了 sun-java6-src
注意,根据正则表达式“java-*”选中了 libcommons-daemon-java
注意,根据正则表达式“java-*”选中了 libglib-java
注意,根据正则表达式“java-*”选中了 java-gcj-compat
注意,根据正则表达式“java-*”选中了 sun-java6-source
注意,根据正则表达式“java-*”选中了 libglade-java-doc
注意,根据正则表达式“java-*”选中了 libservlet2.4-java-gcj
注意,根据正则表达式“java-*”选中了 libcommons-validator-java
注意,根据正则表达式“java-*”选中了 libglade-java-gcj
注意,根据正则表达式“java-*”选中了 libcommons-collections-java
注意,根据正则表达式“java-*”选中了 wipl-client-java
注意,根据正则表达式“java-*”选中了 libsapdbc7.5.01-java
注意,根据正则表达式“java-*”选中了 libcommons-modeler-java-doc
注意,根据正则表达式“java-*”选中了 libcommons-beanutils-java
注意,根据正则表达式“java-*”选中了 libjdom-java
注意,根据正则表达式“java-*”选中了 java-compiler
注意,根据正则表达式“java-*”选中了 libxalan2-java
注意,根据正则表达式“java-*”选中了 libasm-java-doc
注意,根据正则表达式“java-*”选中了 libnbio2-java
注意,根据正则表达式“java-*”选中了 libavalon-framework-java
注意,根据正则表达式“java-*”选中了 sun-java5-demo
注意,根据正则表达式“java-*”选中了 libstruts1.2-java
注意,根据正则表达式“java-*”选中了 libreadline-java
注意,根据正则表达式“java-*”选中了 libasm-java
注意,根据正则表达式“java-*”选中了 libsapdbc-java
注意,根据正则表达式“java-*”选中了 java2-compiler
注意,根据正则表达式“java-*”选中了 libjargs-java-doc
注意,根据正则表达式“java-*”选中了 java1-runtime
注意,根据正则表达式“java-*”选中了 libjargs-java
注意,根据正则表达式“java-*”选中了 libcommons-httpclient-java-doc
注意,根据正则表达式“java-*”选中了 libgnuinet-java
注意,根据正则表达式“java-*”选中了 libwsdl4j-java
注意,根据正则表达式“java-*”选中了 java-gcj-compat-dev
注意,根据正则表达式“java-*”选中了 libdb4.5-java-dev
注意,根据正则表达式“java-*”选中了 libzeroc-ice-java
注意,根据正则表达式“java-*”选中了 vtk-java
注意,根据正则表达式“java-*”选中了 librxtx-java
注意,根据正则表达式“java-*”选中了 libextractor-java
注意,根据正则表达式“java-*”选中了 libcommons-digester-java
注意,根据正则表达式“java-*”选中了 libdb4.5-java-gcj
注意,根据正则表达式“java-*”选中了 libdb-java-dev
注意,根据正则表达式“java-*”选中了 libnsuml-java
注意,根据正则表达式“java-*”选中了 libdb4.5-java
注意,根据正则表达式“java-*”选中了 libjakarta-poi-java
注意,根据正则表达式“java-*”选中了 libow-util-ant-tasks-java
注意,根据正则表达式“java-*”选中了 libjlha-java
注意,根据正则表达式“java-*”选中了 libdb4.3-java
注意,根据正则表达式“java-*”选中了 libhsqldb-java
注意,根据正则表达式“java-*”选中了 libpng-sixlegs-java
注意,根据正则表达式“java-*”选中了 libjzlib-java
注意,根据正则表达式“java-*”选中了 lib-editline-java
注意,根据正则表达式“java-*”选中了 libxml-commons-resolver1.1-java
注意,根据正则表达式“java-*”选中了 libjmock-java-doc
注意,根据正则表达式“java-*”选中了 libgtk-java
注意,根据正则表达式“java-*”选中了 libicu4j-java
注意,根据正则表达式“java-*”选中了 libjdom0-java
注意,根据正则表达式“java-*”选中了 libservlet2.3-java
注意,根据正则表达式“java-*”选中了 liblucene-java-doc
注意,根据正则表达式“java-*”选中了 libsnmp1.4-java
注意,根据正则表达式“java-*”选中了 libcommons-collections3-java-doc
注意,根据正则表达式“java-*”选中了 libi18n-java
注意,根据正则表达式“java-*”选中了 libcommons-lang-java
注意,根据正则表达式“java-*”选中了 libsablevm-classlib1-java
注意,根据正则表达式“java-*”选中了 libjessie-java
注意,根据正则表达式“java-*”选中了 postgresql-8.1-pljava
注意,我选了 postgresql-8.1-pljava-gcj 而非 postgresql-8.1-pljava
注意,根据正则表达式“java-*”选中了 postgresql-8.1-pljava-gcj
注意,根据正则表达式“java-*”选中了 libaxis-java-doc
注意,根据正则表达式“java-*”选中了 libjsch-java
注意,根据正则表达式“java-*”选中了 libjavascript-perl
注意,根据正则表达式“java-*”选中了 libgnome-java-doc
注意,根据正则表达式“java-*”选中了 lib-gnu.regexp-java
注意,根据正则表达式“java-*”选中了 libaxis-java-gcj
注意,根据正则表达式“java-*”选中了 libgnome-java-gcj
注意,根据正则表达式“java-*”选中了 sun-java5-fonts
注意,根据正则表达式“java-*”选中了 postgresql-postgis-java
注意,根据正则表达式“java-*”选中了 libgnome2-java
注意,根据正则表达式“java-*”选中了 sun-java5-plugin
注意,根据正则表达式“java-*”选中了 java-gcp-compat-dev
注意,根据正则表达式“java-*”选中了 libdb4.4-java-dev
注意,根据正则表达式“java-*”选中了 libnekohtml-java
注意,根据正则表达式“java-*”选中了 libforms-java-doc
注意,我选了 libjgoodies-forms-java-doc 而非 libforms-java-doc
注意,根据正则表达式“java-*”选中了 libgnome0-java
注意,根据正则表达式“java-*”选中了 sun-java6-javadb
注意,根据正则表达式“java-*”选中了 libgnujmi-java
注意,根据正则表达式“java-*”选中了 lib-readline-java
注意,根据正则表达式“java-*”选中了 libgconf-java
注意,根据正则表达式“java-*”选中了 java-virtual-machine
注意,根据正则表达式“java-*”选中了 libdb4.4-java-gcj
注意,根据正则表达式“java-*”选中了 libdcop3-java-dev
注意,根据正则表达式“java-*”选中了 libcommons-jxpath-java
注意,根据正则表达式“java-*”选中了 libitext-java-doc
注意,根据正则表达式“java-*”选中了 libmx4j-java
注意,根据正则表达式“java-*”选中了 libxalan2-java-doc
注意,根据正则表达式“java-*”选中了 libcrimson-java-doc
注意,根据正则表达式“java-*”选中了 libxalan2-java-gcj
注意,根据正则表达式“java-*”选中了 libbcpg-java
注意,根据正则表达式“java-*”选中了 librelaxng-datatype-java
注意,根据正则表达式“java-*”选中了 libvte-java
注意,根据正则表达式“java-*”选中了 libgnu-regexp-java
注意,根据正则表达式“java-*”选中了 libgnujaf-java
注意,根据正则表达式“java-*”选中了 libjaxen-java
注意,根据正则表达式“java-*”选中了 libsaxon-java-doc
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libdb4.2-java-dev: 冲突: libdb-java-dev
libdb4.3-java: 冲突: libdb-java
libdb4.3-java-dev: 冲突: libdb-java-dev
libdb4.4-java: 冲突: libdb-java
libdb4.4-java-dev: 冲突: libdb-java-dev
libdb4.5-java: 冲突: libdb-java
libdb4.5-java-dev: 冲突: libdb-java-dev
libjaxen-java: 冲突: libsaxpath-java 但是 1.0.0FCS-6 正要被安装
sun-java5-fonts: 冲突: ttf-lucida
sun-java6-fonts: 冲突: ttf-lucida
E: 无法安装的软件包


如上 我 不 明白那里 出错了 请大家指点下 刚刚 接触Ubuntu的


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-08-31 21:33 

注册: 2006-09-07 22:51
帖子: 849
送出感谢: 0 次
接收感谢: 0 次
可以试试:
sudo apt-get install sun-java6-jdk


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-01 2:36 
头像

注册: 2007-08-05 2:50
帖子: 182
送出感谢: 0 次
接收感谢: 0 次
LZ你打算安装什么、sudo apt-get install java 会是安装什么 ?
如果是JDK如 "wkt" 所说 sudo apt-get install sun-java6-jdk


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译