当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : g++ 001.cpp通不过??
帖子发表于 : 2007-09-24 12:54 

注册: 2007-08-28 2:00
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
刚刚开始用ubuntu,虽然装了G++ 和库文件 但编译
#include"iostream.h"
using namespace std;
int main()
{
cout<<"hello world"<<endl;
return 0;
}
却不行
我最先在终端输入:g++ 001.cpp
却出现:
z212152@z212152-desktop:~/Desktop$ g++ 001.cpp
在包含自 /usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/backward/iostream.h:31 的文件中,
从 001.cpp:1:
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/backward/backward_warning.h:32:2: 警告: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <iostream> instead of the deprecated header <iostream.h>. To disable this warning use -Wno-deprecated.
z212152@z212152-desktop:~/Desktop$
有没有那位高人指点一下亚 谢了 !!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-24 13:02 
头像

注册: 2006-11-08 16:50
帖子: 67
送出感谢: 0 次
接收感谢: 0 次
第一行 改成 #include <iostream>


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:fspc9527 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译