使用ljedit编译查看c++工程,附linux下的截图

C、C++和Java语言
回复
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

使用ljedit编译查看c++工程,附linux下的截图

#1

帖子 louis315 » 2007-10-03 14:13

总算有空重装了ubuntu, 直接安装了7.10 beta, 趁着新系统,测试了一个ljedit的安装包,原来依赖关系里少了libglademm-2.4-1c2a,现在修好了,不过现在还不清楚在7.04下是不是用的这个版本的libglademm。

现在放一下使用说明吧

1. 在7.10下启动ljedit:
方法一. 菜单-[应用程序]->[其它]->ljedit (在7.04里好像没有,看来我的ljedit.desktop文件位置不对吧)
方法二. 在terminal里输入ljedit

2.
现在来放几个linux下的截图吧:

图片

[imghttp://forum.ubuntu.org.cn/files/preview_15788.jpg[/img]

图片

图片

图片

图片

图片

图片

图片

图片


今天的安装包:http://ljedit.googlecode.com/files/ljed ... 7-10-3.deb

homepage : http://ljedit.googlecode.com
附件
main.jpg
preview.jpg
auto_complete.jpg
cpp_tip.jpg
quick_find.jpg
quick_jump.jpg
setup_cpp_env.jpg
find_jump.jpg
terminal.jpg
python_console.jpg
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#2

帖子 louis315 » 2007-10-03 14:15

对了,主页上还有winxp版本的,没有在空机器上测试过,不清楚少不少dll。

不过要先安装python-2.5.1和gtkmm运行环境, gtkmm运行环境在ljedit主页里b也有下载,要试用一下的朋友可以去下载
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2007-10-03 15:37

不错。

直接使用ctags吗???

没道理只支持到小白版本吧。
ljedit 依赖于 libglademm-2.4-1c2a (>= 2.6.4-0ubuntu3);然而:
系统中 libglademm-2.4-1c2a 的版本为 2.6.3-0ubuntu2。
● 鸣学
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#4

帖子 louis315 » 2007-10-03 22:33

;-) 因为我的ubuntu7.04升级内核时机器热死了,重装了系统,用的是7.10beta版本的,所以没有在7.04上编译啊。

ubuntu7.04肯定可以的,我以前就是在这个平台开发的,有空帮忙做个7.04的deb包吧?
我写好打deb包的脚本的,都在源码里,我想反正没几天7.10就出来了,呵…… 所以没有装7.04啊。其它linux我也还没有做打包.

没有使用ctags哦,语法解析之类的写了两年了,我自己写的,还没有完成,不过可以先用啦;-)
不错。

直接使用ctags吗???

没道理只支持到小白版本吧。
引用:
ljedit 依赖于 libglademm-2.4-1c2a (>= 2.6.4-0ubuntu3);然而:
系统中 libglademm-2.4-1c2a 的版本为 2.6.3-0ubuntu2。
头像
yexin218
帖子: 461
注册时间: 2007-08-22 17:36
来自: 澳门
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yexin218 » 2007-10-03 23:46

推荐eclipse+cdt
或者使用netbean
我很敏捷,我是网上的蜘蛛;我很茫然,我是网中的猎物!
欢迎到我的Blog※代码回音※
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2007-10-04 19:24

打包,不会。重来没想过打包。 :lol: 到irc找人帮忙?
● 鸣学
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#7

帖子 louis315 » 2007-10-05 12:01

昨天又打了个包 http://ljedit.googlecode.com/files/ljed ... 7-10-4.deb,把libglademm的版本依赖改为ubuntu2那个了,不知道能用不。

听取了 windwiny.ubt 的建议:
  * 添加了字体修改功能
  * ctrl+1,2,3,4,5,... 切换底部面板的功能。
  * F11全屏模式切换

可惜其它的,特别是 windwiny.ubt强烈建议的使用ctrl-tab切换文件的功能没找到方案实现... 谁用了gtk写程序就知道了,我没有试出来哦。。

打包很简单的,如果能编译ljedit的源码,编译完成后,进入 ljedit/build/ 目录,sudo ./make-deb就ok了。
头像
mikeandmore
帖子: 109
注册时间: 2005-10-13 18:29
送出感谢: 0
接收感谢: 0

#8

帖子 mikeandmore » 2007-12-11 20:33

牛人呀。。。。
用什么写的。。。
我想了很长时间也没有想到一个比较完美的c++parser。。。。
头像
shellex
帖子: 2180
注册时间: 2007-02-18 19:33
系统: OSX
来自: lyric.im
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 shellex » 2007-12-11 21:11

很棒。祝你成功
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#10

帖子 louis315 » 2007-12-17 22:30

:D 谢谢,我在努力
回复

回到 “C/C++/Java”