当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我没有装jre 为什么也能运行Eclipse
帖子发表于 : 2007-10-08 20:20 

注册: 2007-10-04 22:01
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
rt,咋回事捏……


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-08 21:24 
头像

注册: 2007-09-22 13:09
帖子: 188
送出感谢: 0 次
接收感谢: 0 次
我没在Ubuntu下玩过Eclipse

我只在windows下玩过,

我个人理解为:

Eclipse用到了java.exe程序,那么她在环境变量中已经将java.exe加入自己的路径,所以她能正常运行,

jre中文名字叫java运行环境(java run environment)

作用就是把与java想关联的程序与java.exe相关联起来,使它能执行。

我想在linux中应该也是相应的道理,要运行,必须得得到程序的路径,而Eclipse已经在安装时已经安装了jdk,也就是已经把java.exe程序的路径加入了自己的环境中,所以就能运行。

呵呵,


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-08 21:27 
头像

注册: 2006-01-19 11:55
帖子: 1114
地址: HUST
送出感谢: 0 次
接收感谢: 0 次
1,可能是安装了,你不知道而已,试试在终端运行
$java
2,也有可能可能是你eclipse目录下存在一个jre,也就是说有人给你把eclipse和jre打包在一起了。。


_________________
http://www.classfoo.org


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-08 22:37 

注册: 2007-10-04 22:01
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
谢谢newman0708和juanzhewudi的回复,

http://www.eclipse.org/downloads/上很明白地写着You will need a Java runtime environment (JRE) to use Eclipse (Java 5 JRE recommended). 借此我推测Eclipse是不会自己带一个jre的。

当时我没用 java-version,不过用新立得看了一下,确实一个jre都没装,然后顺手装了一个1.6的。

后来又看到有人提到了/ect/jvm,打开看了以下,里面有如下内容
# This file defines the default system JVM search order. Each
# JVM should list their JAVA_HOME compatible directory in this file.
# The default system JVM is the first one available from top to
# bottom.

/usr/lib/jvm/java-gcj
/usr/lib/jvm/ia32-java-1.5.0-sun
/usr/lib/jvm/java-1.5.0-sun
/usr

这些路径在我机器里都不存在,不过从修改时间上看,此文件应该是建立的时候就是这个内容,而没有被修改过。

我们总是被教育装jdk,设置环境变量,配置开发环境。真还没有在Windows底下不装jre跑过Eclipse。不过跑Eclipse不用配环境变量,这个我记得很清楚。

不知道的事情太多了……


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-09 9:41 
头像

注册: 2007-08-03 12:26
帖子: 83
送出感谢: 0 次
接收感谢: 0 次
ubuntu 本身就带gij.不装也可以 但是你在gij下编译的东西到了 sun-jre下不一定能跑

至于现在的D版windows 被人能上个jre 再正常不过了...


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-09 9:46 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
eclipse貌似自带了jre吧.


_________________
关注我的blog: ε==3


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-09 9:49 
头像

注册: 2007-08-03 12:26
帖子: 83
送出感谢: 0 次
接收感谢: 0 次
看他下的是什么版本 我下的jee版是不带的
all in one 可能带

2L说的很正确 ubuntu 的alternatives已经注册了系统自带的jdk
在windows下 安装jre 会写到注册表,这样不用classpath eclipse tomcat也识别


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-17 21:10 

注册: 2007-06-09 10:10
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
这要看你下载的是什么版本的eclipse了,一般是不带jre的,但是有的包帮你加了不少插件,当然有时也会把jre打包进去,这样方便解压后立即就能用。楼主的情况可能就是解压目录里已经有了jre了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译