当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]eclipse 3.3 不能正常启动
帖子发表于 : 2007-10-21 19:24 
头像

注册: 2006-09-19 7:17
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
我的系统是 ubuntu 7.10 ,eclipse 是从官方网站上下载的
启动eclipse出现的错误如下
JVM terminated. Exit code=13
/usr/bin/java
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-jar /opt/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
-os linux
-ws gtk
-arch x86
-showsplash
-launcher /opt/eclipse/eclipse
-name Eclipse
--launcher.library /opt/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.1.R33x_v20070828/eclipse_1020.so
-startup /opt/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
-exitdata 468047
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-jar /opt/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar


刚开始的时候我安装的jdk是6。0,看到错误后我就安装了jdk5。0,然后设置了一下,可是问题依旧,有没有哪位朋友遇到过同样的问题,还请指点!

附:
skychen@AMD64:~$ cat /etc/jvm
# This file defines the default system JVM search order. Each
# JVM should list their JAVA_HOME compatible directory in this file.
# The default system JVM is the first one available from top to
# bottom.

/usr/lib/jvm/java-1.5.0-sun
/usr/lib/jvm/ia32-java-1.5.0-sun
/usr/lib/jvm/java-6-sun
/usr/lib/jvm/java-gcj
/usr

skychen@AMD64:~$ sudo update-alternatives --config java
[sudo] password for skychen:

There are 4 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
+ 1 /usr/lib/jvm/java-6-sun/jre/bin/java
2 /usr/bin/gij-4.2
3 /usr/bin/gij-4.1
* 4 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

Press enter to keep the default[*], or type selection number:


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-21 21:08 

注册: 2007-08-16 22:42
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我曾在装了lomboz后启动不起来,后来,我设置了JAVA_HOME的环境变量后就好了,不知你是不是这个原因


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-21 21:15 
头像

注册: 2007-08-22 17:36
帖子: 461
地址: 澳门
送出感谢: 0 次
接收感谢: 0 次
echo $JAVA_HOME
看看环境配置
检查结果
java -version.
我的eclipse3.3好好的。 +cdt +swt+webwor+tomcat


_________________
我很敏捷,我是网上的蜘蛛;我很茫然,我是网中的猎物!
欢迎到我的Blog※代码回音※


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-12 20:19 

注册: 2007-11-09 18:57
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
这可能是eclipse选用了系统默认的JVM


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-12 21:36 

注册: 2007-11-02 10:46
帖子: 103
送出感谢: 0 次
接收感谢: 0 次
可以指定使用的jvm

代码:
eclipse -vm <jre location>


页首
 用户资料  
 
6 楼 
 文章标题 : [闲聊]
帖子发表于 : 2007-11-13 18:36 

注册: 2007-08-27 17:31
帖子: 445
送出感谢: 0 次
接收感谢: 1
资料不足,先看你是32位还是64的,我记得好像有分的,看你下的那个版本的eclipse
linux的软件管理一直不很直白,容易乱,有时候装着装着自己就不知道作了些什么,
这种问题遇到过几次,你先把JDK全部删了,然后重新装下eclipse,一般都没什么问题的!


_________________
你能学会世界上所有语言来叫一种鸟的名字,当你知道所有这些名字叫法后,却对这种鸟一无所知~
理查德-费曼


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译