用c和c++的朋友来试试puss源代码编辑器吧(更新:已发布ubuntu-8.10版本)

C、C++和Java语言
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

用c和c++的朋友来试试puss源代码编辑器吧(更新:已发布ubuntu-8.10版本)

#1

帖子 louis315 » 2007-10-23 14:32

时间很少,过了快一年了才放出新版本:
1. 重构了puss的架构,添加了插件机制
2. 增加了Ctrl+Tab切换文本的功能
3. Windows版本增加了Terminal插件,学习VConsole,使用cmd.exe终端。(linux下使用libvte之前就有)
4. 使用了新版本的gtk环境,win32环境中添加了python2.5,安装更方便了

未完成功能:
1. 本来打算使用lua做默认脚本引擎,但现在还没有完成
2. gdb调式插件准备使用C/或LUA重构,在win32下已可以暂停正在运行的程序了(之前一直被这个问题困扰)
3. 语法提示扩展也才开始重构(目前只支持c/c++)
4. 查找/替换对话框还没有做,这个会尽快(时间真的很难找哦)放出

现在的版本已经支持:
1. c++语法分析/提示,tab键自动补全
2. include 文件名补全
3. 鼠标点击进行tag定义预览
4. ctrl+鼠标点击打开#include文件及tag定位
5. 浏览代码时回退到上次浏览位置
6. 像gedit一样的 ctrl+K, ctrl+I的查找定位
7. 支持在当前文件/当前打开的所有文件/文件所在目录及子目录中搜索
8. 部分从gedit里移植过来的插件(如:python-console, terminal)

支持linux及windows系统

主页: http://ljedit.googlecode.com

下载:http://code.google.com/p/ljedit/downloads/list
上次由 louis315 在 2009-02-01 22:33,总共编辑 5 次。
dotboy
帖子: 37
注册时间: 2006-11-01 15:10
送出感谢: 0
接收感谢: 0

#2

帖子 dotboy » 2007-10-23 21:00

安装以后不能启动,是怎么回事?
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#3

帖子 windwiny » 2007-10-23 21:24

硬实是,依赖的 libgtksourceviewmm-2 好像有问题
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#4

帖子 louis315 » 2007-10-24 16:14

晕啊,我最怕的问题来了。。。 你们用的是ubuntu-7.10吗?

今天晚上我有空装个ubuntu-7.10的虚拟机,看看缺什么吧。。。 实在报歉,在我这儿没问题哦
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#5

帖子 louis315 » 2007-10-24 16:16

我用了:

gtk-2.4
gtkmm-2.4
python-gtk
libsourceview-2
libsourceviewmm-2
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#6

帖子 louis315 » 2007-10-24 16:16

我朋友帮我测过,说是运行正常的哦,晚上看看吧
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#7

帖子 windwiny » 2007-10-24 16:41

libsourceview-2
libsourceviewmm-2

?? 7.10 有这些软件包?
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#8

帖子 louis315 » 2007-10-24 23:10

刚才测试过了,原来是在做deb包时一个依赖项少了,是 libgtksourceviewmm-2.0 .


libsourceview-2
libsourceviewmm-2

?? 7.10 有这些软件包?

我打错了,是libgtksourceview-2.0和libgtksourceviewmm-2.0
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#9

帖子 louis315 » 2007-10-24 23:43

现在安装包已更新,喜欢的朋友来帮忙测试一下吧 ;-)
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#10

帖子 windwiny » 2007-10-25 2:11

没更新啊


发现依赖包没写完整,在control 依赖项里加入 libgtksourceviewmm-2.0-1 libgtkmm-2.4-1c2a 就可以了
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#11

帖子 louis315 » 2007-10-25 9:44

更新过了的,control文件如下:

Package: ljedit
Version: 1.0.0-0ubuntu1
Section: devel
Priority: optional
Architecture: i386
Depends: libgtksourceviewmm-2.0-1 (>= 1.9.2-0ubuntu1), python2.5 (>= 2.5), python-gtk2 (>= 2.10.4-0ubuntu3), libglade2-0 (>= 1:2.6.0-3), libglademm-2.4-1c2a (>= 2.6.3-0ubuntu2)
Installed-Size: 512
Maintainer: LJ Louis <louisliangjun@gmail.com>
Description: SourceEditor for C/C++
Homepage: http://ljedit.googlecode.com/

呵…… 可能是libgtksourceviewmm-2.0-1和以前的libgtksourcevie-2.0太像了,libgtksourceviewmm-2.0-1本身依赖于gtkmm-2.4,所以我就没有写上去哦

更新过的下载地址: http://ljedit.googlecode.com/files/ljed ... -10-24.deb
头像
blackiron
帖子: 887
注册时间: 2007-05-25 16:47
来自: 上海
送出感谢: 0
接收感谢: 0

#12

帖子 blackiron » 2007-10-26 21:25

谁开发的,我要去官网上看看
louis315
帖子: 86
注册时间: 2005-10-20 9:19
送出感谢: 0
接收感谢: 0

#13

帖子 louis315 » 2007-10-29 18:44

嘿^^ 我开发的, 正在学习和开发中, 有兴趣学glib,gtk相关的朋友可以看下源码,帮忙指正啊,我前几天才看了glib相关的资料和源码,前面都是随便用一下,所以源码里还有不少写的不好的地方呢。

如果有喜欢这个编辑器的朋友,能来帮忙啦!!可以用 c++和gtkmm 或是 python和pygtk 开发插件,或把gedit里喜欢的插件移植过来哦
头像
blackiron
帖子: 887
注册时间: 2007-05-25 16:47
来自: 上海
送出感谢: 0
接收感谢: 0

#14

帖子 blackiron » 2007-10-29 19:05

不错,支持你
Timo
帖子: 1
注册时间: 2007-10-30 1:33
送出感谢: 0
接收感谢: 0

#15

帖子 Timo » 2007-10-30 1:37

我想装来试,可惜刚学LIUNX,包依赖关系没搞定。装不上。新立得上也没有那些包。
回复

回到 “C/C++/Java”