gcc无法安装

C、C++和Java语言
回复
rhymery
帖子: 37
注册时间: 2006-01-10 13:51
送出感谢: 0
接收感谢: 0

gcc无法安装

#1

帖子 rhymery » 2006-01-11 18:54

rhymery@mercury:~$ sudo apt-get install gcc
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对问题的解决有所帮助:

下列的软件包有不能满足的依赖关系:
gcc: 依赖: gcc-4.0 (>= 4.0.1-2) 但是它将不会被安装
E: 无法安装的软件包
rhymery@mercury:~$ sudo apt-get install gcc gcc-4.0
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对问题的解决有所帮助:

下列的软件包有不能满足的依赖关系:
gcc-4.0: 依赖: gcc-4.0-base (= 4.0.1-4ubuntu9) 但是 4.0.2-3ubuntu1 正要被安装
依赖: cpp-4.0 (= 4.0.1-4ubuntu9) 但是 4.0.2-3ubuntu1 正要被安装
E: 无法安装的软件包
rhymery@mercury:~$ sudo apt-get install gcc gcc-4.0 gcc-4.0-base cpp-4.0
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
gcc-4.0-base 已经是最新的版本了。
cpp-4.0 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对问题的解决有所帮助:

下列的软件包有不能满足的依赖关系:
gcc-4.0: 依赖: gcc-4.0-base (= 4.0.1-4ubuntu9) 但是 4.0.2-3ubuntu1 正要被安装
依赖: cpp-4.0 (= 4.0.1-4ubuntu9) 但是 4.0.2-3ubuntu1 正要被安装
E: 无法安装的软件包
rhymery@mercury:~$
回复

回到 “C/C++/Java”