当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]jdk 怎么样都装不上去!!!差点崩溃了!!
帖子发表于 : 2007-11-25 9:40 
头像

注册: 2007-10-16 19:29
帖子: 296
送出感谢: 0 次
接收感谢: 0 次
java5,java6,都试了,还是不行,在新立得里面安装无任何错误提示,但结束后在终端里java -version的结果却是

名为 'java' 的程序可以在下列包中找到
* cacao
* j2re1.4
* kaffe
* jamvm
* java-gcj-compat
* gij-4.1
* gij-4.2
* sablevm
试试:sudo apt-get install <选定的软件包>
bash: java:找不到命令

这还不说,我安装netbeans时居然找不到JVM(这是主要目的),装不上,郁闷。然后下载了jdk-6u3-linux-i586-rpm.bin手动安装:

chmod a+x jdk-6u3-linux-i586-rpm.bin
sudo ./jdk-6u3-linux-i586-rpm.bin
一路空格后yes:

Unpacking...
Checksumming...
Extracting...
UnZipSFX 5.50 of 17 February 2002, by Info-ZIP (Zip-Bugs@lists.wku.edu).
inflating: jdk-6u3-linux-i586.rpm
inflating: sun-javadb-common-10.2.2-0.1.i386.rpm
inflating: sun-javadb-core-10.2.2-0.1.i386.rpm
inflating: sun-javadb-client-10.2.2-0.1.i386.rpm
inflating: sun-javadb-demo-10.2.2-0.1.i386.rpm
inflating: sun-javadb-docs-10.2.2-0.1.i386.rpm
inflating: sun-javadb-javadoc-10.2.2-0.1.i386.rpm
error: 依赖性检测失败:
/bin/basename 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/cat 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/cp 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/gawk 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/grep 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/ln 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/ls 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/mkdir 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/mv 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/pwd 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/rm 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/sed 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/sort 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/touch 被 jdk-1.6.0_03-fcs.i586 所需要
/usr/bin/cut 被 jdk-1.6.0_03-fcs.i586 所需要
/usr/bin/dirname 被 jdk-1.6.0_03-fcs.i586 所需要
/usr/bin/expr 被 jdk-1.6.0_03-fcs.i586 所需要
/usr/bin/find 被 jdk-1.6.0_03-fcs.i586 所需要
/usr/bin/tail 被 jdk-1.6.0_03-fcs.i586 所需要
/usr/bin/tr 被 jdk-1.6.0_03-fcs.i586 所需要
/usr/bin/wc 被 jdk-1.6.0_03-fcs.i586 所需要
/bin/sh 被 jdk-1.6.0_03-fcs.i586 所需要
Installing JavaDB
error: 依赖性检测失败:
/bin/sh 被 sun-javadb-core-10.2.2-0.1.i386 所需要

Done.
这里结束了就。java -version还是不行,netbeans仍然找不到JVM
那个兄弟作一下技术支持阿,可能都不用高手的






页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-25 19:31 

注册: 2007-08-27 17:31
帖子: 445
送出感谢: 0 次
接收感谢: 1
干吗下rpm的后缀啊,直接下bin后缀就好了!


_________________
你能学会世界上所有语言来叫一种鸟的名字,当你知道所有这些名字叫法后,却对这种鸟一无所知~
理查德-费曼


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-25 19:35 

注册: 2007-08-27 17:31
帖子: 445
送出感谢: 0 次
接收感谢: 1
jdk-6u3-linux-i586-rpm.bin
rpm包是不能直接安装在ubuntu上的,那是redhat提倡的安装形式,ubuntu是deb的!
不过java写的是可以直接安装的,但转成RPM就不能直接安装了

比如,我下的就是:jdk-6u2-linux-amd64.bin


_________________
你能学会世界上所有语言来叫一种鸟的名字,当你知道所有这些名字叫法后,却对这种鸟一无所知~
理查德-费曼


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-25 19:41 

注册: 2007-08-27 17:31
帖子: 445
送出感谢: 0 次
接收感谢: 1
安装有困难或是不会下安装文件的,看下这个地址!
http://forum.ubuntu.org.cn/viewtopic.php?t=90746


_________________
你能学会世界上所有语言来叫一种鸟的名字,当你知道所有这些名字叫法后,却对这种鸟一无所知~
理查德-费曼


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-25 21:11 
头像

注册: 2007-10-16 19:29
帖子: 296
送出感谢: 0 次
接收感谢: 0 次
谢谢LS的阿


_________________
cpu:Intel(R) Core(TM)2 Quad CPU Q6600
mem:2GB DDR2 800 *4
disk:ide320GB+(640GB+640GB)raid
video:Nvidia GTX 260+
network: Atheros AR8121/AR8113
monitor: BENQ FP92W
OS: ubuntu


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-25 21:24 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
我猜想你还不会用新立德软件包管理器


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-25 22:06 
头像

注册: 2007-10-16 19:29
帖子: 296
送出感谢: 0 次
接收感谢: 0 次
LS怎么说话的呢?不过为了装好JDK,忍了!不和你解释什么,咱是新手!照2楼的方法去下了bin版的,安装时没有弹出路径选项,也没有说什么错误,可说是一路顺利,装完后java -version还是老话:

名为 'java' 的程序可以在下列包中找到
* cacao
* j2re1.4
* kaffe
* jamvm
* java-gcj-compat
* gij-4.1
* gij-4.2
* sablevm
试试:sudo apt-get install <选定的软件包>
bash: java:找不到命令

我晕了,怎么就是不行呢?


_________________
cpu:Intel(R) Core(TM)2 Quad CPU Q6600
mem:2GB DDR2 800 *4
disk:ide320GB+(640GB+640GB)raid
video:Nvidia GTX 260+
network: Atheros AR8121/AR8113
monitor: BENQ FP92W
OS: ubuntu


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-25 22:23 
头像

注册: 2006-10-16 7:24
帖子: 624
地址: 安康/西安/广州
送出感谢: 0 次
接收感谢: 0 次
sudo update-alternatives --config java
sudo update-alternatives --config javac


_________________
读书取正,读易取变,读骚取幽,读庄取达,读汉文取坚,最有味卷中岁月。
与菊同野,与梅同疏,与莲同洁,与兰同芳,与海棠同韵,定自称花里神仙。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-25 22:32 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
pxw816 写道:
LS怎么说话的呢?不过为了装好JDK,忍了!不和你解释什么,咱是新手!照2楼的方法去下了bin版的,安装时没有弹出路径选项,也没有说什么错误,可说是一路顺利,装完后java -version还是老话:

名为 'java' 的程序可以在下列包中找到
* cacao
* j2re1.4
* kaffe
* jamvm
* java-gcj-compat
* gij-4.1
* gij-4.2
* sablevm
试试:sudo apt-get install <选定的软件包>
bash: java:找不到命令

我晕了,怎么就是不行呢?

你的操作告诉我你还没有安装,而且你说新立德软件包管理器也没有错误提示信息,这让猜你的操作可能是点选了jdk相关的软件包,标记安装,然后就推出新立德软件包管理器了。


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-25 22:37 
头像

注册: 2007-10-16 19:29
帖子: 296
送出感谢: 0 次
接收感谢: 0 次
stlxv 写道:
pxw816 写道:
LS怎么说话的呢?不过为了装好JDK,忍了!不和你解释什么,咱是新手!照2楼的方法去下了bin版的,安装时没有弹出路径选项,也没有说什么错误,可说是一路顺利,装完后java -version还是老话:

名为 'java' 的程序可以在下列包中找到
* cacao
* j2re1.4
* kaffe
* jamvm
* java-gcj-compat
* gij-4.1
* gij-4.2
* sablevm
试试:sudo apt-get install <选定的软件包>
bash: java:找不到命令

我晕了,怎么就是不行呢?

你的操作告诉我你还没有安装,而且你说新立德软件包管理器也没有错误提示信息,这让猜你的操作可能是点选了jdk相关的软件包,标记安装,然后就推出新立德软件包管理器了。


我不会那么近视,那么大的“应用”我会看不见?


_________________
cpu:Intel(R) Core(TM)2 Quad CPU Q6600
mem:2GB DDR2 800 *4
disk:ide320GB+(640GB+640GB)raid
video:Nvidia GTX 260+
network: Atheros AR8121/AR8113
monitor: BENQ FP92W
OS: ubuntu


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-25 22:41 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
pxw816 写道:
stlxv 写道:
pxw816 写道:
LS怎么说话的呢?不过为了装好JDK,忍了!不和你解释什么,咱是新手!照2楼的方法去下了bin版的,安装时没有弹出路径选项,也没有说什么错误,可说是一路顺利,装完后java -version还是老话:

名为 'java' 的程序可以在下列包中找到
* cacao
* j2re1.4
* kaffe
* jamvm
* java-gcj-compat
* gij-4.1
* gij-4.2
* sablevm
试试:sudo apt-get install <选定的软件包>
bash: java:找不到命令

我晕了,怎么就是不行呢?

你的操作告诉我你还没有安装,而且你说新立德软件包管理器也没有错误提示信息,这让猜你的操作可能是点选了jdk相关的软件包,标记安装,然后就推出新立德软件包管理器了。


我不会那么近视,那么大的“应用”我会看不见?
:roll: 直接也有不准的时候


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-26 11:02 
头像

注册: 2005-07-21 19:13
帖子: 681
地址: Peking, China
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get install sun-java6-jdk


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-11-27 21:49 

注册: 2007-08-27 17:31
帖子: 445
送出感谢: 0 次
接收感谢: 1
还是老样子吗?下载完,安装好后,把环境配置下,然后重新起电脑,环境才能起作用!
你在看下那个文章,看自己是否漏了什么没!


_________________
你能学会世界上所有语言来叫一种鸟的名字,当你知道所有这些名字叫法后,却对这种鸟一无所知~
理查德-费曼


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-11-27 21:50 

注册: 2007-08-27 17:31
帖子: 445
送出感谢: 0 次
接收感谢: 1
angelus@angelus-yylove:~$ java -version
java version "1.6.0_02"
Java(TM) SE Runtime Environment (build 1.6.0_02-b05)
Java HotSpot(TM) 64-Bit Server VM (build 1.6.0_02-b05, mixed mode)
angelus@angelus-yylove:~$


这是我的,你看你那步没弄好!


_________________
你能学会世界上所有语言来叫一种鸟的名字,当你知道所有这些名字叫法后,却对这种鸟一无所知~
理查德-费曼


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-12-21 12:19 

注册: 2007-11-13 1:11
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我喜欢下bin。自己配置环境。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译