当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:无法安装build-essential
帖子发表于 : 2007-11-27 18:32 

注册: 2007-11-09 8:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
gcc 编译时候,提示无法找到stdio.h,根据前人的帮助,安装build-essential,但是无法安装
提示为:
“kuchen@ubuntu:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.11ubuntu7 正要被安装
E: 无法安装的软件包”

恳请达人指点
多谢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-27 18:34 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
请先按照wiki里的快速设置指南设置好源


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-28 10:31 

注册: 2007-11-09 8:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
请先按照wiki里的快速设置指南设置好源

我当然把源设置好了阿!而且也更新了阿!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-28 10:32 

注册: 2007-11-09 8:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
请先按照wiki里的快速设置指南设置好源

但还是不行,提示还是上面的那些内容! :(


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-28 14:27 
头像

注册: 2006-02-27 20:19
帖子: 599
地址: works system
送出感谢: 0 次
接收感谢: 0 次
确认你的源设置的正确?版本对吗?


_________________
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-28 16:16 

注册: 2007-11-09 8:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
madoldman 写道:
确认你的源设置的正确?版本对吗?

谢谢,非常感谢,我在网上又重新找了个源,以前得源我也是在网上找得
以前更新也是用那个
这回重新找得源让我更新了很多
当然也又libc6 libc6-dev 和build-essential
最后问题解决了
谢谢达人帮忙!感激不尽 :D


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-28 16:58 
头像

注册: 2006-02-27 20:19
帖子: 599
地址: works system
送出感谢: 0 次
接收感谢: 0 次
晕,估计是以前的源版本不对


_________________
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-29 11:43 

注册: 2008-08-24 7:37
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
如果不能上网怎么办?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-09-08 13:31 

注册: 2007-12-17 20:12
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
引用:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
dpkg-dev g++ g++-4.3 libstdc++6-4.3-dev patch
建议安装的软件包:
debian-keyring g++-multilib g++-4.3-multilib gcc-4.3-doc libstdc++6-4.3-dbg
libstdc++6-4.3-doc diff-doc
下列【新】软件包将被安装:
build-essential dpkg-dev g++ g++-4.3 libstdc++6-4.3-dev patch
共升级了 0 个软件包,新安装了 6 个软件包,要卸载 0 个软件包,有 1 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 4778kB/5499kB 的软件包。
解压缩后会消耗掉 20.5MB 的额外空间。
您希望继续执行吗?[Y/n]y
错误 http://cn.archive.ubuntu.com intrepid/main libstdc++6-4.3-dev 4.3.2-0ubuntu3
无法解析域名“cn.archive.ubuntu.com”
错误 http://cn.archive.ubuntu.com intrepid/main g++-4.3 4.3.2-0ubuntu3
无法解析域名“cn.archive.ubuntu.com”
无法下载 http://cn.archive.ubuntu.com/ubuntu/poo ... 3_i386.deb 无法解析域名“cn.archive.ubuntu.com”
无法下载 http://cn.archive.ubuntu.com/ubuntu/poo ... 3_i386.deb 无法解析域名“cn.archive.ubuntu.com”
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?


我用的8。10谁能帮忙解决一下!!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 求助:无法安装build-essential
帖子发表于 : 2008-11-06 15:25 

注册: 2008-04-14 19:35
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我用的台湾的源,好像也不行,安装build-essential中也报同样错误,我检查了版本就是interprid(8.10),但是官方的源太慢了,好像最近不能访问,苏州的源也不能访问了,我用的是上海电信的ADSL :em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译