当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我今天用TOMCAT安装JIVE
帖子发表于 : 2007-12-16 21:25 
头像

注册: 2007-07-28 14:04
帖子: 214
送出感谢: 0 次
接收感谢: 0 次
我今天有TOMCAT安装JIVE的时候(JIVE的版本好像是3。1)的时候
就报错
报错信息如下
Jive Forums 3 Setup

Error: Can not proceed with Jive Forums setup.

Your current installation fails to meet minimum Jive Forums requirements - please see the checklist below:

1:At least JDK 1.3
2:Servlet 2.3 Support
3:JSP 1.1 Support
4:Jive Forums 3 Classes
5:Jive Home Directory - Not Set

Please read the installation documentation and try setting up your environment again. After making changes, restart your appserver and load this page again
1,2,3都没有错,就是4和5错了。
不知道为什么
我传上来的附件就是报错信息的截图!
麻烦大家帮帮忙看看,说说我哪里错了阿?
这里先谢了!


附件:
文件注释: 这个是错误信息
.jpg
.jpg [ 51.42 KiB | 被浏览 491 次 ]



_________________
我要去租车搜索www.517car.com
页首
 用户资料  
 
2 楼 
 文章标题 : 大家帮帮忙啊
帖子发表于 : 2007-12-16 21:36 
头像

注册: 2007-07-28 14:04
帖子: 214
送出感谢: 0 次
接收感谢: 0 次
The jiveHome directory
The jive_config.xml file does not exist in your jiveHome directory. Make sure the file is there an that the appserver has read access to the jiveHome directory.


就是在这步始终过去步到
说我的jiveHome这个目录里面没有jive_config.xml 这个文件
明明这里面有啊!
所以不知道为什么啊?
麻烦安过的朋友帮帮忙啊,指出我的错误啊
我的jive_init.xml的内容如下
<?xml version="1.0"?>
<!--
* Specifies the full path to your jiveHome directory.
* This file must be in the classpath of your application
* server. Normally, the easiest way to do this is to
* put it into the [jive]/WEB-INF/classes directory,
* where [jive] is the name of your Jive Forums web
* application.
*
* For unix this might be:
* <jiveHome> /var/web/jiveHome </jiveHome>
*
* For Windows this might be:
* <jiveHome> c:\web\jiveHome </jiveHome>
-->
<jiveHome> C:\Documents and Settings\Administrator\桌面\apache-tomcat-5.5.23\webapps\jive3\jiveHome </jiveHome>


web.xml的内容如下
<?xml version="1.0" encoding="ISO-8859-1"?>

<!-- Servlet 2.3 is required for Jive Forums 3 -->
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>
<display-name> Jive Forums 3 </display-name>
<description> Forum application by Jive Software (jivesoftware.com) </description>
<!--
Uncomment the following context-param section to specify your
jiveHome location in this file. Setting the value here will override
the value in jive_init.xml.

For unix the param value might be:
/var/web/jiveHome

For Windows this might be:
c:\web\jiveHome

Please note that spaces in the path *might* fail. For example on Windows:
c:\Program Files\...
may not work whereas:
c:\progra~1\..
will work.
-->

<context-param>
<param-name> jiveHome </param-name>
<param-value> C:\Documents and Settings\Administrator\桌面\apache-tomcat-5.5.23\webapps\jive3\jiveHome </param-value>
</context-param>


<!-- Filters -->
<filter>
<filter-name> Set Character Encoding </filter-name>
<filter-class> com.jivesoftware.util.SetCharacterEncodingFilter </filter-class>
</filter>
<filter>
<filter-name> PresenceFilter </filter-name>
<filter-class> com.jivesoftware.base.presence.PresenceFilter </filter-class>
</filter>
<filter>
<filter-name> SetupFilter </filter-name>
<filter-class> com.jivesoftware.util.JiveSetupFilter </filter-class>
</filter>

<!-- Filter mappings -->
<filter-mapping>
<filter-name> Set Character Encoding </filter-name>
<url-pattern> /* </url-pattern>
</filter-mapping>
<filter-mapping>
<filter-name> PresenceFilter </filter-name>
<url-pattern> *.jspa </url-pattern>
</filter-mapping>
<filter-mapping>
<filter-name> SetupFilter </filter-name>
<url-pattern> /index.jspa </url-pattern>
</filter-mapping>

<!-- Listeners -->
<listener>
<listener-class> com.jivesoftware.base.presence.PresenceListener </listener-class>
</listener>

<!-- Servlets -->
<servlet>
<servlet-name> JiveServlet </servlet-name>
<servlet-class> com.jivesoftware.forum.util.JiveServlet13 </servlet-class>
<load-on-startup> 1 </load-on-startup>
</servlet>
<servlet>
<servlet-name> action </servlet-name>
<servlet-class> com.jivesoftware.webwork.dispatcher.ServletDispatcher </servlet-class>
<load-on-startup> 1 </load-on-startup>
</servlet>

<!-- Migration servlet -->
<!-- This servlet (and its mappings) is diabled by default. If you are upgrading -->
<!-- from Jive 2.x, it is recommended to enable this servlet. This will -->
<!-- servlet will automatically translate calls for Jive 2.x pages to -->
<!-- Jive 3.x pages, ie: forum.jsp?forum=1 to forum.jspa?forumID=1 -->
<!--
<servlet>
<servlet-name> migration </servlet-name>
<servlet-class> com.jivesoftware.forum.util.MigrationServlet </servlet-class>
<init-param>
<param-name> properties </param-name>
<param-value> jive-forums-mappings.properties </param-value>
</init-param>
<load-on-startup> 10 </load-on-startup>
</servlet>
-->

<!-- Servlet mappings -->
<servlet-mapping>
<servlet-name> JiveServlet </servlet-name>
<url-pattern> /servlet/JiveServlet/* </url-pattern>
</servlet-mapping>
<servlet-mapping>
<servlet-name> action </servlet-name>
<url-pattern> *.jspa </url-pattern>
</servlet-mapping>
<!-- Migration servlet mappings commented out by default (see note above) -->
<!--
<servlet-mapping>
<servlet-name> migration </servlet-name>
<url-pattern> /index.jsp </url-pattern>
</servlet-mapping>
<servlet-mapping>
<servlet-name> migration </servlet-name>
<url-pattern> /forum.jsp </url-pattern>
</servlet-mapping>
<servlet-mapping>
<servlet-name> migration </servlet-name>
<url-pattern> /thread.jsp </url-pattern>
</servlet-mapping>
<servlet-mapping>
<servlet-name> migration </servlet-name>
<url-pattern> /search.jsp </url-pattern>
</servlet-mapping>
<servlet-mapping>
<servlet-name> migration </servlet-name>
<url-pattern> /profile.jsp </url-pattern>
</servlet-mapping>
-->

<!-- Welcome file list -->
<welcome-file-list>
<welcome-file> index.jspa </welcome-file>
<welcome-file> index.jsp </welcome-file>
<welcome-file> index.html </welcome-file>
</welcome-file-list>

<!-- tag lib definitions -->
<taglib>
<taglib-uri> webwork </taglib-uri>
<taglib-location> /WEB-INF/lib/jivebase.jar </taglib-location>
</taglib>
<taglib>
<taglib-uri> jivetags </taglib-uri>
<taglib-location> /WEB-INF/lib/jiveforums.jar </taglib-location>
</taglib>
</web-app>


麻烦大家帮帮忙啊,看看哪里没有设置对啊!


_________________
我要去租车搜索www.517car.com


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译