NetBeans 6.0 有谁在用么?

C、C++和Java语言
halve
帖子: 45
注册时间: 2005-09-09 11:32
送出感谢: 0
接收感谢: 0

NetBeans 6.0 有谁在用么?

#1

帖子 halve » 2007-12-17 9:56

好像不是很稳定???

调试跑到
if (fread(src, sizeof(src[0]), sizeof(src), funisrc) != -1) {
...
}
竟然就挂掉了?

本来还想夸2句,使用界面,以及自动补全的功能还不错的。。。
头像
fortruth
帖子: 1795
注册时间: 2005-11-06 1:51
来自: 七彩云世界
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 fortruth » 2007-12-17 12:36

好像还是beta版吧。 !
佛出寺,求索真世界 For_Truth:Free_Open_Share
OPEN GPG KEY:03D18D95
头像
hubert_star
论坛版主
帖子: 5372
注册时间: 2007-10-29 22:12
系统: OSX 10.9 + Ub 1304
来自: 江苏南京
送出感谢: 0
接收感谢: 5 次

#3

帖子 hubert_star » 2007-12-17 12:40

正式版也出来了

我刚用就给扔了,说说话,sun真不是做ide的料

我感觉eclipse一系的swt要好多了,不论是界面还是字体,纯粹的swing做界面还是不如swt好看。

在从功能上面说,netbeans增加的一些智能功能还真不错,比eclipse要好一点,但是我受不了netbeans的“模块开启中...”
佛经说,人有八苦: 生、老、病、死、求不得、怨憎、爱别离、五阴盛 故我苦!
圣经说,人有七罪: 饕餮、贪婪、懒惰、淫欲、傲慢、嫉妒和暴怒  故我有罪!

我这篇帖子里面没有任何攻击我们伟大的中华人民共和国政府和任劳任怨的人民公仆(和本论坛高素质的版主)的文字和含义;

特此声明!

有些事,我们明知道是错的,也要去坚持,因为不甘心;有些人,我们明知道是爱的,也要去放弃,因为没结局;有时候,我们明知道没路了,却还在前行,因为习惯了。

欢迎来我的新浪微博@me
头像
猛将兄
帖子: 2052
注册时间: 2005-10-19 17:33
送出感谢: 0
接收感谢: 0

#4

帖子 猛将兄 » 2007-12-17 13:19

你自己的core dump吧
不過eclipse也不怎麽樣,對于C還是用emacs+gdb,別的都不行
我現在寫java就用netbeans,eclipse也不錯,只是感覺netbeans 6.0更舒服一點
头像
bird
帖子: 765
注册时间: 2006-09-04 10:45
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 bird » 2007-12-17 13:23

任何事物都要有个发展过程,NetBeans也一样,大家还是宽容一点比较好吧……

至于eclipse,刚出道的时候,也没有现在这么好用,国内基本上都是到2.x以后才开始慢慢流行起来的。

2个IDE都是很优秀的东东,个人喜好就OK;

要想发牢骚或提建议或捉BUG,本人极力推荐netbeans.org或gceclub !!


----------------------------------------------------------------

根据楼下意见,特地修改一次,以免引起口水仗,hoho~~

----------------------------------------------------------------
上次由 bird 在 2007-12-17 13:47,总共编辑 3 次。
头像
hubert_star
论坛版主
帖子: 5372
注册时间: 2007-10-29 22:12
系统: OSX 10.9 + Ub 1304
来自: 江苏南京
送出感谢: 0
接收感谢: 5 次

#6

帖子 hubert_star » 2007-12-17 13:31

楼上说的对是对

但是这个论坛也不应该程序专用于ubuntu的论坛,实际上有些bug确实要对应到ubuntu上面,比如themes与gtk不兼容的现象,这这里有人给出解决办法岂不更好?

很多人用ide也都是在ubuntu下用,觉得那个舒服出来说一下也不应该有什么忌讳
佛经说,人有八苦: 生、老、病、死、求不得、怨憎、爱别离、五阴盛 故我苦!
圣经说,人有七罪: 饕餮、贪婪、懒惰、淫欲、傲慢、嫉妒和暴怒  故我有罪!

我这篇帖子里面没有任何攻击我们伟大的中华人民共和国政府和任劳任怨的人民公仆(和本论坛高素质的版主)的文字和含义;

特此声明!

有些事,我们明知道是错的,也要去坚持,因为不甘心;有些人,我们明知道是爱的,也要去放弃,因为没结局;有时候,我们明知道没路了,却还在前行,因为习惯了。

欢迎来我的新浪微博@me
sam1860
帖子: 312
注册时间: 2006-10-28 11:05
送出感谢: 0
接收感谢: 0

#7

帖子 sam1860 » 2007-12-17 13:49

swing与scim有冲突,因此swing based的软件都不能用 :evil:
google drive client for linux 下载
---------------------------------------------------------------
项目|9918视频秀
CentOS, Nginx, Java, C++, Go, MySQL, Redis
头像
bird
帖子: 765
注册时间: 2006-09-04 10:45
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 bird » 2007-12-17 13:57

7楼的言重了~~呵呵
sam1860
帖子: 312
注册时间: 2006-10-28 11:05
送出感谢: 0
接收感谢: 0

#9

帖子 sam1860 » 2007-12-17 14:07

http://bugs.sun.com/bugdatabase/view_bu ... id=6506617

我是由于此原因才放弃了freemind, netbeans。这个问题我2年多前就遇到,一直到几个星期前试了还是有此问题

我用五笔实在找不到代替品,没办法
google drive client for linux 下载
---------------------------------------------------------------
项目|9918视频秀
CentOS, Nginx, Java, C++, Go, MySQL, Redis
头像
mikeandmore
帖子: 109
注册时间: 2005-10-13 18:29
送出感谢: 0
接收感谢: 0

#10

帖子 mikeandmore » 2007-12-17 22:05

我用。。。
头像
tipfoo
帖子: 303
注册时间: 2007-07-12 16:30
来自: 桂林
送出感谢: 0
接收感谢: 2 次

#11

帖子 tipfoo » 2007-12-17 22:27

我在用。。。NetBeans6开发网站感觉非常的不错,从Eclipse转来。。。
mathgl
帖子: 51
注册时间: 2007-10-24 17:05
来自: 中国
送出感谢: 0
接收感谢: 0

#12

帖子 mathgl » 2007-12-18 0:49

我正在用 netbean 6.0 + scim 没有什么问题

在everest .05下
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#13

帖子 stlxv » 2007-12-18 0:53

sam1860 写了:swing与scim有冲突,因此swing based的软件都不能用 :evil:
我一直用scim,从来没遇到你说的这个问题
PHP是最好的语言!不服来战!
foreversky12
帖子: 12
注册时间: 2007-12-20 20:12
送出感谢: 0
接收感谢: 0

#14

帖子 foreversky12 » 2007-12-25 20:44

Java7将会有重大改变, eclipse 将会疲于奔命,毕竟还是自家的东西好,我在eclipse下脸“foreach“循环都用不了,
halve
帖子: 45
注册时间: 2005-09-09 11:32
送出感谢: 0
接收感谢: 0

#15

帖子 halve » 2007-12-27 17:46

调试还是 GNU 家自己的 emacs 用起来舒服
暂时是这样滴:
vim 编辑,make
emacs 调试
争取慢慢离开 vim ,完全在 emacs 下工作
回复

回到 “C/C++/Java”