[问题]快疯了,还是无法安装anjuta,望各位指点一二。多谢

C、C++和Java语言
回复
csmoskain
帖子: 6
注册时间: 2007-07-14 12:47
来自: 上海
送出感谢: 0
接收感谢: 0

[问题]快疯了,还是无法安装anjuta,望各位指点一二。多谢

#1

帖子 csmoskain » 2007-12-21 3:01

anjuta: 依赖: graphviz 但却无法安装它
依赖: libapr1 但却无法安装它
依赖: libaprutil1 但却无法安装它
依赖: libdevhelp-1-0 (>= 0.13) 但却无法安装它
依赖: libsvn1 (>= 1.4) 但却无法安装它
E: 无法安装的软件包

我不知道上述问题如何解决,首先安装graphviz的时候就说该包已经不存在了,我狂汗阿~是不是装系统的时候有差池?
其他的我也不知道怎么办了。
还有,在新立德里安装时都说有其他的软件包冲突,我只装了个JDK啊,还是按照SUN官方的方法。想到这里还是狂晕。
lmjalex
帖子: 17
注册时间: 2007-09-10 9:44
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 lmjalex » 2007-12-21 9:55

下载2.2.2的源码,自己编译吧。
http://www.sourceforge.net/projects/anjuta
chencmao
帖子: 43
注册时间: 2007-11-22 19:05
送出感谢: 0
接收感谢: 0

#3

帖子 chencmao » 2007-12-21 11:17

同病相怜阿,我是下载的源码包,自己编译安装时也出现问题:

代码: 全选

tony@tony-laptop:~$ cd /usr/local/anjuta-2.3.1/
tony@tony-laptop:/usr/local/anjuta-2.3.1$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
...
...
checking for GLIB... yes
checking for GOBJECT... yes
checking for GMODULE... yes
checking for GTHREAD... yes
checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.8.0) were not met:

No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
我就不知道了我是GNOME环境,怎会没有GTK呢?
chencmao
帖子: 43
注册时间: 2007-11-22 19:05
送出感谢: 0
接收感谢: 0

#4

帖子 chencmao » 2007-12-21 11:20

另外,楼主看过这帖没:
viewtopic.php?t=79137
不知道能解决你的问题不,反这没解决我的问题。
chencmao
帖子: 43
注册时间: 2007-11-22 19:05
送出感谢: 0
接收感谢: 0

#5

帖子 chencmao » 2007-12-21 11:32

利用楼主的地方再罗嗦下,我在anjuta之前想用eclipse+CDT来着,弄好了环境,可以build,但运行时说:

代码: 全选

Launch failed no binaries!
我已经装了gcc、g++、autogen、 automake、 build-essential、 indent和intltool了。

顶起顶起,希望有热心人能解答。。。
csmoskain
帖子: 6
注册时间: 2007-07-14 12:47
来自: 上海
送出感谢: 0
接收感谢: 0

#6

帖子 csmoskain » 2007-12-21 14:44

问题已经解决。
总结下:
1)长年在MW平台上操作,转到LX时候把在WM平台上从不更新的坏习惯带了过来。由于荷兰寄来的710有问题导致无法安装,我只能选择时间较早的701版本,刚装完后许多包是没有的,也就是更本无法满足依赖关系。在一次更新后,就可以安装了。
2)Ubnutu在教育网咋就不设个服务器呢?我在学校就是没办法更新,毕竟从事教育或学习这方面的人还是比较多的阿。回家之后更新这个问题才得以解决。这才让我意识到更新的重要性。
3)Ubuntu需要走的路还很长啊~大家一起努力吧。就个人而言,使用下来的感受并没有想象中的那么坏。包括SCIM的输入法,就合GOOGLE差不多了。总有一天,那3个小人组成的环会象太阳一样耀眼的。
csmoskain
帖子: 6
注册时间: 2007-07-14 12:47
来自: 上海
送出感谢: 0
接收感谢: 0

#7

帖子 csmoskain » 2007-12-21 14:46

lmjalex 写了:下载2.2.2的源码,自己编译吧。
http://www.sourceforge.net/projects/anjuta
谢谢哥哥,我在第一次更新完系统之后就能够从“添加/删除”里面直接安装了。还是感谢!
halve
帖子: 45
注册时间: 2005-09-09 11:32
送出感谢: 0
接收感谢: 0

#8

帖子 halve » 2007-12-21 15:39

csmoskain 写了:问题已经解决。
总结下:
1)长年在MW平台上操作,转到LX时候把在WM平台上从不更新的坏习惯带了过来。由于荷兰寄来的710有问题导致无法安装,我只能选择时间较早的701版本,刚装完后许多包是没有的,也就是更本无法满足依赖关系。在一次更新后,就可以安装了。
2)Ubnutu在教育网咋就不设个服务器呢?我在学校就是没办法更新,毕竟从事教育或学习这方面的人还是比较多的阿。回家之后更新这个问题才得以解决。这才让我意识到更新的重要性。
3)Ubuntu需要走的路还很长啊~大家一起努力吧。就个人而言,使用下来的感受并没有想象中的那么坏。包括SCIM的输入法,就合GOOGLE差不多了。总有一天,那3个小人组成的环会象太阳一样耀眼的。
1) 硬盘安装好了
2) 教育网不是有个 sjtu 的服务器么?那速度飕飕的~
3) 好像 scim 的作者现在就在 google 。。。
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#9

帖子 bones7456 » 2007-12-21 16:04

教育网的源不少哦~
关注我的blog: ε==3
chencmao
帖子: 43
注册时间: 2007-11-22 19:05
送出感谢: 0
接收感谢: 0

#10

帖子 chencmao » 2007-12-21 16:06

我也搞定,包之间的依赖搞得我头都大了, 还好总算能跑起来了。
elipse+CDT还是不错的说,哈哈
anjuta莫名奇妙的装了个1.2.4,自己下的2.3.1没编译成功,说是gdl-gnome没法找到,哎,至少还有eclipse好用
azhwhy
帖子: 60
注册时间: 2007-11-06 11:21
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 azhwhy » 2007-12-27 13:05

源里有,不过要想装2.2.2需要加个源,看这个
viewtopic.php?p=553020#553020
halve
帖子: 45
注册时间: 2005-09-09 11:32
送出感谢: 0
接收感谢: 0

#12

帖子 halve » 2007-12-27 18:35

如果说不是为了专门研究 anjuta 的话
完全可以去 netbeans 官网下个免安装包的程序下来,直接就能用了,免得麻烦
longforfreedom
帖子: 36
注册时间: 2006-11-15 19:02
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 longforfreedom » 2008-01-19 18:44

SCIM的作者现在在google,也是从事于linux的开发,不过不知道什么时候google的输入法有linux版 的
回复

回到 “C/C++/Java”