当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]xubuntu如何配jdk
帖子发表于 : 2007-12-22 23:58 

注册: 2007-12-22 23:47
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我的xubuntu7.10不联网,从sun下的 jdk-6u3-linux-i586.bin,安装在/home/xxx/java下,然后在/etc/profile设置的JAVA_HOME, PATH和CLASS_PATH,之前用ubuntu6.06时这样做是没有问题的,但现在在xubuntu7.10上就不行,请问怎么解决


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-23 0:27 
头像

注册: 2007-10-16 19:29
帖子: 296
送出感谢: 0 次
接收感谢: 0 次
错误信息?


_________________
cpu:Intel(R) Core(TM)2 Quad CPU Q6600
mem:2GB DDR2 800 *4
disk:ide320GB+(640GB+640GB)raid
video:Nvidia GTX 260+
network: Atheros AR8121/AR8113
monitor: BENQ FP92W
OS: ubuntu


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-23 1:28 

注册: 2007-12-22 23:47
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
在terminal输java -version结果如下

xxx@xxx:~$ java -version
名为 'java' 的程序可以在下列包中找到
* cacao (You will have to enable component called 'universe')
* j2re1.4 (You will have to enable component called 'multiverse')
* kaffe (You will have to enable component called 'universe')
* jamvm (You will have to enable component called 'universe')
* java-gcj-compat
* gij-4.1 (You will have to enable component called 'universe')
* gij-4.2
* sablevm (You will have to enable component called 'universe')
试试:sudo apt-get install <选定的软件包>
bash: java:找不到命令


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-23 15:50 

注册: 2007-12-22 23:47
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
还是要配的

在/etc/profile中添加的是如下几行:

JAVA_HOME=/home/xxx/java/jdk1.6.0_03
export PATH=$JAVA_HOME/bin:$PATH
export CLASSPATH=.:$JAVA_HOME/lib/tools.jar

谢谢各位!周末愉快!预祝圣诞快乐!新年快乐!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译