安装eclipse3.1.2时,遇到的gij-4.0的问题.

C、C++和Java语言
回复
Alonso
帖子: 60
注册时间: 2006-01-15 16:51
送出感谢: 0
接收感谢: 0

安装eclipse3.1.2时,遇到的gij-4.0的问题.

#1

帖子 Alonso » 2006-02-19 10:34

在安装eclipse3.1.2时,sdk和wtp,jdt都安好了,启动时,出现了不能启动,原因为:
org.eclipse.jst.servlet.ui......不能启动.
打开系统监视器,eclipse的java占用CPU达到70左右,并用是一直都是这种状态.
察看/usr/bin/java,是链接指向gij-4.0的,于是在/usr/bin里重新做了个指向/usr/lib/j2sdk1.5-sun/bin/java的链接.再启动eclipse,就正常了.

Package gij-4.0
breezy (devel): The GNU Java bytecode interpreter
4.0.1-4ubuntu9: amd64 i386 powerpc
这是从ubuntu包搜索中查到的,gij-4.0是用于java字节码编译的,可是为什么eclipse3.1.2用不了呢?
头像
oneleaf
论坛管理员
帖子: 10230
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#2

帖子 oneleaf » 2006-02-19 16:45

不完全兼容。
Alonso
帖子: 60
注册时间: 2006-01-15 16:51
送出感谢: 0
接收感谢: 0

#3

帖子 Alonso » 2006-02-20 9:03

不知道是不是我一个人的问题,要知道有一些人也在ubuntu下使用eclipse进行开发。
jnow
帖子: 40
注册时间: 2005-09-05 14:45
送出感谢: 0
接收感谢: 0

#4

帖子 jnow » 2006-03-09 18:48

我用GIJ也是同样的问题
但一直没有改,怕别的程序出问题,楼主改也没有问题,那我也改了吧
jimmy
帖子: 27
注册时间: 2005-05-18 21:32
送出感谢: 0
接收感谢: 0

#5

帖子 jimmy » 2006-03-12 11:57

用gij有问题,我的情况是左边的树无法显示。
在ubuntu下,要使用eclipse3,还是要sun JDK1.5。
十年一觉扬州梦
回复

回到 “C/C++/Java”