当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]crossftp不能启动!!!
帖子发表于 : 2008-01-15 22:50 
头像

注册: 2006-09-26 22:47
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
这个是出错显示,装的是论坛上的deb版本,就在前一天都可以,今天就不行了,但是运行
代码:
javaws -offline http://www.crossftp.com/crossftp.jnlp

可以启动,
在昨天我装了eclipse,不知道是不是由于这个原因
代码:
xiaopeng@scorpioxp:~$ crossftp
Exception in thread "main" java.lang.NullPointerException
   at java.lang.VMClassLoader.defineClass(libgcj.so.81)
   at java.lang.ClassLoader.defineClass(libgcj.so.81)
   at java.security.SecureClassLoader.defineClass(libgcj.so.81)
   at java.net.URLClassLoader.findClass(libgcj.so.81)
   at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.81)
   at java.lang.ClassLoader.loadClass(libgcj.so.81)
   at java.lang.ClassLoader.loadClass(libgcj.so.81)
   at gnu.java.lang.MainThread.run(libgcj.so.81)

麻烦高手出来解释了一下,难道又是中文配置的问题,而我原来安装的java环境是sun-java6,不用配置就可以启动


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-15 23:42 

注册: 2006-06-09 20:31
帖子: 179
送出感谢: 0 次
接收感谢: 0 次
你装的eclipse修改了系统的默认java环境,把Sun的换成了GCJ的了:at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.81)

你需要把环境改回来,只需执行:
代码:
sudo update-alternatives –config java

然后选择正确的java版本。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-16 13:29 
头像

注册: 2006-09-26 22:47
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
恩,解决了,多谢多谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译