当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 新手请教,编译multiget出现的问题
帖子发表于 : 2008-01-20 20:45 
头像

注册: 2007-04-16 23:15
帖子: 152
送出感谢: 0 次
接收感谢: 0 次
我在的multiget官方网站上下载了 multiget-1.2.0.src.tar.bz2 源码

解压后放在了/usr/local/src/ 下,
然后进入目录,在终端输入
代码:
sudo ./configure


结果在最后一行出现了错误,希望高手帮帮忙.

代码:
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking wxWidgets version... ./configure: line 5813: wx-config: command not found
not found
configure: error: wxWidgets is required. Try --with-wx-config.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-20 20:53 
头像

注册: 2007-04-16 23:15
帖子: 152
送出感谢: 0 次
接收感谢: 0 次
我看了一下终端提示,不大懂,在终端又输入
代码:
wx-config


结果显示如下

代码:
The program 'wx-config' can be found in the following packages:
 * libwxbase2.6-dbg
 * libwxgtk2.6-dbg
 * libwxbase2.6-dev
 * libwxgtk2.4-dbg
 * libwxgtk2.6-dev
 * libwxgtk2.8-dev
 * libwxbase2.8-dev
 * libwxgtk2.8-dbg
 * libwxbase2.4-dev
 * libwxbase2.4-dbg
 * libwxgtk2.4-dev
 * libwxbase2.8-dbg
Try: sudo apt-get install <selected package>
Make sure you have the 'universe' component enabled
bash: wx-config: command not found


按照提示,在终端输入了

代码:
$sudo apt-get install <selected package>


结果显示
代码:
bash: syntax error near unexpected token `newline'


现在应该怎么办...... :shock:


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-20 21:05 

注册: 2006-04-04 1:15
帖子: 83
送出感谢: 0 次
接收感谢: 0 次
晕,楼主显然没理解好这段英文。
代码:
The program 'wx-config' can be found in the following packages:
 * libwxbase2.6-dbg
 * libwxgtk2.6-dbg
 * libwxbase2.6-dev
 * libwxgtk2.4-dbg
 * libwxgtk2.6-dev
 * libwxgtk2.8-dev
 * libwxbase2.8-dev
 * libwxgtk2.8-dbg
 * libwxbase2.4-dev
 * libwxbase2.4-dbg
 * libwxgtk2.4-dev
 * libwxbase2.8-dbg
Try: sudo apt-get install <selected package>
Make sure you have the 'universe' component enabled
bash: wx-config: command not found

意思是wx-config这个程序可以在以下包里找到
* libwxbase2.6-dbg
* libwxgtk2.6-dbg
* libwxbase2.6-dev
* libwxgtk2.4-dbg
* libwxgtk2.6-dev
* libwxgtk2.8-dev
* libwxbase2.8-dev
* libwxgtk2.8-dbg
* libwxbase2.4-dev
* libwxbase2.4-dbg
* libwxgtk2.4-dev
* libwxbase2.8-dbg
而这句sudo apt-get install <selected package> 里的<selected package> 是指在上面的包中你你自行选择
例如sudo apt-get install libwxbase2.6-dbg


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-20 21:13 
头像

注册: 2007-04-16 23:15
帖子: 152
送出感谢: 0 次
接收感谢: 0 次
感谢!
多问一句,为什么从上面的列出的包中任选一个就可以?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-20 21:23 
头像

注册: 2007-04-16 23:15
帖子: 152
送出感谢: 0 次
接收感谢: 0 次
谢谢三楼的朋友,按照您说的方法,在终端输入
代码:
sudo apt-get install libwxbase2.6-dbg


然后执行
引用:
$sudo ./configure
没有问题了.

接着我在终端输入
引用:
$sudo make


结果又出现了大堆错误........


引用:
addproxydlg.cpp:63: error: expected type-specifier before ‘wxTextCtrl’
addproxydlg.cpp:63: error: expected `)' before ‘wxTextCtrl’
addproxydlg.cpp:63: error: invalid conversion from ‘int*’ to ‘int’
addproxydlg.cpp:63: error: initializing argument 1 of ‘wxSizerItem* wxSizer::Add(int, int, int, int, int, wxObject*)’
addproxydlg.cpp:78: error: expected type-specifier before ‘wxRadioBox’
addproxydlg.cpp:78: error: expected `)' before ‘wxRadioBox’
addproxydlg.cpp:80: error: invalid conversion from ‘int*’ to ‘int’
addproxydlg.cpp:80: error: initializing argument 1 of ‘wxSizerItem* wxSizer::Add(int, int, int, int, int, wxObject*)’
addproxydlg.cpp:88: error: expected type-specifier before ‘wxButton’
addproxydlg.cpp:88: error: expected `)' before ‘wxButton’
addproxydlg.cpp:88: error: invalid conversion from ‘int*’ to ‘int’
addproxydlg.cpp:88: error: initializing argument 1 of ‘wxSizerItem* wxSizer::Add(int, int, int, int, int, wxObject*)’
addproxydlg.cpp:89: error: expected type-specifier before ‘wxButton’
addproxydlg.cpp:89: error: expected `)' before ‘wxButton’
addproxydlg.cpp:89: error: invalid conversion from ‘int*’ to ‘int’
addproxydlg.cpp:89: error: initializing argument 1 of ‘wxSizerItem* wxSizer::Add(int, int, int, int, int, wxObject*)’
addproxydlg.cpp:92: error: ‘SetSizer’ was not declared in this scope
make[2]: *** [addproxydlg.o] Error 1
make[2]: Leaving directory `/usr/local/src/multiget/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/multiget'
make: *** [all] Error 2



:(


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-22 16:21 
头像

注册: 2007-04-16 23:15
帖子: 152
送出感谢: 0 次
接收感谢: 0 次
:shock:


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-22 20:08 
头像

注册: 2006-07-08 14:07
帖子: 1771
送出感谢: 14
接收感谢: 1
libwxgtk2.6-dev

大哥,多看一下英文就懂了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-01-23 19:01 
头像

注册: 2007-04-16 23:15
帖子: 152
送出感谢: 0 次
接收感谢: 0 次
eagle5678 写道:
libwxgtk2.6-dev

大哥,多看一下英文就懂了


是的,我已经把缺省的依赖都装上了,./configure没有任何问题

就是make后,最后几行报错..........

代码:
then mv -f ".deps/mainframe.Tpo" ".deps/mainframe.Po"; else rm -f ".deps/mainframe.Tpo"; exit 1; fi
mainframe.cpp:32:25: error: wx/aboutdlg.h: No such file or directory
mainframe.cpp: In member function ‘void MainFrame::OnAbout(wxCommandEvent&)’:
mainframe.cpp:1231: error: ‘wxAboutDialogInfo’ was not declared in this scope
mainframe.cpp:1231: error: expected `;' before ‘info’
mainframe.cpp:1232: error: ‘info’ was not declared in this scope
mainframe.cpp:1249: error: ‘::wxAboutBox’ has not been declared
mainframe.cpp: In member function ‘void MainFrame::OnVisitHome(wxCommandEvent&)’:
mainframe.cpp:4938: error: ‘wxBROWSER_NEW_WINDOW’ was not declared in this scope
make[2]: *** [mainframe.o] Error 1
make[2]: Leaving directory `/usr/local/src/multiget/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/multiget'
make: *** [all] Error 2


页首
 用户资料  
 
9 楼 
 文章标题 : 同样问题,分享解决方法
帖子发表于 : 2008-04-02 10:19 

注册: 2006-10-19 15:22
帖子: 142
送出感谢: 0 次
接收感谢: 0 次
删除libwxbase2.6和libwxgtk2.6及dev, 编译需用2.8版本的
用此方法我的编译通过


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-10 14:30 
头像

注册: 2007-08-30 5:39
帖子: 1670
送出感谢: 0 次
接收感谢: 0 次
用2.8版。


_________________
深度,值得深入!
http://bbs.deepin.org/?u=348684

最新的综艺魔法相册
http://www.77studio.net/?fromuid=344


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-05-10 19:27 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
下载它的ded包省事

http://multiget.sourceforge.net/download.html


_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-05-12 21:40 
头像

注册: 2007-04-20 9:30
帖子: 104
送出感谢: 0 次
接收感谢: 0 次
www.getdeb.net.
有新的1.2.0的包。。

我下载来将bin文件直接放到我的home目录,当绿色软件用,filezilla也是当绿色软件用,benliu本来就是当绿色软件用。呵呵。基本够了。。不过偶尔也用用deluge。。。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-05-13 9:33 

注册: 2007-08-04 13:04
帖子: 274
送出感谢: 0 次
接收感谢: 0 次
用deb包就行了撒


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译