[原创]终于找到9.0版Flash插件在Opera中无显示的症结所在了。。。。

上网、浏览、聊天、下载等
回复
头像
qianwx
帖子: 730
注册时间: 2006-07-08 14:41
送出感谢: 0
接收感谢: 0

[原创]终于找到9.0版Flash插件在Opera中无显示的症结所在了。。。。

#1

帖子 qianwx » 2008-02-27 12:28

现在最新版Flash插件(9.0.115)在Opera9.24以上版本中使用,会出现无显示并出现《单击以激活并使用此控件》的提示。经过不断测试,我发现,在Opera的Plugins目录中还存在一个flashplayer.xpt的文件,该文件可以控制是否使用9.0版Flash的安全选项。但该文件是针对某个版本来的。。

在我自家电脑上,Flash插件的版本是9.0.48,系统是ubuntu7.10,从7.04上升级过来的。Flash使用毫无任何问题。但我单位电脑上使用同样版本的插件,却无法显示Flash。后来,我从单位电脑找到一个Flash插件安装文件包,其中多了个.XPT的文件,开始我没在意,复制了目录下的.so文件去Opera插件目录,结果无显示。之后用其自带安装包安装该插件,这次终于显示了。此后,又复制了一个9.0.155的Flash插件,依然无法显示Flash。。。

可见,Opera应该是通过该.XPT文件来控制最新的Flash插件的安全部分。。。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2008-02-27 12:39

最新版的插件没有这个东西了
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2008-02-27 12:42

opera认xpt?
● 鸣学
头像
qianwx
帖子: 730
注册时间: 2006-07-08 14:41
送出感谢: 0
接收感谢: 0

#4

帖子 qianwx » 2008-02-27 12:46

9.0.48的Flash插件很多地方下载也不带这个xpt文件,,我曾下载过不带xpt文件的9.0.48版插件,安装后就是不能使用,直接复制so文件一样不能使用。。。。但愿我搞错。。。。。
回复

回到 “因特网相关软件”