当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [原创]教大家都用上最新版的mldonkey
帖子发表于 : 2008-03-20 17:37 

注册: 2008-03-17 16:25
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
发帖原因: 刚接触ubuntu三天....还在不断完善各种常用软件的安装....发现ubuntu下的bt和emule的超好工具mldonkey......可是下载最新版发现不能用...一看才知道要编译.....可我不会啊~~~~~

于是忽......(经过1个小时的研究,闭关成功)....下面写上步骤....写的不好多多包涵...

步骤:
1.下载>>mldonkey-2.94
2.安装编译环境和用到lib

运行
代码:
sudo apt-get install build-essential

再打开新立得搜索zlib安装zlib和zlib-dev找不到的可以看图
解开下载的压缩包..打开终-端将-包中的configure文件拖入终端窗口然后回车
或手动输入
代码:
cd xxxxx   ###xxxx是你解压的目录路径
./configure ###输入完这句会自动检测所需文件





代码:
./configure --enable-gui[=newgui2]  ###这个是编译带gui界面的..想用gui的可以输入这个..我没编译这个...因为当我编完nogui的才发现可以编译带gui的:(


>>>>耐心等待...中间会需要下载Objective-Caml 3.10.2..需要你打Y确认下载安装>>>>继续等待...完成后

输入
代码:
make ##开始编译


3.编译完成..运行看效果吧
代码:
./mlnet


4.安装完成后一些相关设置请参看此贴http://forum.ubuntu.org.cn/viewtopic.php?t=42337


附件:
Screenshot.png
Screenshot.png [ 120.81 KiB | 被浏览 1718 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-20 18:14 
头像

注册: 2007-10-20 11:30
帖子: 1132
送出感谢: 1
接收感谢: 0 次
我需要一个好的UI


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-20 21:24 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
驴子,现在不热了。因为被歧视了。被打击了。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-20 22:15 
头像

注册: 2007-05-05 23:30
帖子: 562
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
驴子,现在不热了。因为被歧视了。被打击了。

?被怎么歧视和打击了?我还不知道呢。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-20 22:40 
头像

注册: 2006-10-19 8:43
帖子: 787
地址: 长江口
送出感谢: 1
接收感谢: 2
eexpress 写道:
驴子,现在不热了。因为被歧视了。被打击了。


驴子还是不错,verycd上面的资源是有保证的;不像BT,常下些假货来,令人空欢喜

应该不我的RP问题


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-20 22:56 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
晕,下载静态编译的二进制版本啊,解压直接运行...
http://downloads.sourceforge.net/mldonk ... g_mirror=0


_________________
关注我的blog: ε==3


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-20 22:58 
头像

注册: 2007-11-19 21:51
帖子: 6956
地址: 成都
送出感谢: 0 次
接收感谢: 4
驴子是干嘛的用?没用过。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-24 14:15 
头像

注册: 2007-04-11 10:39
帖子: 319
送出感谢: 0 次
接收感谢: 0 次
不是 ./configure --enable-gui[=newgui2]

而是 ./configure --enable-gui=newgui2


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-03-24 20:38 
头像

注册: 2007-09-23 13:36
帖子: 364
送出感谢: 0 次
接收感谢: 2
能关联 firefox 就好了


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-03-27 22:05 
头像

注册: 2006-12-16 22:05
帖子: 503
地址: 肇庆
送出感谢: 0 次
接收感谢: 0 次
更正,是骡子,不是驴子。


_________________
http://qkthomas.blog.ubuntu.org.cn


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-03-27 23:15 

注册: 2007-08-04 13:04
帖子: 274
送出感谢: 0 次
接收感谢: 0 次
编译就是害怕少了依赖包,看来这里是两个zlib包了


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-28 17:43 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
hecha 写道:
能关联 firefox 就好了

当然可以,有专门的xpi的。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [原创]教大家都用上最新版的mldonkey
帖子发表于 : 2008-11-06 23:32 
头像

注册: 2007-05-12 10:45
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
做个记号


_________________
佩长铗兮握四海升平,邀明月兮放九天高远。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译