当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : skype终于能用啦
帖子发表于 : 2006-03-25 9:58 

注册: 2006-03-06 19:16
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
首先说一句,即便SKYPE能用,系统带的录音机也不能录声音

如果你的SKYPE运行正常,请先添加好友 echo123,这是官方的自动主意测试系统

如果你能听到声音,并且能听到说话的录音,那一切正常啦
如果提示声音错误,请先关闭任何可能用到声音设备的程序再试(不需重启SKYPE)

以下就是相关的配置贴图,特别注意 “声音首选项”


附件:
Screenshot-音量控制:Intel 82801DB-ICH4 (Alsa Mixer)-1.png
Screenshot-音量控制:Intel 82801DB-ICH4 (Alsa Mixer)-1.png [ 9.4 KiB | 被浏览 673 次 ]
Screenshot-音量控制:Intel 82801DB-ICH4 (Alsa Mixer).png
Screenshot-音量控制:Intel 82801DB-ICH4 (Alsa Mixer).png [ 11.13 KiB | 被浏览 680 次 ]
Screenshot-多媒体系统选择器.png
Screenshot-多媒体系统选择器.png [ 15.94 KiB | 被浏览 455 次 ]

Screenshot-声音首选项.png
Screenshot-声音首选项.png [ 11.72 KiB | 被浏览 456 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-03-25 10:00 

注册: 2006-03-06 19:16
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
每一时刻最多只能一个程序使用音频设备
用SKYPE时不退出播放器也可以,暂停就行


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-03-25 17:12 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
声卡的事,可以试试软混音。主页有方法。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-04-05 16:00 

注册: 2005-10-22 10:09
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
2楼的应该到主页找找解决方法,用alsa解决软混音的问题。。。


_________________
Tomorrow is another day!


页首
 用户资料  
 
5 楼 
 文章标题 : 转个多音频流的解决方案
帖子发表于 : 2006-04-20 12:21 

注册: 2006-04-20 11:47
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
大多数Linux初学者都遇到这样一个问题:“为什么我在同时打开两个应用程序时不能听到声音呢?”这是因为你的声卡需要“软混音”。值得庆幸的是,ALSA提供了这项功能,这使得解决这个问题并不是很难。

首先需要安装libesd-alsa0,它就在Ubuntu官方软件库中。

sudo apt-get install libesd-alsa0

然后,用sudo gedit或您喜欢的文本编辑器创建文件/etc/asound.conf(请确定您使用了sudo,因为您需要root权限):

sudo gedit /etc/asound.conf


输入一下内容并保持关闭。
代码

pcm.card0 {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "dmixer"
}

pcm.dmixer {
type dmix
ipc_key 1025
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 4096
periods 128
rate 44100
}
bindings {
0 0
1 1
}
}

(上面的文件可以在大多数声卡上正常运行…尽管我成功地测试了三个不同的声卡,但我还是不能确保它可以使所有声卡都能正常运行)

接下来,运行

sudo gedit /etc/esound/esd.conf

,将文件改成下面的内容:
代码

[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=

然后打开您的Gnome声音控制面板并启用声音服务器,接着到多媒体系统选择控制面板,将其设成ALSA或ESD,并重启计算机。

接下来您就可以将应用程序设成使用ALSA或ESD,这样您就可以一次听到多个声音了。就算是玩着用ALSA发音的游戏并听到使用ESD的GNOME应用发出的声音也没有任何问题!

有些朋友在hoary上按照上述的方法设置却遇到了问题,他们不能在mozilla/firefox/epiphany程序中听到声音,结果我发现在启动 firefox时,程序查找libesd.so.1而系统却只有libesd.so.0,所以只要运行命令

sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1

后就可以解决这个问题了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-05-03 16:29 
头像

注册: 2005-10-16 13:24
帖子: 958
地址: 四川成都
送出感谢: 2
接收感谢: 0 次
用alsa-oss,就可用同时听音乐又能聊天了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-05-12 14:33 
头像

注册: 2005-11-13 1:51
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
Gnome声音控制面板 在哪里啊?


_________________
Stupid is as stupid does.

AMD Sempron 2500+ 64-bits
Asrock K8NF4G-SATA2 (GeForce6100+nForce 410 chipsets)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译