当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何让mystar后台运行?
帖子发表于 : 2008-05-05 18:09 

注册: 2008-05-05 11:54
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我的教育网用mystar认证上网,每次我要上网都先打开一个终端,输入sudo ./mystar,然后还要输入系统管理员密码,论证成功后那个终端窗口一直还在,看着很不爽,但是关了它又不能上网了,我把它移动到第2个桌面。
但还是不爽,建个启动器运行它时不能认证,好像不是sudo运行的,sudo运行要输入密码的。
有没有什么办法搞一个启动器,双击它就用sudo运行,并且后台运行不要出现一个窗口


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-29 16:03 

注册: 2008-01-10 11:14
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
try this

sudo -b xxxx


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-29 18:47 

注册: 2006-11-25 2:08
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
关了可以上网啊,而且linux并不是每次都要认证,我都是偶尔上不了了,我再运行一次,然后就关了,根本没有楼主说的问题!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-29 19:33 
头像

注册: 2007-12-31 14:57
帖子: 1097
送出感谢: 0 次
接收感谢: 1
很久之前我也遇到类似问题
代码:
sudo ./mystar &

加个&就行了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 如何让mystar后台运行?
帖子发表于 : 2010-03-08 12:58 

注册: 2009-05-16 13:41
帖子: 21
系统: Archlinux
送出感谢: 0 次
接收感谢: 0 次
mystar.conf中的echoInterval=4改成0。
#echo interval, 4 seconds. usually between 1 and 100
#set it to 0 to DISABLE it
禁用echo,就可以了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译