编译qterm发生错误:

上网、浏览、聊天、下载等
回复
cainiaoyige
帖子: 69
注册时间: 2006-04-01 19:15
送出感谢: 0
接收感谢: 0

编译qterm发生错误:

#1

帖子 cainiaoyige » 2006-04-02 11:27

checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
怎么解决?
头像
jazzi
帖子: 532
注册时间: 2005-10-16 23:26
来自: 泉州
送出感谢: 0
接收感谢: 3 次
联系:

#2

帖子 jazzi » 2006-04-02 11:43

look at the end of config.log,看一看这个了
提示说你的QT没装或者版本太低,你查一下
You make it fun
It will make you fun
cainiaoyige
帖子: 69
注册时间: 2006-04-01 19:15
送出感谢: 0
接收感谢: 0

#3

帖子 cainiaoyige » 2006-04-02 11:56

configure:29200: checking for Qt
configure: 29265: /usr/lib/qt3/include/qstyle.h
configure: 29265: /usr/lib/qt3/qstyle.h
configure: 29265: /usr/lib/qt/include/qstyle.h
configure: 29265: /usr/lib/qt/qstyle.h
configure: 29265: /usr/share/qt3/include/qstyle.h
configure: 29265: /usr/share/qt3/qstyle.h
configure: 29265: /usr/local/qt/include/qstyle.h
configure: 29265: /usr/include/qt/qstyle.h
configure: 29265: /usr/include/qstyle.h
configure: 29265: /usr/X11R6/include/X11/qt/qstyle.h
configure: 29265: /usr/X11R6/include/qt/qstyle.h
configure: 29265: /usr/X11R6/include/qt2/qstyle.h
configure: 29265: /usr/include/qt3/qstyle.h
configure: 29265: ./qstyle.h
tried NO
tried /usr/lib/qt3/lib
tried /usr/lib/qt3
tried /usr/lib/qt/lib
tried /usr/lib/qt
这是config.log中的一段话。
但我看了下根本没有/usr/lib/qt这个目录,看来是没装qt了.
不知如何装?
sudo apt-get install qt?
jaex
帖子: 190
注册时间: 2006-02-14 21:05
送出感谢: 0
接收感谢: 0

#4

帖子 jaex » 2006-04-02 21:45

apt-cache search qt
然后看看哪个合适就装!!
回复

回到 “因特网相关软件”