当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]Firefox3.0RC1 不能安装插件(已解决)
帖子发表于 : 2008-05-23 16:36 
头像

注册: 2008-05-03 16:44
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
系统8.04,今天将自带的FF3 b5替换成了RC1,结果出现插件都不能安装的情况。上Mozilla的官方插件网站,安装FF3RC1支持的插件,下载完成后却提示插件不支持3.0,而且提示信息一闪而过,都来不及抓图。

同时,扩展插件显示中,插件选项卡中空空如也,“语言”选项卡中,有三个语言包插件提示不支持,但也无法删除。

PS:相同的插件在windows下的firefox 3RC1可以正常安装和使用。


附件:
文件注释: 截图
Screenshot-附加组件.png
Screenshot-附加组件.png [ 27.73 KiB | 被浏览 978 次 ]



最后由 zrong 编辑于 2008-05-28 14:48,总共编辑了 2 次
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-23 20:49 
头像

注册: 2007-11-08 21:23
帖子: 1289
地址: 中国
送出感谢: 0 次
接收感谢: 0 次
版本太新了,等扩展更新吧。


_________________
这个功能如何实现?
http://yufanyufan.spaces.live.com/blog/ ... !149.entry
要实现的功能为,若当前标签页为空白页,则在当前页打开,否则新建一个标签页。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-25 10:09 
头像

注册: 2008-05-03 16:44
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
不是版本的问题,相同的插件,在Windows下的firefox 3RC1是可以正常安装的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-25 10:59 
头像

注册: 2007-11-08 21:23
帖子: 1289
地址: 中国
送出感谢: 0 次
接收感谢: 0 次
zrong 写道:
不是版本的问题,相同的插件,在Windows下的firefox 3RC1是可以正常安装的。


以后肯定是可以用的,只是现在不行,等吧。谁让这些扩展不是由MOZILLA公司写的呢?


_________________
这个功能如何实现?
http://yufanyufan.spaces.live.com/blog/ ... !149.entry
要实现的功能为,若当前标签页为空白页,则在当前页打开,否则新建一个标签页。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-25 11:22 
头像

注册: 2008-05-03 16:44
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
不是这个意思。

相同的一款插件,比如flashgot,在Windows下的firefox 3 RC1中是可以正常安装和使用的。但在Ubuntu下的firefox 3 RC1中就不可以安装。不仅如此,所有在Mozilla插件网站中的插件都不能在Ubuntu下的firefox 3 RC1中安装。所以,不应该是插件不兼容的问题。

可能是我安装firefox 3 RC1的方法不对导致了这个问题。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-25 11:38 

注册: 2007-09-06 16:07
帖子: 466
送出感谢: 0 次
接收感谢: 0 次
about:config
添加:
extensions.checkCompatibility false


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-26 9:59 
头像

注册: 2006-10-25 18:08
帖子: 1582
送出感谢: 0 次
接收感谢: 0 次
把fx2彻底卸载试试


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-26 11:29 
头像

注册: 2008-05-03 16:44
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
和firefox2没关系,我没装过firefox2


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-27 11:41 
头像

注册: 2008-04-26 12:41
帖子: 10971
送出感谢: 11
接收感谢: 38
zrong 写道:
不是这个意思。

相同的一款插件,比如flashgot,在Windows下的firefox 3 RC1中是可以正常安装和使用的。但在Ubuntu下的firefox 3 RC1中就不可以安装。不仅如此,所有在Mozilla插件网站中的插件都不能在Ubuntu下的firefox 3 RC1中安装。所以,不应该是插件不兼容的问题。

可能是我安装firefox 3 RC1的方法不对导致了这个问题。

你是怎么装3.0RC1的?


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-27 15:02 
头像

注册: 2008-05-03 16:44
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
mech 写道:
about:config
添加:
extensions.checkCompatibility false


没用。

另外,我今天彻底卸载了FF3,然后在新立德里安装了FF2,也是同样的问题。不能安装任何插件,甚至连语言包都不能安装。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-05-27 15:16 
头像

注册: 2008-05-03 16:44
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
photor 写道:
zrong 写道:
不是这个意思。

相同的一款插件,比如flashgot,在Windows下的firefox 3 RC1中是可以正常安装和使用的。但在Ubuntu下的firefox 3 RC1中就不可以安装。不仅如此,所有在Mozilla插件网站中的插件都不能在Ubuntu下的firefox 3 RC1中安装。所以,不应该是插件不兼容的问题。

可能是我安装firefox 3 RC1的方法不对导致了这个问题。

你是怎么装3.0RC1的?


去mozilla上下载RC1压缩包,然后解压到/usr/lib/下,然后更新/usr/bin/下的连接文件目标。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-05-27 21:46 
头像

注册: 2006-06-18 21:49
帖子: 517
送出感谢: 0 次
接收感谢: 0 次
# 在地址栏里输入about:config,然后点击I’ll be careful, I promise!按钮;
# 右击选择New > Boolean,新建一个名为extensions.checkCompatibility的键并设值为false;
# 用相同的方法新建一个名为extensions.checkUpdateSecurity的键并设值为false;
再去安装插件,就OK了!!


_________________
Time waits for no man!


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-05-27 22:42 
头像

注册: 2008-05-03 16:44
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
jaywee 写道:
# 在地址栏里输入about:config,然后点击I’ll be careful, I promise!按钮;
# 右击选择New > Boolean,新建一个名为extensions.checkCompatibility的键并设值为false;
# 用相同的方法新建一个名为extensions.checkUpdateSecurity的键并设值为false;
再去安装插件,就OK了!!


试了,没用。

我一直认为,不是插件不兼容的问题。所以在插件上下功夫应该是没用的。可能是ff3b5的某些共享库无法删除导致的。

这是在ff2下安装语言包弹出的错误窗口。

这是ff2下的插件设置窗口。几个原来在ff3b5下的插件始终无法删除。


附件:
文件注释: 这是ff2下的插件设置窗口。几个原来在ff3b5下的插件始终无法删除。
Screenshot-Add-ons.png
Screenshot-Add-ons.png [ 39.17 KiB | 被浏览 805 次 ]

文件注释: 这是在ff2下安装语言包弹出的错误窗口。
Screenshot-Error.png
Screenshot-Error.png [ 12.76 KiB | 被浏览 799 次 ]

页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-05-28 14:47 
头像

注册: 2008-05-03 16:44
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
已经解决。

问题出在我安装RC1的方法不当。我直接把下载的压缩包解压到/usr/lib/firefox-3.0rc1下,然后修改了/usr/bin/firefox-3.0链接到/usr/lib/firefox-3.0rc1/firfox,可能是这种方法导致冲突存在,以至于不能安装插件。

解决方法:
完全删除firefox-3.0rc1目录
添加源:http://forum.ubuntu.org.cn/viewtopic.php?t=126365
在新利得中重新安装firefox3.0rc1


最后由 zrong 编辑于 2008-05-28 21:06,总共编辑了 1 次

页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-05-28 18:14 

注册: 2008-03-09 19:09
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
在新利得中重新安装firefox3.0rc1
——————————————————————
搜索不到firefox3.0rc1


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译