当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [分享]搞定amd64 8.04下面mldonkey自动退出问题(段错误)
帖子发表于 : 2008-06-01 20:08 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
自从换了8.04后,mldonkey 一直用的不顺心,不管是从源里面下载
或是下载deb包安装,或是自己编译,mldonkey一直有自己退出问题

就是运行后,过不了多久就自动退出,我是用web界面管理
在网上找了不少时间,终于在官方找到了问题所在!

原来即不是mldonkey的问题,也不是8.04的问题,问题出在ocaml上!!
amd64 8.04下安装的ocaml是3.10.0,把ocaml换成3.10.2(应该是目前最新版吧)

再重新编译mldonkey
./configure --enable-ocamlver=3.10.2
make

运了一天,问题解决,再也没有自动退出了,希望大家能早日解脱这个烦劳!附件送上
ocaml的几个deb包,下到一个目录里面,然后
sudo dpkg -i *.deb 即可


最后由 斯文败类 编辑于 2008-06-02 7:48,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-01 20:10 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
这是ocaml的新版本包,for amd64位的


附件:
ocaml-base-nox_3.10.2-3_amd64.deb [376.63 KiB]
被下载 101 次
页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-06-02 0:10 

注册: 2007-08-04 13:04
帖子: 274
送出感谢: 0 次
接收感谢: 0 次
lz说的自动退出,是不是报一个段错误,就退出了的,我的也是amd64处理器,ubuntu8.04源里面下载的,有这个问题。一直没有解决的。
呆会换系统试试看。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-06-02 7:15 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
这是ocaml的新版本包,for amd64位的


附件:
ocaml-interp_3.10.2-3_amd64.deb [1.17 MiB]
被下载 101 次
页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-02 7:20 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
是的,我的也是64位的,报一个段错误


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-02 7:30 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
还有两 个包,太大了传不上来,自己去网站下吧
http://packages.debian.org/sid/amd64/ocaml-nox/download
http://packages.debian.org/sid/amd64/oc ... s/download

昨天下了一个晚上,今天早上看,没有退出!呵呵!爽呆了!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-02 9:59 

注册: 2007-06-22 16:15
帖子: 122
系统: Ubuntu-mate
送出感谢: 7
接收感谢: 0 次
不重新编译,只是装deb包可以吗?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-02 10:06 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
那我倒沒試過,你安裝包之後再試一下!

官方說是要重新編譯一下!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-06-02 12:06 
头像

注册: 2007-09-01 23:20
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
我早就被64版本整残了,还是用32位版本吧


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-06-02 12:21 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
現在用64位也基本Ok了,暫時沒發現其它問題!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-06-02 15:55 

注册: 2007-06-22 16:15
帖子: 122
系统: Ubuntu-mate
送出感谢: 7
接收感谢: 0 次
刚试了,只是装那4个deb,不行


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-06-02 17:31 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
jacker@ubuntu:~$ ocaml -version
The Objective Caml toplevel, version 3.10.2

看下版本是不是更新到3.10.2,再重新編譯一下應該OK


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-06-02 18:31 

注册: 2007-08-04 13:04
帖子: 274
送出感谢: 0 次
接收感谢: 0 次
fengtou 写道:
刚试了,只是装那4个deb,不行

看来这个兄弟已经把我想问的问过了,我编译试试看,一会来汇报情况


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-06-02 19:47 

注册: 2007-05-06 20:16
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
嗯,樓上的編譯好了沒?


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-06-02 20:00 

注册: 2007-08-04 13:04
帖子: 274
送出感谢: 0 次
接收感谢: 0 次
确实不会自动退出了, 谢谢lz的方法阿,我终于可以又换回mldonkey了。
我这里的步骤是,先安装lz的四个deb
然后下载mldonkey2.5的源文件包,按照lz的方法执行:
./configure --enable-ocamlver=3.10.2
期间会要求安装ocaml到mldonkey的local目录,这里必须打y以继续。
不是太理解,deb包不就是这个ocaml吗?
之后还会提示缺少zlib, 因此最好configure之前先执行:
apt-get install zlib1g-dev
apt-get install zlib1g

其实安装了lz的四个deb包后,按照这个做就好了:
http://forum.ubuntu.org.cn/viewtopic.php?t=110454


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译