当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安裝firefox為何需安裝這麽多?
帖子发表于 : 2008-07-02 9:55 
头像

注册: 2005-10-04 16:16
帖子: 274
地址: Beijing
送出感谢: 0 次
接收感谢: 2
直接從源中安裝,居然有這麽多依賴。
請教如何去掉依賴,單純安裝firefox-3.0。
引用:
davix:~$ sudo aptitude install firefox
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following NEW packages will be automatically installed:
apturl dbus-x11 deborphan dialog docbook-xml firefox-3.0 gamin gnome-app-install gnome-icon-theme
gnome-mime-data gnome-mount libavahi-glib1 libbonobo2-0 libbonobo2-common libbonoboui2-0 libbonoboui2-common
libcairo-perl libgail-common libgail18 libgamin0 libglib-perl libgnome2-0 libgnome2-canvas-perl
libgnome2-common libgnome2-perl libgnome2-vfs-perl libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0
libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgtk2-perl libgtkhtml2-0
liblaunchpad-integration1 libpolkit-gnome0 librsvg2-common libscrollkeeper0 libvte-common libvte9
policykit-gnome python-cairo python-gconf python-glade2 python-gst0.10 python-gtk2 python-gtk2-doc
python-gtkhtml2 python-launchpad-integration python-numeric python-pyorbit python-sexy python-vte
scrollkeeper sgml-base sgml-data shared-mime-info software-properties-gtk synaptic ubufox xml-core
xulrunner-1.9
The following NEW packages will be installed:
apturl dbus-x11 deborphan dialog docbook-xml firefox firefox-3.0 gamin gnome-app-install gnome-icon-theme
gnome-mime-data gnome-mount libavahi-glib1 libbonobo2-0 libbonobo2-common libbonoboui2-0 libbonoboui2-common
libcairo-perl libgail-common libgail18 libgamin0 libglib-perl libgnome2-0 libgnome2-canvas-perl
libgnome2-common libgnome2-perl libgnome2-vfs-perl libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0
libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgtk2-perl libgtkhtml2-0
liblaunchpad-integration1 libpolkit-gnome0 librsvg2-common libscrollkeeper0 libvte-common libvte9
policykit-gnome python-cairo python-gconf python-glade2 python-gst0.10 python-gtk2 python-gtk2-doc
python-gtkhtml2 python-launchpad-integration python-numeric python-pyorbit python-sexy python-vte
scrollkeeper sgml-base sgml-data shared-mime-info software-properties-gtk synaptic ubufox xml-core
xulrunner-1.9
0 packages upgraded, 64 newly installed, 0 to remove and 0 not upgraded.
Need to get 25.8MB of archives. After unpacking 133MB will be used.
Do you want to continue? [Y/n/?]


_________________
I'd love K* rather than G*,
just like *nix rather than win*.
Bug No. 1
图片


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-02 10:47 
头像

注册: 2005-07-02 14:41
帖子: 4133
系统: Ubuntu 14.04 (Kylin)
送出感谢: 53
接收感谢: 11
這你要找mozilla了投訴了:你們咋把firefox搞成這樣?


_________________
https://weakish.github.io


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-02 10:50 
头像

注册: 2005-08-01 9:14
帖子: 3666
送出感谢: 0 次
接收感谢: 0 次
lz用k的缘故 :lol:


_________________
Gedanken ohne Inhalt sind leer .Anschauungen ohne Begriffe sind blind.


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-02 15:13 
头像

注册: 2005-10-04 16:16
帖子: 274
地址: Beijing
送出感谢: 0 次
接收感谢: 2
millenniumdark 写道:
這你要找mozilla了投訴了:你們咋把firefox搞成這樣?


倒也未必。
我之前安裝的fx3 beta1并沒有依賴那些東西啊。
回想一下,好像是用的官方安裝包。
并沒有依賴那麽多東西,可以正常使用。

所以這責任不能推給mozilla吧
引用:
davix:~$ ls ~/bin/firefox
active-update.xml extensions libnss3.so libssl3.so res
application.ini firefox libnssckbi.so libxpcom.so run-mozilla.sh
blocklist.xml firefox-bin libnssdbm3.so libxul.so searchplugins
browserconfig.properties greprefs libnssutil3.so modules Throbber-small.gif
chrome icons libplc4.so mozilla-xremote-client updater
components libfreebl3.chk libplds4.so old-homepage-default.properties updater.ini
crashreporter libfreebl3.so libsmime3.so platform.ini updates
crashreporter.ini libjemalloc.so libsoftokn3.chk plugins updates.xml
crashreporter-override.ini libmozjs.so libsoftokn3.so README.txt
defaults libnspr4.so libsqlite3.so removed-files


_________________
I'd love K* rather than G*,
just like *nix rather than win*.
Bug No. 1
图片


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-02 15:21 
头像

注册: 2005-10-04 16:16
帖子: 274
地址: Beijing
送出感谢: 0 次
接收感谢: 2
嗯,從源中安裝:
Need to get 25.8MB of archives. After unpacking *****133MB******* will be used.

從官方下載:
http://download.mozilla.org/?product=fi ... lang=en-US
firefox-3.0.tar.bz2 ****8.7M********

可惡的源中的dependency
我要用fx,連python-sexy這類沒什麽關係的都要一起安裝


_________________
I'd love K* rather than G*,
just like *nix rather than win*.
Bug No. 1
图片


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-07 21:41 
头像

注册: 2005-07-02 14:41
帖子: 4133
系统: Ubuntu 14.04 (Kylin)
送出感谢: 53
接收感谢: 11
davix 写道:
millenniumdark 写道:
這你要找mozilla了投訴了:你們咋把firefox搞成這樣?


倒也未必。
我之前安裝的fx3 beta1并沒有依賴那些東西啊。
回想一下,好像是用的官方安裝包。
并沒有依賴那麽多東西,可以正常使用。



aptitude默認是把建議安裝的也一并裝上的,你可以設置一下,不裝建議的。


_________________
https://weakish.github.io


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-07 22:29 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
图片


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-07 22:43 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
如楼上所示, 或者用apt-get安装.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译