用pppoeconf后还是无法连接网络?

上网、浏览、聊天、下载等
ztb707
帖子: 19
注册时间: 2006-03-01 15:18
送出感谢: 0
接收感谢: 0

用pppoeconf后还是无法连接网络?

#1

帖子 ztb707 » 2006-05-21 22:52

摸索了好久了,在论坛里也搜索了一些相关的贴子,还是没有找到解决方案
用PPPoeconf可以正常配置,用户名和密码也没有错,拨号后有时偶尔可以打开一两个网页,比如百度什么的,但是基本上别的网页是没有什么响应,可能是无法解析域名?更别说apt-get了...
我是宽带拨号,请问有人能告诉我为什么吗?
fuhuizn
帖子: 738
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 13 次
联系:

#2

帖子 fuhuizn » 2006-05-21 23:20

只有两个可能:没有自动获得DNS,或者防火墙安全级别过高
ztb707
帖子: 19
注册时间: 2006-03-01 15:18
送出感谢: 0
接收感谢: 0

#3

帖子 ztb707 » 2006-05-23 18:11

要怎么样才能自动获取DNS啊?
我是新装的系统,没有进行过任何设置
防火墙又要怎么设置?
fuhuizn
帖子: 738
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 13 次
联系:

#4

帖子 fuhuizn » 2006-05-23 23:17

apt-get install resolvconf #自动获得DNS
apt-get install lokkit #防火墙配置工具[/u]
ztb707
帖子: 19
注册时间: 2006-03-01 15:18
送出感谢: 0
接收感谢: 0

#5

帖子 ztb707 » 2006-05-27 20:53

老大,我连网都上不去...怎么apt-get install...
前几天出去了,今天回来还是解决不了问题,烦死了,到底应该怎么办啊
dida
帖子: 131
注册时间: 2006-03-12 17:01
送出感谢: 0
接收感谢: 0

#6

帖子 dida » 2006-05-27 21:26

那你先试试输入dns服务器,系统-系统管理-联网那里
具体的dns服务器地址要咨询您的网络服务提供商 :)
fuhuizn
帖子: 738
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 13 次
联系:

#7

帖子 fuhuizn » 2006-05-28 9:10

ztb707 写了:老大,我连网都上不去...怎么apt-get install...
前几天出去了,今天回来还是解决不了问题,烦死了,到底应该怎么办啊
用单用户模式,防火墙就不会被启动了,估计你就可以上网了
ztb707
帖子: 19
注册时间: 2006-03-01 15:18
送出感谢: 0
接收感谢: 0

#8

帖子 ztb707 » 2006-05-28 14:32

回六楼:不能自动获取DNS地址吗?
回七楼:单用户模式是怎么启用的啊?
谢谢~
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2006-05-28 15:14

$ cat /etc/resolv.conf
nameserver 61.137.94.196
nameserver 202.103.96.112
有这样的信息?
6楼的说了菜单那里设置。作了吗。
自动获取dns,好像记得是pppoeconf的配置文件,那个dsl-provider里面有一句自动获取dns的行,不记得怎么写的。看看有像的行没有。
● 鸣学
ztb707
帖子: 19
注册时间: 2006-03-01 15:18
送出感谢: 0
接收感谢: 0

#10

帖子 ztb707 » 2006-06-02 16:29

今天回来试了一下六楼的方法,把DNS服务器填上,还是不行,总是过一会就自动变回两个默认的DNS服务器了,不管怎么换都不行,修改interfaces,resolv.conf,dsl-provider都试过了,DNS服务器总是会自动变回去...
现在上网是开百度的一些页面或者用它搜索可以打开,其它一概打不开...Firefox下方总是显示"waiting for XXX..."
我已经把Breezy换成Dapper了,还是同样的问题...
DNS服务器到底应该怎么设置呢...唉,烦死了...一个Ubuntu搞了半个多月了...还不能正常上网...
ztb707
帖子: 19
注册时间: 2006-03-01 15:18
送出感谢: 0
接收感谢: 0

#11

帖子 ztb707 » 2006-06-02 17:37

我发现一个问题...就是PPPOECONF不能让我手动填写DNS服务器地址啊
在设置--联网里修改的DNS地址每次在拨号后就被自动获取的DNS覆盖了
要怎么样设置使PPPoeconf拨号能够使用静态DNS地址呢?
ztb707
帖子: 19
注册时间: 2006-03-01 15:18
送出感谢: 0
接收感谢: 0

#12

帖子 ztb707 » 2006-06-02 18:10

今天用了一天时间来解决,虽然还没有解决,但现在问题基本确定是在DNS上了...
我还是不知道要怎么才能使PPPOEconf拨号后使用我指定的静态DNS地址,每次它都要自己寻找两个,而那两个DNS服务器好像都不好用,现在仍然是只打得开百度的页面
谁能告诉我如何使PPPOECONF使用我指定的DNS服务器吗?谢谢
ztb707
帖子: 19
注册时间: 2006-03-01 15:18
送出感谢: 0
接收感谢: 0

#13

帖子 ztb707 » 2006-06-03 15:06

没有人能告诉我一下吗?等了一天了...
zxx007
帖子: 217
注册时间: 2006-04-29 15:43
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 zxx007 » 2006-06-09 8:27

pppoeconf设置时可以填两个dns(你isp的DNS难道你不知道?)
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

仔细看懂就会知道了。

#15

帖子 eexpress » 2006-06-09 9:15

就是我9楼说的那个文件。是dns设置。

pppoeconf里面有一次提问,会问道是否自动获取dns。你不选自动获取就是了啊。要不当然覆盖了自己填写的。

也可以手动修改。

代码: 全选

$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 10.23.1.10<----这里什么设置都有
netmask 255.255.255.0
network 10.23.1.0
broadcast 10.23.1.255
gateway 10.23.1.1
# dns-* options are implemented by the resolvconf package, if installed <---这个就是4楼说的那个软件,如果你安装了。这里的dns设置就无效了,就会使用9楼说的那个文件。
dns-nameservers 61.137.94.196

/etc/ppp/peers/dsl-provider这个文件是pppoeconf产生的。里面如果有autodns这样的语句。可以去掉。
● 鸣学
回复

回到 “因特网相关软件”