新的Qipmsg0.9.5ipmsg安装办法。摸索了两天了跟大家分享一下

上网、浏览、聊天、下载等
回复
头像
philojava
帖子: 337
注册时间: 2008-04-18 22:47
来自: 中国上海
送出感谢: 0
接收感谢: 0
联系:

新的Qipmsg0.9.5ipmsg安装办法。摸索了两天了跟大家分享一下

#1

帖子 philojava » 2008-10-09 18:05

我的机器是amd64+ubuntu8.04

下载请到http://code.google.com/p/qipmsg/
我下载的是qipmsg-0.9.5.tar.bz2,大家也可下载qipmsg-0.9.5.tar.gz
下载后解压到自已想要安装的目录下。我的是在/home/philo/文档/software/ipmsg (philo是我自己的主文件夹名,各位换成自己的)
我解压之后的目录结构是: /home/philo/文档/software/ipmsg/qipmsg-0.9.5

* 32 位系统安装

首先,使用新立得软件包管理器安装 libqt4-core 和 libqt4-gui 两个包。然后 下载 QIpMsg 后鼠标双击安装包完成安装。

* 64 位系统安装

从源码编译安装
下面说说编译时的问题:
$ cd /home/philo/文档/software/ipmsg/qipmsg-0.9.5
$ make
$ sudo make install

注意:在$ make的过程中会出现很多“警告”,这个没关系的,放心。
但是在make最后的这个信息请注意一下:
make[1]:正在离开目录 `/home/philo/文档/software/ipmsg/qipmsg-0.9.5/src'
cd src && lrelease-qt4 qipmsg.pro
/home/philo/software/ipmsg/qipmsg-0.9.5/src/qipmsg.pro(0): ERROR: parse failure.error: lrelease encountered project file functionality that is currently not supported.
You might want to consider using .ts files as input instead of a project file.
Try the following syntax:
lrelease [options] ts-files [-qm qm-file]

如果继续$ sudo make install的时候出现以下的报错信息:
philo@philo:~/文档/software/ipmsg/qipmsg-0.9.5$ sudo make install
[sudo] password for philo:
install -d /usr/bin/
install -m 755 src/qipmsg /usr/bin/
install -d /usr/bin/
install -m 755 src/qipmsg-xdg-open /usr/bin/
install -d /usr/share/qipmsg/translations
install -m 644 src/translations/*.qm /usr/share/qipmsg/translations
install: 无法 [b]stat “src/translations/*.qm”:
没有该文件或目录
make: *** [install] 错误 1
[/b]
就是这个问题导致我编译安装一直不通过。
后来我找到 /home/philo/文档/software/ipmsg/qipmsg-0.9.5/src/translations里面有一个qipmsg_zh_CN.ts的文件,就是这个文件搞的怪。

请将这个文件重命名为qipmsg_zh_CN.qm
然后再
$ cd /home/philo/文档/software/ipmsg/qipmsg-0.9.5
$ make
$ sudo make install
如果前面已经make过了的话,会在$ make时出现
philo@philo:~/文档/software/ipmsg/qipmsg-0.9.5$ make
make: “src/qipmsg”是最新的。

不用管,继续$ sudo make install就可以了。
会在 应用程序--》互联网--》飞鸽传书 这有一个图标启动的。
至此大功告成

代码: 全选

sudo apt-get install girlfriend
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。
下列的信息可能会对解决问题有所帮助:
下列的软件包有不能满足的依赖关系:
girlfiend: 依赖: house但是它将不会被安装
girlfiend: 依赖: car但是它将不会被安装
house,car: 依赖: money但是它将不会被安装
E: 无法安装的软件包
头像
kxjhlele
帖子: 28
注册时间: 2010-03-08 9:56
送出感谢: 0
接收感谢: 0

Re: 新的Qipmsg0.9.5ipmsg安装办法。摸索了两天了跟大家分享一下

#2

帖子 kxjhlele » 2010-05-01 9:09

好贴,没人回……
回复

回到 “因特网相关软件”