当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu8.04在切换过XP后回来怎么就不能上网
帖子发表于 : 2008-11-08 12:23 

注册: 2008-11-03 18:46
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
首先将如何提高上网速度的方法转载给大家
适合人群:你在打开一个网站的时候,浏览器左下常时间显示“look up 网址“,这个就说明你的DNS解析出问题了
设置DNS缓冲池的方法告诉大家,我也是在论坛看到的,效果N明显

1、安装dnsmasq
sudo apt-get install dnsmasq

2、编辑dnsmasq的配置文件
sudo gedit /etc/dnsmasq.conf

找到下面这一项
#resolv-file=

用下面的一条语句替换
resolv-file=/etc/resolv_dnsmasq.conf

3、将原dns配置复制至resolv_dnsmasq.conf
sudo cp /etc/resolv.conf /etc/resolv_dnsmasq.conf

4、编辑resolv.conf
sudo gedit /etc/resolv.conf

将其中的域名服务器全部去掉,加入以下这行
nameserver 127.0.0.1
保存,退出

5、编辑adsl链接配置文件,防止pppoe自动连接网络后resolv.conf的设置被覆盖
sudo gedit /etc/ppp/peers/provider
在 usepeerdns 前面增加 # ,也就是把这条语句覆盖掉。
#usepeerdns

6、启动服务dnsmasq服务
直接sudo /etc/init.d/dnsmasq start
或者
使用sysv-rc-conf工具(和window系统控制面板的后台服务管理类似,sudo apt-get install sysv-rc-conf安装了,通过sudo sysv-rc-conf使用)来打开dnsmasq的默认开始状态和启用他。

1.问题来了:在我登录XP之后回到ubuntu的时候,我QQ可以登录,但是我不能上网了,发现是dnsmasq没有启动。
我是这样处理的:打开终端,只能再命令输入sudo /etc/init.d/dnsmasq start,就可以上网了
而我之前就已经sysv-rc-conf已经将各级别的dnsmasq服务全部设置打开了呵,我现在该如何自动启动dnsmasq,高手指点怎么搞的?

2.顺便问下,我安装了WINE来登录XP下QQ时候,可以启动QQ,但是没聊几分钟QQ必死,这又怎么回事阿?

3.目前我玩单机魔兽的时候需要以加opengl参数的命令才能登录wine war3.exe opengl,我上VS或者浩方平台,魔兽是有平台自动启动,参数我也不能加了,就启动不了了,怎么解决?


最后由 renxiong1984 编辑于 2008-11-09 21:33,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu8.04在切换过XP后回来怎么就不能上网
帖子发表于 : 2008-11-08 17:51 

注册: 2006-09-25 15:08
帖子: 167
送出感谢: 0 次
接收感谢: 0 次
会否是xp的网卡设置问题?

进入win,
网卡-属性-高级,里面有wake-on-lan after shutdown选项,
点之,选择右面下拉框,选中“enable".
重启。
再进ubuntu,可能就好了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译