[问题]我把LumaQQ安装完了!却运行不了!(解决不了)

上网、浏览、聊天、下载等
wandong
帖子: 18
注册时间: 2006-06-06 16:59
送出感谢: 0
接收感谢: 0

[问题]我把LumaQQ安装完了!却运行不了!(解决不了)

#1

帖子 wandong » 2006-06-07 23:00

以下就是安装的方法!我都照做了!但是没办法运行!


1. 安装JAVA环境(仅适合x86,PPC版见另外的文件)

*

如果出现需要输入[Y/n] 或 [y/N] 一律输入 y 并 回车

sudo apt-get install sun-j2re1.5
sudo ln -sf /usr/lib/j2re1.5-sun/bin/java /usr/bin/java

*

安装JRE 5的另一种方法,供参考。

sudo apt-get install sun-java5-jre

# 如果空间富裕,建议安装一个JDK。呵呵
sudo apt-get install sun-java5-jdk

export JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun-1.5.0.06
export PATH=${JAVA_HOME}/bin:${JAVA_HOME}/jre/bin:${PATH}

2. 安装QQ

*

1.下载并安装
*

安装QQ需要先安装JAVA环境

wget -c http://download.ubuntu.org.cn/software/ ... jre.tar.gz
sudo tar zxvf lumaqq_2005-linux_gtk2_x86_no_jre.tar.gz -C /opt/
wget -c http://download.ubuntu.org.cn/software/ ... .02.00.zip
sudo unzip -o lumaqq_2005_patch_2006.01.30.02.00.zip -d /opt/LumaQQ/lib
sudo chown -R root:root /opt/LumaQQ/
sudo chmod -R 755 /opt/LumaQQ/
sudo gedit /usr/share/applications/LumaQQ.desktop

2.在新增的文件内加入下面这几行

[Desktop Entry]
Name=LumaQQ
Comment=QQ Client
Exec=/opt/LumaQQ/lumaqq
Icon=/opt/LumaQQ/QQ.png
Terminal=false
Type=Application
Categories=Application;Network;

3.保存编辑过的文件 安装完成后的快捷方式在(应用程序 -> internat -> LumaQQ)。
上次由 wandong 在 2006-06-11 13:45,总共编辑 1 次。
rods
帖子: 181
注册时间: 2005-11-19 18:43
送出感谢: 0
接收感谢: 0

#2

帖子 rods » 2006-06-07 23:24

建议装一个带JRE的版本,华军有下,不用安装就可以运行
不积跬步,无以致千里

ArchLinux
wandong
帖子: 18
注册时间: 2006-06-06 16:59
送出感谢: 0
接收感谢: 0

#3

帖子 wandong » 2006-06-07 23:56

但是这样为什么不行呢!!它们有什么区别呢!
Vstar
帖子: 273
注册时间: 2005-10-03 14:13
来自: Tokushima, Japan
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 Vstar » 2006-06-08 0:03

在终端下输入/opt/LumaQQ/lumaqq,然后把错误信息贴上来,看一下错误是不是发生在jre上
wandong
帖子: 18
注册时间: 2006-06-06 16:59
送出感谢: 0
接收感谢: 0

#5

帖子 wandong » 2006-06-08 16:25

我对LINUX不懂!但是JAVA我会!这个很明显是找不到MAIN类!无法启动!但是我都照说的安的!为什么呢!
难道LumaQQ本来就有问题!



wandong@ubuntu:~$ sh /opt/LumaQQ/lumaqq

wandong@ubuntu:~$ /opt/LumaQQ/lumaqq
wandong@ubuntu:~$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /opt/LumaQQ/swt/libswt-pi-gtk-3138.so: /opt/LumaQQ/swt/libswt-pi-gtk-3138.so: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
at java.lang.Runtime.loadLibrary0(Runtime.java:822)
at java.lang.System.loadLibrary(System.java:992)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:122)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:121)
frank.chi
帖子: 10
注册时间: 2006-06-03 21:48
送出感谢: 0
接收感谢: 0

#6

帖子 frank.chi » 2006-06-08 20:46

我的现象和你一模一样,可是谁能帮帮我们阿, 谢谢
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#7

帖子 dbzhang800 » 2006-06-08 20:54

不是LumaQQ的问题
是java的版本不对

你用java -version
看看估计还是1.4.2

sudo update-alternatives --config java

在显示的屏幕上出现
1 /usr/bin/gij-wrapper-4.0
*+ 2 /usr/lib/jvm/java-gcj/bin/java
3 /usr/lib/j2sdk1.5-sun/bin/java

选择 3 java1.5的版本。

就可以了。
wandong
帖子: 18
注册时间: 2006-06-06 16:59
送出感谢: 0
接收感谢: 0

#8

帖子 wandong » 2006-06-08 22:46

楼上说的我都有做呀!

wandong@ubuntu:~$ java -version
java version "1.5.0_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_06-b05, mixed mode)
wandong@ubuntu:~$ /opt/LumaQQ/lumaqq
wandong@ubuntu:~$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /opt/LumaQQ/swt/libswt-pi-gtk-3138.so: /opt/LumaQQ/swt/libswt-pi-gtk-3138.so: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
at java.lang.Runtime.loadLibrary0(Runtime.java:822)
at java.lang.System.loadLibrary(System.java:992)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:122)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:121)

wandong@ubuntu:~$
wandong
帖子: 18
注册时间: 2006-06-06 16:59
送出感谢: 0
接收感谢: 0

#9

帖子 wandong » 2006-06-08 22:50

我也是用的3!但是就是问题仍在呀!

There are 3 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
1 /usr/bin/gij-wrapper-4.1
+ 2 /usr/lib/jvm/java-gcj/jre/bin/java
* 3 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

Press enter to keep the default[*], or type selection number:
wandong
帖子: 18
注册时间: 2006-06-06 16:59
送出感谢: 0
接收感谢: 0

#10

帖子 wandong » 2006-06-09 20:04

没人回答我呀!!我实在不知道了!!!难道AMD64的系统有问题吗?
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 nobrain » 2006-06-09 20:15

Exception in thread "main" java.lang.UnsatisfiedLinkError: /opt/LumaQQ/swt/libswt-pi-gtk-3138.so: /opt/LumaQQ/swt/libswt-pi-gtk-3138.so: cannot open shared object file: No such file or directory

我猜是找不到这两个文件,可能是启动脚本的问题,到 lumaqq 的主页上看看,我记得有新的启动脚本。
确定你的LumaQQ是否装在/opt/LumaQQ目录里。
爱喝真猪奶茶的夜鸣猪
wandong
帖子: 18
注册时间: 2006-06-06 16:59
送出感谢: 0
接收感谢: 0

#12

帖子 wandong » 2006-06-09 21:32

那两个文件存在!!不是那两个文件的问题!
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 nobrain » 2006-06-10 10:57

代码: 全选

chmod -R 755 /opt/LumaQQ

看看能不能解决
爱喝真猪奶茶的夜鸣猪
frank.chi
帖子: 10
注册时间: 2006-06-03 21:48
送出感谢: 0
接收感谢: 0

#14

帖子 frank.chi » 2006-06-10 11:11

我用7楼的方法试了一下,果然我的版本是1.4.2
用你的方法就可以运行QQ了,真爽,谢谢7楼楼主
wandong
帖子: 18
注册时间: 2006-06-06 16:59
送出感谢: 0
接收感谢: 0

#15

帖子 wandong » 2006-06-10 21:46

我不明白!我这是什么的问题!一看就是JAVA执行出了问题!
回复

回到 “因特网相关软件”