关于python:2.6.1和3.0.1有什么区别?

上网、浏览、聊天、下载等
回复
elanse
帖子: 30
注册时间: 2009-02-14 15:45
送出感谢: 0
接收感谢: 0

关于python:2.6.1和3.0.1有什么区别?

#1

帖子 elanse » 2009-02-18 11:26

如题,

Gappproxy说要支持https协议,必须python2.6才行,所以我查了一下python.org,发现13号新出来一个3.0.1的版本,可惜我英文不行,看不懂它和2.6.1有什么区别,英文达人帮忙看一下好吗?谢谢

另,本主题原本是问gappproxy for linux的,而且一开始我也没注意到帖子的编辑功能,所以第一个回复请大家直接无视
上次由 elanse 在 2009-02-18 13:29,总共编辑 1 次。
三人行,必有我師焉
elanse
帖子: 30
注册时间: 2009-02-14 15:45
送出感谢: 0
接收感谢: 0

Re: 关于GAppProxy:google app proxy,有没有linux版本的?

#2

帖子 elanse » 2009-02-18 11:31

哦,抱歉!
之前搜索的方向不对,所以一直没找到正确的东东,刚才反应过来,哈哈。

不过现在这个版本据说不支持https协议,需要python2.6才行,有空我再搞搞看,呵呵
三人行,必有我師焉
renstone
帖子: 1
注册时间: 2006-09-08 10:00
送出感谢: 0
接收感谢: 0

Re: 关于python:2.6.1和3.0.1有什么区别?

#3

帖子 renstone » 2009-02-18 19:49

自己下载源代码编译吧。我下了ActivePython的for AMD64的包,但是无法使用gappproxy的https模式,只好在www.python.org下载2.6.1的tar ball自己编译。
./configure --prefix=/opt
make
make install
修改.bashrc,添加export PATH=/opt/Python-2.6/bin;$PATH
然后在控制台下运行python以确认是在运行python 2.6。
最后运行proxy.py是就会出现https Enabled消息。
yyz139
帖子: 84
注册时间: 2007-01-07 15:04
送出感谢: 0
接收感谢: 0

Re: 关于python:2.6.1和3.0.1有什么区别?

#4

帖子 yyz139 » 2009-02-18 23:50

自己找去,Google上一大片...
用linux要学会自己找答案来解决问题,别光靠别人
贴一个wiki上的pyhton简介
http://zh.wikipedia.org/w/index.php?tit ... iant=zh-cn
里面就有你想要的
wonchipper
帖子: 9
注册时间: 2009-03-24 22:29
送出感谢: 0
接收感谢: 0

Re: 关于python:2.6.1和3.0.1有什么区别?

#5

帖子 wonchipper » 2009-04-13 19:18

renstone 写了:自己下载源代码编译吧。我下了ActivePython的for AMD64的包,但是无法使用gappproxy的https模式,只好在www.python.org下载2.6.1的tar ball自己编译。
./configure --prefix=/opt
make
make install
修改.bashrc,添加export PATH=/opt/Python-2.6/bin;$PATH
然后在控制台下运行python以确认是在运行python 2.6。
最后运行proxy.py是就会出现https Enabled消息。
按照上面的做了,可是https还是不行,迷惑中
wonchipper
帖子: 9
注册时间: 2009-03-24 22:29
送出感谢: 0
接收感谢: 0

Re: 关于python:2.6.1和3.0.1有什么区别?

#6

帖子 wonchipper » 2009-04-13 19:19

renstone 写了:自己下载源代码编译吧。我下了ActivePython的for AMD64的包,但是无法使用gappproxy的https模式,只好在www.python.org下载2.6.1的tar ball自己编译。
./configure --prefix=/opt
make
make install
修改.bashrc,添加export PATH=/opt/Python-2.6/bin;$PATH
然后在控制台下运行python以确认是在运行python 2.6。
最后运行proxy.py是就会出现https Enabled消息。
好像不行亚,还是不能实现https
头像
davoola
帖子: 134
注册时间: 2007-08-24 20:49
送出感谢: 0
接收感谢: 0

Re: 关于python:2.6.1和3.0.1有什么区别?

#7

帖子 davoola » 2009-09-27 17:06

请参考What's New in Python3.0
地址:http://docs.python.org/dev/3.0/whatsnew/3.0.html
寵辱不驚,閑看庭前花開花落;
去留無意,漫隨天外雲卷雲舒。
头像
Mr.Dict
帖子: 109
注册时间: 2007-10-26 12:47
送出感谢: 0
接收感谢: 0

Re: 关于python:2.6.1和3.0.1有什么区别?

#8

帖子 Mr.Dict » 2009-11-01 18:56

楼主的问题似乎可以换个角度去看,而不一定是纠结于Python的版本:

比如:修改自己上传的fetchserver\app.yaml内容,补充一行"secure: optional"即可。


以下摘自Google App Engine的Python 应用程序配置:[安全网址]
http://code.google.com/intl/zh-CN/appen ... ecure_URLs
安全网址

对于使用 *.appspot.com 域的网址,Google App Engine 支持通过 HTTPS 的安全连接。如果某个请求使用 HTTPS 访问网址,且该网址配置为使用 app.yaml 文件中的 HTTPS,则发件人在发送请求数据和响应数据前需要对其加密,收件人收到后需要将其解密。安全连接有利于保护客户数据,如联系人信息、密码和私人消息。

注意:Google 企业应用套件域目前不支持 HTTPS。HTTPS 支持限于通过 *.appspot.com 域访问的应用程序。在 Google 企业应用套件域上访问 HTTPS 网址将返回“找不到主机”错误,而使用 HTTP 访问其处理程序仅接受 HTTPS 的网址(参见下文)将返回 HTTP 403“禁止访问”错误。您可以为了安全起见而链接到具有 *.appspot.com 域的 HTTPS 网址,而针对网站的其余部分使用企业应用套件域和 HTTP。

要将网址配置为接受安全连接,请为处理程序提供 secure 参数:

handlers:

- url: /youraccount/.*
script: accounts.py
login: required
secure: always

secure 具有 3 个可能的值:

* never。对与该处理程序(使用 HTTPS)匹配的网址的请求将被自动重定向到 HTTP 同义网址。在没有为处理程序提供 secure 的情况下,这是默认设置。
* always。对与该处理程序(不使用 HTTPS)匹配的网址的请求将被自动重定向到相同路径的 HTTPS 网址。保留查询参数,以便重定向。
* optional。对与处理程序匹配的网址的 HTTP 和 HTTPS 请求均将成功,无需重定向。应用程序可检查请求以确定所使用的协议,并相应地作出响应。
头像
Mr.Dict
帖子: 109
注册时间: 2007-10-26 12:47
送出感谢: 0
接收感谢: 0

Re: 关于python:2.6.1和3.0.1有什么区别?

#9

帖子 Mr.Dict » 2009-11-01 19:09

另外,Google App Engine对Python的版本支持最好的还是2.5吧?
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

Re: 关于python:2.6.1和3.0.1有什么区别?

#10

帖子 syrano » 2009-11-03 12:04

python2.6.1的程序, 3.0运行不了.
3.0不再向下兼容.
E=m c^2
回复

回到 “因特网相关软件”