当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于firefox关键字域名解析优化,dns劫持,自动转向的问题(解决)
帖子发表于 : 2009-04-19 11:48 
头像

注册: 2009-04-17 10:42
帖子: 764
送出感谢: 0 次
接收感谢: 1
以前在win下的firefox,地址栏输入一个词,直接回车,就可以自动匹配下拉列表里第一个网址,或者直接打开google的搜索页面
在linux下尝试了很久,在输入一个关键词的情况下,都不能完成搜索,也不能自动匹配第一个查找出来的网址
比如:我在地址栏输入“我的”
回车的结果是打开“http://sddns5.cncmax.cn:8080/?HOST=xn--wnu286b&R=/&”
其中“我的”这俩字被firefox转换成了“xn--wnu286b”
然后他尝试打开的网页也是:http://xn--wnu286b,而不是下拉列表里的第一个项目~~
如果想正确激活google的搜索页面,必须输入两个词关键词后边随便加个空格再加个东西才行,比如“我的 a”

问题简化一下就是:
1,怎么让他自动匹配第一个列表记录
2,怎么让firefox在输入一个词的情况下,就启动google搜索

我知道可以用tab去选第一个,但是这就多出来一次按键~~~~难道只能从使用习惯上修改么?


_________________
恨不死的阿弥陀,历尽千重罪,炼就不死心,来吧,一起配置Ubuntu
Ubuntu9.04配置手记


最后由 kurai 编辑于 2009-04-25 0:07,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 问个关于firefox地址栏的使用问题
帖子发表于 : 2009-04-19 15:51 
头像

注册: 2008-02-23 17:31
帖子: 401
送出感谢: 0 次
接收感谢: 1
在地址栏输入about:config,找到keyword.URL键,设置相应的值即可。例如要使用Google搜索,就设置为
http://www.google.com/search?ie=utf-8&o ... firefox&q=
要使用Google的手气不错功能,就设置为
http://www.google.com/search?btnI=I%27m ... e=UTF-8&q=
即可.


_________________
My Blog: matlab, ubuntu, python
http://goo.gl/GDIO


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 问个关于firefox地址栏的使用问题
帖子发表于 : 2009-04-19 16:55 
头像

注册: 2009-04-17 10:42
帖子: 764
送出感谢: 0 次
接收感谢: 1
呃,谢谢楼上,
可是不是我要问的问题,搜索引擎是没问题的,现在我是觉得ubuntu下,输入一个词,回车确认,fox是不会自动搜索的,firefox把这个词转换编码,然后当成一个网址解析了,
相同的情况放到xp下的fox里,确是另一回事,如果列表里有相近的,就直接进入该网址,如果没有相近的,就当成一个关键词搜索,不会转换编码,也不会当成网址解析哦~~~

现在虽然我知道,输完一个词,要么点个tab选首选网址,要么加个空格和字符,启动搜索引擎,很麻烦很麻烦~~~
难道这个使用问题大家都没遇到过么?


_________________
恨不死的阿弥陀,历尽千重罪,炼就不死心,来吧,一起配置Ubuntu
Ubuntu9.04配置手记


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 问个关于firefox地址栏的使用问题
帖子发表于 : 2009-04-23 10:12 
头像

注册: 2009-04-17 10:42
帖子: 764
送出感谢: 0 次
接收感谢: 1
引用:
哎,都没人关心这个问题阿~~
这个问题终于让我解决了一半了~~
分享一下解决办法吧:
首先问题跟我想得方向有点出入,字符被转成"xn-XXXX",原来是国际域名转换搞得鬼,firefox默认是开启得,这样输入一个任意字符的时候,都会被转换成xn的形式,然后去搜索这个域名,在xp下,如果这个域名没搜到,会自动转向到google搜索得试试手气里,
我在firefox下,却被cncmax.cn劫持了~~,显示得是服务商得网页~~~XXXXX得~~
对于前个问题,可以用这个设置项关闭:
代码:
about:config
network.enableIDN    改为false

这样改过之后,在地址栏输入字母得时候,还是会去搜索域名,但是输入汉字得时候,就会马上转到google搜索,比原来去域名解析得时候,速度快了很多很多,可以作为一项速度优化了~~~
dns劫持这个,我暂时没解决,因为我设了本地得dns服务,可是不会修改配置文件,在hosts里添加项,也不管用,找不到域名的网址还是继续转到cncmax.cn,为什么xp下就能自动转向阿?明明是用得同一个网络,同一个dns地址~~~~
以前得老版本里有个配置项是browser. goBrowsing. enabled,这个就是自动转向得开关,但是现在被废弃了,我添加进去,也没什么用了~~
插件库里,也有个自动转向得插件,忘记名字了,试了试,还是被cncmax劫持~~晕死了~~~
谁能教教我,怎么在ubuntu下搞定dns劫持?
我添加了这个服务得:
dnsmasq

另外,对于输入一个单词,想要直接转到google搜索,而不经过域名转换得步骤得话,可以在字符后面跟上一个']'或者'`',总之你方便输入得一个符号,然后回车,就会直接google搜索,而不去寻找匹配得域名.


问题已解决,更新到手记里去了,请关注
viewtopic.php?f=77&t=196208&p=1219184#p1219184
3楼,第36条查看,dns服务器的安装,在1楼的12条


_________________
恨不死的阿弥陀,历尽千重罪,炼就不死心,来吧,一起配置Ubuntu
Ubuntu9.04配置手记


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 关于firefox关键字域名解析优化,dns劫持,自动转向的问题(解决)
帖子发表于 : 2009-08-17 23:58 

注册: 2008-09-14 19:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
about:config

keyword.URL http://www.google.com/search?btnI=I%27m ... e=UTF-8&q=
keyword.enabled true

这样设置试试


我一直认为,地址栏不应用于搜索。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译