当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : firefox不能显示JAVA页面[已解决]
帖子发表于 : 2009-05-05 9:13 
头像

注册: 2009-01-05 9:03
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
firefox 3.0.10
刚换了UBUNTU9.04碰到了很多问题,其中一个搞不定的就是“如题”的问题。带JAVA程序的页面时在下面的任务栏会提示“启动:未初始化小程序”。 :em20
UBUNTU9.04带的JVM是什么OPENJDK的,后来我又在SUN的网站下载安装了一个jre1.6.0_13,也是出现同样的问题。但奇怪的是我在访问SUN的测试页的时候,那个跳跃的公爵可以看到。
以下是提示:
you are using an older version of JRE. You can download the latest version from the Java Software Download link above
you java configuration is:
vendo: sun Microsystems inc.
version: java 6 update
operation system:linux
我想1.6的应该不会低呀。

以下是我执行update-alternatives --config java显示的结果,帮忙看一下是什么问题。 :em20 我喜欢解决问题,而不喜欢重装系统,谢谢!
jordie@ubuntu:~/program/thunderbird$ sudo update-alternatives --config java
[sudo] password for jordie:
现有 2 个可选项,它们都提供了“java”<

选择 可选项
-----------------------------------------------
+ 1 /usr/lib/jvm/java-6-openjdk/jre/bin/java
* 2 /usr/java/jre1.6.0_13/bin/java

要维持缺省值[*],按回车键,或者键入选择的编号:


_________________
近期学习Glusterfs、KVM...


最后由 jordie 编辑于 2009-05-07 9:02,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: firefox不能显示JAVA页面
帖子发表于 : 2009-05-05 12:35 
头像

注册: 2007-12-05 12:25
帖子: 1153
送出感谢: 0 次
接收感谢: 0 次
首先把没用的都删掉。

然后:
如果想作开发,可以装这个:
代码:
sudo apt-get install sun-java6-jdk

如果只是想运行一下,可以装这个:
代码:
sudo apt-get install sun-java6-jre


然后再
代码:
sudo update-alternatives --config java

选择刚刚装好的那个java。

还有这个:
代码:
sudo apt-get install sun-java6-plugin


还可以在浏览器中安装,如图
附件:
Screenshot-插件搜索服务.png
Screenshot-插件搜索服务.png [ 60.04 KiB | 被浏览 4228 次 ]

附件:
Screenshot-无标题窗口.png
Screenshot-无标题窗口.png [ 43.26 KiB | 被浏览 4222 次 ]



页首
 用户资料  
 
3 楼 
 文章标题 : Re: firefox不能显示JAVA页面
帖子发表于 : 2009-05-06 8:53 
头像

注册: 2009-01-05 9:03
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
谢谢 darasion 的回复,我照你的方法做了,但还是有不行。
“sudo apt-get install sun-java6-plugin ”这条代码应该是给浏览器安装插件的,我也执行了,安装后在FIREFOX里的插件里没有看到“The Jave(TM)Plug-in,Java SE 6”的,但好像多了一个"libnpjp2.so"的插件,不知道是什么,当我把libnpjp2.so和以前旧的"Java(TM)Plug-in 1.6.0_13-b03"和“IcedTea Java Web Browser Plugin”都禁用的时候,我在打开我的一个带JAVA的页面进会提示安装插件,我根据提示,也就是 darasion 回复的附件里的“The Jave(TM)Plug-in,Java SE 6”,选择安装后提示已经安装。

顺便问一下要如何删掉以前安装的那一个系统自带的“OPENJDK”和“jre1.6.0_13”? :em01
现在还是跟以前一样任务栏会提示“启动:未初始化小程序”。 :em20
我现在安装的情况如下:

现有 3 个可选项,它们都提供了“java”<

选择 可选项
-----------------------------------------------
+ 1 /usr/lib/jvm/java-6-openjdk/jre/bin/java
* 2 /usr/java/jre1.6.0_13/bin/java
3 /usr/lib/jvm/java-6-sun/jre/bin/java

要维持缺省值[*],按回车键,或者键入选择的编号:3
使用“/usr/lib/jvm/java-6-sun/jre/bin/java”来提供“java”。


附件:
Screenshot-附加组件.png
Screenshot-附加组件.png [ 118.42 KiB | 被浏览 4190 次 ]



_________________
近期学习Glusterfs、KVM...
页首
 用户资料  
 
4 楼 
 文章标题 : Re: firefox不能显示JAVA页面
帖子发表于 : 2009-05-07 9:00 
头像

注册: 2009-01-05 9:03
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
darasion 写道:
首先把没用的都删掉。

这一条就是关键,其实我的根问题就是UBUNTU9.04自带的OPENJDK(不知道是哪个组织或公司开发的)不兼容我的JAVA(思科的asdm还有另一个raritan的JAVA程序)。删掉后装sun的java6的版本就可以了,之前装了一个sun的1.6的版本也还是不行,可能是版本太低,只怪自己对JAVA的版本不了解。
此次安装采用二楼的兄弟的第二种方式,当删掉所有的JAVA版本后,打开带JAVA程序的页面时自己会提示安装插件,选择安装一个6的版本就好了。
另外删除JAVA的所有版本可以在“新立得软件管理”里删。


_________________
近期学习Glusterfs、KVM...


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译