当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 162 篇帖子 ]  前往页数 1, 2, 3, 4, 5 ... 11  下一页
作者 内容
1 楼 
 文章标题 : 让aMule支持DLP的源码补丁(1月24日更新了~)
帖子发表于 : 2009-10-17 18:36 
头像

注册: 2009-02-24 13:07
帖子: 40
送出感谢: 0 次
接收感谢: 0 次

--------------------------------------------------------

本帖已经不再更新,amule-dlp的最新动态请看: viewtopic.php?f=73&t=273010

---------------------------------------------------------


因为aMule没有提供插件功能,只能靠修改aMule源码的方法把DLP编译进aMule去,所以需要重新编译安装aMule。

这个源码补丁使用的DLP是官方的39版本。fzh的DLP似乎在国内效果更好,但是源码没有公开,目前只好先使用官方的DLP。

3904更新说明
· 合并了 Bill Lee 对迅雷检测的修改
· 增加了GUI的设置界面,可以自行选择使用哪些检测手段
· 参照 DLP Strict 增加了屏蔽 VeryCD Mod 和 easyMule 的选项,提供给有需要的人使用。这两个屏蔽选项默认是不启用的。另外,对于 VeryCD Mod 和 easyMule 的检测还不完善,目前还存在漏检
· 修复检测 HelloTag 时使用了错误的数据的鬼
· 增加对 InfoTag 的检测
· 修复一些崩溃问题

这个版本我只在自己的机子上跑了不到一天的时间,不知到长时间运行的稳定性如何,而且在不同的环境上可能也会出现不同的问题。如果在编译或运行的时候出现错误,请报告到回帖中。

重点说明,对 VeryCD Mod 的屏蔽是因为其有不良行为,而对 easyMule 的检测是因为其涉嫌违反GPL。详情请自行谷歌 DLP Strict。是否屏蔽这两个客户端请自行斟酌。

下载地址

aMule-2.2.6 DLP支持源码补丁: http://libantixunlei.googlecode.com/fil ... 3904.patch

以前的源码补丁,3902版开始才是稳定版:
http://libantixunlei.googlecode.com/fil ... 3902.patch
http://libantixunlei.googlecode.com/fil ... 3902.patch (存在一个误杀纯中文用户名用户的问题)
http://libantixunlei.googlecode.com/fil ... 3901.patch (该版本存在一个未处理std::out_of_range异常的问题,会导致崩溃)
http://libantixunlei.googlecode.com/fil ... LP39.patch (部分系统下会在运行几分钟后崩溃,15L,20L)

另外方便不清楚如何给源码打补丁的人准备了已经打好3903版本补丁的源码,下载回来以后可以直接编译安装: http://libantixunlei.googlecode.com/fil ... 03.tar.bz2

PPA源请看: viewtopic.php?f=95&t=233117

补丁的使用方法,以及编译安装的方法

下载aMule-2.2.6 的源码包和DLP源码补丁,并解压出来。
进入aMule的源码目录应用DLP源码补丁

代码:
cd aMule-2.2.6
patch -p0 < ../aMule-2.2.6-DLP3904.patch


编译和安装

开始安装之前,先安装一些必要的软件包:
代码:
sudo apt-get install g++ binutils-dev libcrypto++-dev libgtk2.0-dev libgd2-xpm-dev libgeoip-dev libupnp3-dev zlib1g-dev libwxbase2.8-dev libwxgtk2.8-dev


然后就正式开始编译并安装
代码:
./configure --prefix=/usr --disable-debug --enable-optimize --enable-upnp --enable-geoip --enable-nls --enable-amulecmd --enable-alcc -enable-alc --enable-cas --enable-wxcas --enable-mmap
# 编译需要较长时间,如果CPU是双核的话可以 make -j2 同时使用两个线程进行编译
make
sudo make install

之后就可以使用带有DLP的aMule了,如果有吸血驴被屏蔽的话,就会在aMule日志中显示出来。

如果崩溃的话

从3903版本开始补丁就已经比较稳定了,但是时不时还是会收到一些网友反馈上来的崩溃报告,有些错误可能是官方版就已经存在的,如果发现崩溃的话,请看本主题83楼: viewtopic.php?f=73&t=232845&p=1626332#p1626332


附件:
文件注释: 注意看右边稍靠下的蓝字
Screenshot-aMule 2.2.6-封杀.png
Screenshot-aMule 2.2.6-封杀.png [ 131.79 KiB | 被浏览 15544 次 ]

Screenshot-aMule 2.2.6-日志.png
Screenshot-aMule 2.2.6-日志.png [ 223.38 KiB | 被浏览 15544 次 ]



_________________
叫我greensea吧 [@lvhai]

虽然现在这个用户名是midoriumi,但实际上是我把自己注册的greensea的密码给忘记了,于是只好再注册一个midoriumi,字面意思也和greensea一样是緑海(みどりうみ)。所以,叫我greensea或GS吧。


最后由 midoriumi 编辑于 2010-07-14 14:26,总共编辑了 15 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 19:07 
头像

注册: 2009-03-10 13:04
帖子: 7803
送出感谢: 1
接收感谢: 0 次
很好
安装也说明的很具体,菜鸟可以直接搞定


_________________
广告位招租


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 19:31 
头像

注册: 2009-03-19 9:19
帖子: 1423
地址: 江苏
送出感谢: 0 次
接收感谢: 2
不错 支持 :em11 9.10下编译出错 :em20

代码:
may@may-desktop:~/aMule-2.2.6-DLP39$ ./configure --prefix=/usr --disable-debug --enable-optimize --enable-upnp --enable-geoip --enable-nls --enable-amulecmd --enable-alcc -enable-alc --enable-cas --enable-wxcas --enable-mmap
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking if this is a FreeBSD 4 or earlier system... no
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for gawk... (cached) mawk
checking for egrep... grep -E
checking whether make sets $(MAKE)... (cached) yes
checking for flex... no
checking for lex... no
checking for yywrap in -lfl... no
checking for yywrap in -ll... no
checking for a BSD-compatible install... /usr/bin/install -c
checking for ranlib... ranlib
checking for bison... no
checking for byacc... no
checking for ranlib... (cached) ranlib
checking for strip... strip
checking for ar... ar
checking for ld... ld
checking for zlib >= 1.1.4... yes (version 1.2.3.3)
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for gdlib-config... /usr/bin/gdlib-config
checking for gdlib version >= 2.0.0... yes (version 2.0.36)
checking gd.h usability... yes
checking gd.h presence... yes
checking for gd.h... yes
checking for File::Copy... ok
checking whether we need the GUI... yes
checking GeoIP.h usability... yes
checking GeoIP.h presence... yes
checking for GeoIP.h... yes
checking for GeoIP_open in -lGeoIP... yes
checking for the --with-toolkit option... will be automatically detected
checking for the --with-wxshared option... will be automatically detected
checking for the --with-wxdebug option... will be automatically detected
checking for the --with-wxversion option... will be automatically detected
checking for wx-config... no
configure: error:
      wxWidgets must be installed on your system but wx-config
      script couldn't be found. Please check that wx-config is
      in path or specified by --with-wx-config=path flag, the
      directory where wxWidgets libraries are installed (returned
      by 'wx-config --libs' command) is in LD_LIBRARY_PATH or
      equivalent variable and wxWidgets version is 2.8.0 or above.
   
may@may-desktop:~/aMule-2.2.6-DLP39$ make
make: *** 没有指明目标并且找不到 makefile。 停止。
may@may-desktop:~/aMule-2.2.6-DLP39$


新立德搜索安装wxWidgets后
代码:
...
Compiling UploadClient.cpp
Compiling UploadQueue.cpp
In file included from antiLeech.cpp:19,
                 from UploadQueue.cpp:26:
antiLeech_unix.h: In function ‘char* _tcsstr(const char*, const char*)’:
antiLeech_unix.h:31: error: invalid conversion from ‘const char*’ to ‘char*’
antiLeech_unix.h: In function ‘char* StrStr(const char*, const char*)’:
antiLeech_unix.h:37: error: invalid conversion from ‘const char*’ to ‘char*’
make[3]: *** [amule-UploadQueue.o] 错误 1
make[2]: *** [all-recursive] 错误 1
make[1]: *** [all-recursive] 错误 1
make: *** [all] 错误 2
may@may-desktop:~/aMule-2.2.6-DLP39$


_________________


最后由 mickeywaley 编辑于 2009-10-17 20:34,总共编辑了 2 次

页首
 用户资料  
 
4 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 19:34 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
对amule-deamon有效吗?


_________________
E=m c^2


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 19:38 
头像

注册: 2007-09-10 20:20
帖子: 1352
地址: 南京
系统: Debian
送出感谢: 0 次
接收感谢: 0 次
这个好,不过又要再编译安装了


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 20:22 
头像

注册: 2009-02-24 13:07
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
syrano 写道:
对amule-deamon有效吗?


同样有效,我也改写了amulet-daemon部分的代码
不过我没有测试amule-daemon


_________________
叫我greensea吧 [@lvhai]

虽然现在这个用户名是midoriumi,但实际上是我把自己注册的greensea的密码给忘记了,于是只好再注册一个midoriumi,字面意思也和greensea一样是緑海(みどりうみ)。所以,叫我greensea或GS吧。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 20:23 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
楼主又发精华贴了。。。看不懂源码的路过帮顶。。。 :em11


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 20:43 
头像

注册: 2009-02-24 13:07
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
mickeywaley 写道:
不错 支持 :em11 9.10下编译出错 :em20

代码:

新立德搜索安装wxWidgets后
[code]
...
Compiling UploadClient.cpp
Compiling UploadQueue.cpp
In file included from antiLeech.cpp:19,
                 from UploadQueue.cpp:26:
antiLeech_unix.h: In function ‘char* _tcsstr(const char*, const char*)’:
antiLeech_unix.h:31: error: invalid conversion from ‘const char*’ to ‘char*’
antiLeech_unix.h: In function ‘char* StrStr(const char*, const char*)’:
antiLeech_unix.h:37: error: invalid conversion from ‘const char*’ to ‘char*’
make[3]: *** [amule-UploadQueue.o] 错误 1
make[2]: *** [all-recursive] 错误 1
make[1]: *** [all-recursive] 错误 1
make: *** [all] 错误 2
may@may-desktop:~/aMule-2.2.6-DLP39$


谢谢反馈,我找另一台机子编译看看能不能重现这个错误
另外能否告知g++版本号?


_________________
叫我greensea吧 [@lvhai]

虽然现在这个用户名是midoriumi,但实际上是我把自己注册的greensea的密码给忘记了,于是只好再注册一个midoriumi,字面意思也和greensea一样是緑海(みどりうみ)。所以,叫我greensea或GS吧。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 21:05 
头像

注册: 2007-10-18 17:40
帖子: 1006
送出感谢: 0 次
接收感谢: 0 次
arch下:

引用:
g++ (GCC) 4.4.1
Copyright © 2009 Free Software Foundation, Inc.


引用:
Compiling UploadQueue.cpp
In file included from antiLeech.cpp:19,
from UploadQueue.cpp:26:
antiLeech_unix.h: In function ‘char* _tcsstr(const char*, const char*)’:
antiLeech_unix.h:31: 错误:从类型‘const char*’到类型‘char*’的转换无效
antiLeech_unix.h: In function ‘char* StrStr(const char*, const char*)’:
antiLeech_unix.h:37: 错误:从类型‘const char*’到类型‘char*’的转换无效
make[3]: *** [amule-UploadQueue.o] 错误 1
make[2]: *** [all-recursive] 错误 1
make[1]: *** [all-recursive] 错误 1
make: *** [all] 错误 2


_________________

千帖户,享有论坛特权!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 21:59 
头像

注册: 2009-02-24 13:07
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
3楼和9楼的朋友,我已经修改出错部分的代码了,请重新下载补丁(地址没变,小心Firefox的缓存,记得先撤销原来的补丁),应该能编译通过了。

错误原因是头文件中strstr()函数返回值的定义,Ubuntu 8.10 下头文件定义的返回值不够严格,所以我编译时没出错。

其实只要将 antiLeech_unix.h 31行和37行两个函数的返回值改成const char* 就可以了。


_________________
叫我greensea吧 [@lvhai]

虽然现在这个用户名是midoriumi,但实际上是我把自己注册的greensea的密码给忘记了,于是只好再注册一个midoriumi,字面意思也和greensea一样是緑海(みどりうみ)。所以,叫我greensea或GS吧。


最后由 midoriumi 编辑于 2009-10-18 15:06,总共编辑了 1 次

页首
 用户资料  
 
11 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 22:01 
头像

注册: 2008-12-21 15:27
帖子: 5349
地址: TARDIS
送出感谢: 1
接收感谢: 10
mark :em11


_________________


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 22:52 
头像

注册: 2009-03-19 9:19
帖子: 1423
地址: 江苏
送出感谢: 0 次
接收感谢: 2
代码:
./configure --prefix=/usr --disable-debug --enable-optimize --enable-upnp --enable-geoip --enable-nls --enable-amulecmd --enable-alcc -enable-alc --enable-cas --enable-wxcas --enable-mmap

#删除刚错误的
代码:
make uninstall

:em11
下载软件继续编译 http://libantixunlei.googlecode.com/files/aMule-2.2.6-DLP39.tar.bz2
:em11
代码:
./configure --prefix=/usr --disable-debug --enable-optimize --enable-upnp --enable-geoip --enable-nls --enable-amulecmd --enable-alcc -enable-alc --enable-cas --enable-wxcas --enable-mmap
# 编译需要较长时间,如果CPU是双核的话可以 make -j2 同时使用两个线程进行编译
make
sudo make install


这次OK了 :em09

用makefile的源码打包

在源码所在的目录下用make命令来编译,然后用checkinstall命令来打包. 若没有checkinstall命令则可以先安装
代码:
apt-get install checkinstall
.一会试试去

文章出处:http://www.diybl.com/course/6_system/linux/Linuxjs/2008611/124675.html
====================
引用:
ubuntu 源码编译安装软件,并制作DEB软件包!!!

配置基础开发环境GCC

刚装好的系统中已经有GCC了,但是这个GCC几乎什么文件都不能编译,因为缺少一些必须的头文件,所以要安装build-essential这个软件包。 可以在新立得里面搜索build-essential或输入下面命令:

sudo apt-get install build-essential

安装GTK/GNOME开发环境

安装GTK环境只要安装一个libgtk2.0-dev就可以了,而安装gnome开发环境的话,需要装gnome-core-devel,它包含GTK开发包。 但在一般情况下,我们需要有一个ide开发环境,需要帮助文件,于是我们安装
sudo apt-get install gnome-devel gnome-dev-doc

根据软件包的不同可能还存在对其他软件包的依赖,根据错误提示进行安装所需软件包

sudo apt-get install dpkg-dev dh-make debhelper fakeroot gnupg pbuilder
制作DEB软件包
解压后进入源码包目录,执行
代码:
./configure
make
sudo checkinstall -D make install
用此方法初次打包


代码:
may@may-desktop:~/Compile-Software/aMule-2.2.6-DLP39$ sudo checkinstall -D make install
[sudo] password for may:

checkinstall 1.6.1, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
本软件以 GNU GPL 版权协议颁布



*****************************************
**** Debian package creation selected ***
*****************************************

*** Warning: The package name "aMule-2.2.6" contains upper case
*** Warning: letters. dpkg might not like that so I changed
*** Warning: them to lower case.

软件包将用下面的值来创建:

0 -  Maintainer: [ root@may-desktop ]
1 -  Summary: [ aMule-2.2.6-DLP39-ubuntu9.10 ]
2 -  Name:    [ amule-2.2.6 ]
3 -  Version: [ DLP39 ]
4 -  Release: [ 1 ]
5 -  License: [ GPL ]
6 -  Group:   [ checkinstall ]
7 -  Architecture: [ i386 ]
8 -  Source location: [ aMule-2.2.6-DLP39 ]
9 -  Alternate source location: [  ]
10 - Requires: [  ]
11 - Provides: [ amule-2.2.6 ]

输入一个数字来改变它们,或按回车键继续:

Installing with make...Installing with install...

=============================== 安装结果 =================================
Installing /usr/share/locale/ar/LC_MESSAGES/amule.mo
Installing /usr/share/locale/ast/LC_MESSAGES/amule.mo
Installing /usr/share/locale/bg/LC_MESSAGES/amule.mo
Installing /usr/share/locale/ca/LC_MESSAGES/amule.mo
Installing /usr/share/locale/cs/LC_MESSAGES/amule.mo
Installing /usr/share/locale/da/LC_MESSAGES/amule.mo
Installing /usr/share/locale/de/LC_MESSAGES/amule.mo
Installing /usr/share/locale/el/LC_MESSAGES/amule.mo
Installing /usr/share/locale/en_GB/LC_MESSAGES/amule.mo
Installing /usr/share/locale/es/LC_MESSAGES/amule.mo
Installing /usr/share/locale/et_EE/LC_MESSAGES/amule.mo
Installing /usr/share/locale/eu/LC_MESSAGES/amule.mo
Installing /usr/share/locale/fi/LC_MESSAGES/amule.mo
Installing /usr/share/locale/fr/LC_MESSAGES/amule.mo
Installing /usr/share/locale/gl/LC_MESSAGES/amule.mo
Installing /usr/share/locale/he/LC_MESSAGES/amule.mo
Installing /usr/share/locale/hr/LC_MESSAGES/amule.mo
Installing /usr/share/locale/hu/LC_MESSAGES/amule.mo
Installing /usr/share/locale/it/LC_MESSAGES/amule.mo
Installing /usr/share/locale/it_CH/LC_MESSAGES/amule.mo
Installing /usr/share/locale/ja/LC_MESSAGES/amule.mo
Installing /usr/share/locale/ko_KR/LC_MESSAGES/amule.mo
Installing /usr/share/locale/lt/LC_MESSAGES/amule.mo
Installing /usr/share/locale/nl/LC_MESSAGES/amule.mo
Installing /usr/share/locale/nn/LC_MESSAGES/amule.mo
Installing /usr/share/locale/pl/LC_MESSAGES/amule.mo
Installing /usr/share/locale/pt_BR/LC_MESSAGES/amule.mo
Installing /usr/share/locale/pt_PT/LC_MESSAGES/amule.mo
Installing /usr/share/locale/ru/LC_MESSAGES/amule.mo
Installing /usr/share/locale/sl/LC_MESSAGES/amule.mo
Installing /usr/share/locale/sq/LC_MESSAGES/amule.mo
Installing /usr/share/locale/sv/LC_MESSAGES/amule.mo
Installing /usr/share/locale/tr/LC_MESSAGES/amule.mo
Installing /usr/share/locale/uk/LC_MESSAGES/amule.mo
Installing /usr/share/locale/zh_CN/LC_MESSAGES/amule.mo
Installing /usr/share/locale/zh_TW/LC_MESSAGES/amule.mo
Installing /usr/man/man1/amulecmd.1
Installing /usr/man/de/man1/amulecmd.1
Installing /usr/man/es/man1/amulecmd.1
Installing /usr/man/eu/man1/amulecmd.1
Installing /usr/man/fr/man1/amulecmd.1
Installing /usr/man/hu/man1/amulecmd.1
Installing /usr/man/it/man1/amulecmd.1
Installing /usr/man/man1/amule.1
Installing /usr/man/de/man1/amule.1
Installing /usr/man/es/man1/amule.1
Installing /usr/man/eu/man1/amule.1
Installing /usr/man/fr/man1/amule.1
Installing /usr/man/hu/man1/amule.1
Installing /usr/man/it/man1/amule.1
Installing /usr/man/man1/ed2k.1
Installing /usr/man/de/man1/ed2k.1
Installing /usr/man/es/man1/ed2k.1
Installing /usr/man/eu/man1/ed2k.1
Installing /usr/man/fr/man1/ed2k.1
Installing /usr/man/hu/man1/ed2k.1
Installing /usr/man/it/man1/ed2k.1
Installing /usr/share/doc/aMule-2.2.6/ABOUT-NLS
Installing /usr/share/doc/aMule-2.2.6/amulesig.txt
Installing /usr/share/doc/aMule-2.2.6/amule-win32.HOWTO.txt
Installing /usr/share/doc/aMule-2.2.6/Changelog
Installing /usr/share/doc/aMule-2.2.6/ED2K-Links.HOWTO
Installing /usr/share/doc/aMule-2.2.6/INSTALL
Installing /usr/share/doc/aMule-2.2.6/license.txt
Installing /usr/share/doc/aMule-2.2.6/README
Installing /usr/share/doc/aMule-2.2.6/TODO
Installing /usr/share/doc/aMule-2.2.6/EC_Protocol.txt
Installing /usr/share/doc/aMule-2.2.6/socks4.protocol
Installing /usr/man/man1/xas.1
Installing /usr/man/de/man1/xas.1
Installing /usr/man/es/man1/xas.1
Installing /usr/man/eu/man1/xas.1
Installing /usr/man/hu/man1/xas.1
Installing /usr/bin/autostart-xas
Installing /usr/lib/xchat/plugins/xas.pl
Installing /usr/man/man1/cas.1
Installing /usr/man/de/man1/cas.1
Installing /usr/man/es/man1/cas.1
Installing /usr/man/eu/man1/cas.1
Installing /usr/man/hu/man1/cas.1
Installing /usr/bin/cas
Installing /usr/share/cas/tmp.html
Installing /usr/share/cas/stat.png
Installing /usr/bin/wxcas
Installing /usr/man/man1/wxcas.1
Installing /usr/man/de/man1/wxcas.1
Installing /usr/man/es/man1/wxcas.1
Installing /usr/man/eu/man1/wxcas.1
Installing /usr/man/hu/man1/wxcas.1
Installing /usr/share/pixmaps/wxcas.xpm
Installing /usr/share/applications/wxcas.desktop
Installing /usr/bin/alc
Installing /usr/bin/alcc
Installing /usr/man/man1/alc.1
Installing /usr/man/de/man1/alc.1
Installing /usr/man/es/man1/alc.1
Installing /usr/man/eu/man1/alc.1
Installing /usr/man/hu/man1/alc.1
Installing /usr/man/man1/alcc.1
Installing /usr/man/de/man1/alcc.1
Installing /usr/man/es/man1/alcc.1
Installing /usr/man/eu/man1/alcc.1
Installing /usr/man/fr/man1/alcc.1
Installing /usr/man/hu/man1/alcc.1
Installing /usr/share/pixmaps/alc.xpm
Installing /usr/share/applications/alc.desktop
Installing /usr/share/amule/skins/gnome.zip
Installing /usr/share/amule/skins/kde4.zip
Installing /usr/share/amule/skins/tango.zip
Installing /usr/share/amule/skins/xfce.zip
Installing /usr/bin/amule
Installing /usr/bin/amulecmd
Installing /usr/bin/ed2k
Installing /usr/share/pixmaps/amule.xpm
Installing /usr/share/applications/amule.desktop

=============================== 安装成功 =================================

Copying documentation directory...
./
./README.Debian-Packages
./ABOUT-NLS
./docs/
./docs/TODO
./docs/Doxyfile
./docs/Makefile.am
./docs/COPYING
./docs/amulesig.txt
./docs/Makefile.in
./docs/README.Windows.txt
./docs/Releases.dia
./docs/socks4.protocol
./docs/README.Mac.txt
./docs/man/
./docs/man/ed2k.eu.1
./docs/man/amulecmd.hu.1
./docs/man/amule.eu.1
./docs/man/amuleweb.it.1
./docs/man/amule.it.1
./docs/man/amuleweb.eu.1
./docs/man/Makefile.am
./docs/man/manpages-de.po
./docs/man/amuled.it.1
./docs/man/ed2k.de.1
./docs/man/amuled.eu.1
./docs/man/amulegui.de.1
./docs/man/amulegui.1
./docs/man/amule.1
./docs/man/amuleweb.1
./docs/man/Makefile.in
./docs/man/amulecmd.1
./docs/man/amulecmd.de.1
./docs/man/ed2k.1
./docs/man/Makefile
./docs/man/amule.es.1
./docs/man/amuleweb.hu.1
./docs/man/amule.de.1
./docs/man/amule.hu.1
./docs/man/amule.fr.1
./docs/man/amulecmd.it.1
./docs/man/amuled.de.1
./docs/man/amuled.fr.1
./docs/man/ed2k.fr.1
./docs/man/amuled.hu.1
./docs/man/amuleweb.es.1
./docs/man/amulecmd.eu.1
./docs/man/amuleweb.de.1
./docs/man/ed2k.hu.1
./docs/man/amuled.es.1
./docs/man/ed2k.es.1
./docs/man/amuled.1
./docs/man/ed2k.it.1
./docs/man/amuleweb.fr.1
./docs/man/manpages.pot
./docs/man/amulecmd.fr.1
./docs/man/amulecmd.es.1
./docs/man/amulegui.it.1
./docs/Makefile
./docs/license.txt
./docs/INSTALL
./docs/Changelog
./docs/amule-win32.HOWTO.txt
./docs/README
./docs/AUTHORS
./docs/ABOUT-NLS
./docs/EC_Protocol.txt
./docs/ED2K-Links.HOWTO
grep: /var/tmp/tmp.naUp2LT6H9/newfile: 没有该文件或目录

把文件拷贝到临时目录……OK

Stripping ELF binaries and libraries...OK

压缩 man 手册页……OK

创建文件列表……OK

创建 Debian 包……OK

安装 Debian 包……OK

删除临时文件……OK

生成备份包……OK

删除临时目录……OK


**********************************************************************

 Done. The new package has been installed and saved to

 /home/may/Compile-Software/aMule-2.2.6-DLP39/amule-2.2.6_DLP39-1_i386.deb

 You can remove it from your system anytime using:

      dpkg -r amule-2.2.6

**********************************************************************

may@may-desktop:~/Compile-Software/aMule-2.2.6-DLP39$


aMule-2.2.6-DLP39-ubuntu9.10
下载地址: ftp://share:share@share.shoukang.org/hhh/amule-2.2.6_DLP39-1_i386.deb
电驴下载:
代码:
ed2k://|file|amule-2.2.6_DLP39-1_i386.deb|4210324|9455EC911D0AAE421DBE7D1E488213B3|/

不知道能用不
或(因为软件包的执行标准不同)
dpkg-buildpackage –rfakeroot

执行完毕后deb软件包就会出现在这个目录里面了。


_________________


最后由 mickeywaley 编辑于 2009-10-18 0:17,总共编辑了 2 次

页首
 用户资料  
 
13 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 23:28 
头像

注册: 2007-10-18 17:40
帖子: 1006
送出感谢: 0 次
接收感谢: 0 次
arch linux下
代码:
yaourt -S  amule-dlp


安装成功

再也见不到xl build的客户端了。 太爽了。


_________________

千帖户,享有论坛特权!


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-17 23:45 
头像

注册: 2007-10-18 17:40
帖子: 1006
送出感谢: 0 次
接收感谢: 0 次
感谢楼主的无私奉献


_________________

千帖户,享有论坛特权!


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 让aMule支持DLP的源码补丁
帖子发表于 : 2009-10-18 0:09 
头像

注册: 2007-10-18 17:40
帖子: 1006
送出感谢: 0 次
接收感谢: 0 次
不稳定,容易崩溃


附件:
amule-臭虫报告.txt.rar [18.27 KiB]
被下载 61 次


_________________

千帖户,享有论坛特权!
页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 162 篇帖子 ]  前往页数 1, 2, 3, 4, 5 ... 11  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译