当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-02-10 15:04 
头像

注册: 2010-02-06 10:43
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
QQ聊天时,总是在 发第五句话的时候关闭。。。。网上找了一下,说是linux qq与ibus 不兼容,各位高人,怎么解决,难道要用webqq么?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-02-10 15:19 
头像

注册: 2008-12-19 18:25
帖子: 143
送出感谢: 1
接收感谢: 0 次
答案是肯定的,tecent做webqq就是不想花力气再开发其他平台的qq客户端。


_________________
你用过ubuntu吗?什么?没用过?你可被时代抛弃了啊?看看这位大侠的帖子吧,你会爱上ubuntu的。
大侠cityboy又一力作,9.10全攻略
我的ubuntu经历http://hi.baidu.com/heke2929
自己定制发行版的200条命令


页首
 用户资料  
 
3 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-02-10 15:28 
头像

注册: 2009-05-16 8:47
帖子: 2753
送出感谢: 0 次
接收感谢: 2
不兼容?换fcitx试试 :em02


_________________
“飞达”——武汉理工大学开源技术协会http://vedaclub.org/


页首
 用户资料  
 
4 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-02-10 16:15 
头像

注册: 2010-01-13 9:54
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
sudo gedit /usr/bin/qq
于第二行添加:
export GDK_NATIVE_WINDOWS=true GTK_IM_MODULE=xim XMODIFIERS="@im=ibus"

即:
#!/bin/sh
export GDK_NATIVE_WINDOWS=true GTK_IM_MODULE=xim XMODIFIERS="@im=ibus"
cd /usr/share/tencent/qq/
./qq


_________________
"More people willing to give their souls for what they desire..."


页首
 用户资料  
 
5 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-02-10 16:59 

注册: 2010-01-13 23:26
帖子: 3173
送出感谢: 0 次
接收感谢: 12
还是那句话啦,放弃linuxqq吧


_________________
Here I am.
Ubuntu 桌面培训 - 全中文官方文档,含汉化截图,提供PDF


页首
 用户资料  
 
6 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-02-12 18:42 
头像

注册: 2009-11-19 13:13
帖子: 120
送出感谢: 0 次
接收感谢: 0 次
用fcitx吧,王道


页首
 用户资料  
 
7 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-02-13 23:37 

注册: 2008-12-29 23:38
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
修改 linuxQQ的启动脚本
sudo gedit /usr/bin/qq
加上下面这行
export GDK_NATIVE_WINDOWS=true

最终该配置文件为:

#!/bin/sh
export GDK_NATIVE_WINDOWS=true
cd /usr/share/tencent/qq/
./qq


疯狂读写解决方法:主目录下.tecent改成只读


页首
 用户资料  
 
8 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-02-14 21:59 

注册: 2010-02-02 7:15
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
楼上解决方案是可行的。我已经如此解决。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-10-18 11:02 
头像

注册: 2007-11-12 14:27
帖子: 629
地址: 地球的角落
送出感谢: 0 次
接收感谢: 2
Ubuntu-Jon 写道:
sudo gedit /usr/bin/qq
于第二行添加:
export GDK_NATIVE_WINDOWS=true GTK_IM_MODULE=xim XMODIFIERS="@im=ibus"

即:
#!/bin/sh
export GDK_NATIVE_WINDOWS=true GTK_IM_MODULE=xim XMODIFIERS="@im=ibus"
cd /usr/share/tencent/qq/
./qq



我以前可以 但升成10.10后 好象又不行了


页首
 用户资料  
 
10 楼 
 文章标题 : Re: linux qq与ibus 不兼容问题怎么解决?
帖子发表于 : 2010-10-18 11:41 
头像

注册: 2007-10-23 22:05
帖子: 171
送出感谢: 0 次
接收感谢: 0 次
在输入框里面右键,选择xim即可


_________________
我向星星许了个愿。我并不是真的相信它,但是反正也是免费的,而且也没有证据证明它不灵。。。
http://bit.ly/9rJ71o


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译