当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 8.10 下编译pidgin2.5.8终于成功了,解决乱码
帖子发表于 : 2010-03-15 16:16 
头像

注册: 2008-10-30 10:40
帖子: 406
送出感谢: 0 次
接收感谢: 5
由于系统上自带的pidgin2.5.2无法登陆QQ,我只好下载了linux qq,但这个版本比较低,很多功能受限制。
所以,只好试着自己编译看看。
第一次编译东东,差点就进不了系统了。险啊。 :em06

在网上找了一个方法,
http://www.oklinux.cn/html/Basic/jyjq/2 ... 73041.html
引过来如下:
在Ubuntu中下好了pidgin-2.5.8.tar.bz2
(注释:我是在网上搜索这个文件,从SourceForge.net下载的。

开始./configure –prefix=/usr/lib/pidgin-2.5.8
(注释:这里可以用cd命令,进入pidgin-2.5.8文件夹,在执行./configure命令。如果不是管理员,就执行sudo ./configure)

首先出现了

configure: error: The intltool scripts were not found. Please install intltool.

解决办法:sudo apt-get install intltool

然后出现了
configure: error: You must have the GLib 2.0 development headers installed to build.

If you have these installed already you may need to install pkg-config so
I can find them.

解决办法:sudo apt-get install libglib2.0-dev pkg-config

然后又出现

configure: error: You must have the GTK 2.0 development headers installed to compile Pidgin.
If you want to build only Finch then specify –disable-gtkui when running configure.

解决方法:sudo apt-get install libgtk2.0-dev

错误继续出现

configure: error: XScreenSaver extension development headers not found.
Use –disable-screensaver if you do not need XScreenSaver extension support,
this is required for detecting idle time by mouse and keyboard usage.

解决方法:sudo apt-get install libxss-dev

继续错误

configure: error:
Startup notification development headers not found.
Use –disable-startup-notification if you do not need it.

解决方法:sudo apt-get install libstartup-notification0-dev

继续错误

configure: error:
GtkSpell development headers not found.
Use –disable-gtkspell if you do not need it.

解决方法:sudo apt-get install libgtkspell-dev

继续错误

configure: error:You must have libxml2 >= 2.6.0 development headers installed to build.

解决方法:sudo apt-get install libxml2-dev

继续错误

configure: error:
GStreamer development headers not found.
Use –disable-gstreamer if you do not need GStreamer (sound) support.

解决方发:sudo apt-get install libgstreamer0.10-dev

到现在为止错误还是不断

configure: error:
Meanwhile development headers not found.
Use –disable-meanwhile if you do not need meanwhile (Sametime) support.

解决方法:pinane@Ubuntu:~/file/pidgin-2.5.8$ sudo apt-get install libmeanwhile-dev

configure: error:
avahi development headers not found.
Use –disable-avahi if you do not need avahi (Bonjour) support.

解决方法:pinane@Ubuntu:~/file/pidgin-2.5.8$ sudo apt-get install libavahi-client-dev libavahi-glib-dev

configure: error:
Perl development headers not found.
Use –disable-perl if you do not need Perl scripting support.

解决方法:pinane@Ubuntu:~/file/pidgin-2.5.8$ sudo apt-get install libperl-dev

Tcl development headers not found.: tcl8.4-dev

Tk development headers not found.: tk8.4-dev

解决方法:pinane@Ubuntu:~/file/pidgin-2.5.8$ sudo apt-get install tk8.4-dev tcl8.4-dev

到此为止我的编译终于通过了附错误大全表

XScreenSaver extension development headers not found.: libxss-dev

Startup notification development headers not found.: libstartup-notification0-dev

GStreamer development headers not found.: libgstreamer0.10-dev

Meanwhile development headers not found.: libmeanwhile-dev

D-Bus development headers not found.: libdbus-1-dev libdbus-glib-1-dev

NetworkManager development headers not found.: network-manager-dev

Perl development headers not found.: libperl-dev

Tcl development headers not found.: tcl8.4-dev

Tk development headers not found.: tk8.4-dev

GtkSpell development headers not found.:libgtkspell-dev

avahi development headers not found.:libavahi-client-dev libavahi-glib-dev

---------------------------------引用完----------------------------------------------------------
注:实际上作者还有一些在前面没有列出来,不过在错误大全表里给出来了,只要执行sudo apt-get install加上冒号后面的文件名就可以了。
如sudo apt get install tk8.4-dev
------------------------------------------------------------------------------------
按照这个方法,一直进行的很好,就差几步就完成了。可这时候提示,
configure: error:
GStreamer development headers not found.
Use –disable-gstreamer if you do not need GStreamer (sound) support.

我安装上面的方法,输入sudo apt-get install libgstreamer0.10-dev
结果提示:
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是 因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件 包尚未被创建或是它们还在新到(incoming)目录中。
下列的软件包有不能满足的依赖关系: libgstreamer0.10-dev: 依赖: libgstreamer0.10-0 (= 0.10.21-4) 但是 0.10.24-1~pidgin1.9.04 正要被安装。

我就在新立德里面找,结果发现里面的版本比提示的版本高。我就卸载libgstreamer。提示要卸载很多相关的东西。我都卸载了。
然后继续sudo ./configure
这回都通过了,然后
sudo make
sudo make install
装好了。可是,这下,可惹麻烦了。我发现进入莫个文件夹都进不去了。重启,结果再进系统,没有声音,只有一片背景。啥也看不到了。就像windows的黑屏,除了printsreen键可以用。啥键都不好使了。
:em20 :em20
我想着,也许得重新作系统,安装9.1了。但还是想找找解决问题的办法。
重起,按esc,在这里有个提示,可以进入recovery方式。
我就按了。进入后,选择“修复”,wow,太好了。(我的电脑一直连着网线的),我看见系统在自动下载被删除的文件了。(当然还安装了默认的我已经卸载的文件,如openoffice,游戏等)。经过约20分钟的下载,以及5分钟作用的安装。终于结束了。高兴一下。然后系统提示,进入初始登陆界面,我选择“正常登陆”,....................铃声响起来了。终于又看见桌面了。
卸载openoffice,游戏等。
启动pidgin2.5.8,将qq版本设为2008,ok了。
:em06

装好后,发现别人发来的字体都是方块,不能正常显示。
打开pidgin 菜单栏 "工具->首选项->对话" 设置标签页面的 "对话" 设置里,把 "收到的消息显示格式" 前面的复选框去掉
把“使用主题中的字体”勾选掉,在下面自定选个中文字体就可以了(可以预览到效果)

再登陆后,发现过不了多久,就得老是输入验证码。
找了一下,可能是代理的关系,默认是“使用Gnome代理设置”
把它改成无代理,暂时没问题了。而且连登陆的速度都变快了。呵呵
据说是有代理的情况,IP变更会要求重新激活。


_________________
Namas Amitabha
南无阿弥陀佛
一切有为法,如梦幻泡影,
如露亦如电,应作如是观。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译