关于MLdonkey的编译

上网、浏览、聊天、下载等
回复
jsntyyl
帖子: 45
注册时间: 2009-02-25 22:29
送出感谢: 0
接收感谢: 0

关于MLdonkey的编译

#1

帖子 jsntyyl » 2010-12-04 14:13

ubuntu源自带的版本为3.0.1,而最新的版本已近是3.0.6,我把源码下载下来,按照网上的提示进行编译,例如:

Compile mldonkey without GUI support
You have to have zlib, zlib-dev and m4 packages installed.
For gd-made statistics libgd2-dev should be installed.

Mldonkey/> ./configure
Mldonkey/> make

但是进行到“./configure”终端就提示“bash: ./configure: 没有那个文件或目录”,我看文件夹里头确实没有“configure”这个文件,那又如何编译呢?
wykzly
帖子: 224
注册时间: 2010-05-20 13:45
送出感谢: 0
接收感谢: 0

Re: 关于MLdonkey的编译

#2

帖子 wykzly » 2010-12-04 15:44

jsntyyl
帖子: 45
注册时间: 2009-02-25 22:29
送出感谢: 0
接收感谢: 0

Re: 关于MLdonkey的编译

#3

帖子 jsntyyl » 2010-12-04 18:58

下载完成后直接点击安装出现下列文字,无法安装。

发生了一个无法处理的错误
这似乎是 aptdaemon 的程序错误,aptdaemon 允许您添加或删除软件,并可执行其他与包管理有关的工作。请报告此错误到 http://launchpad.net/aptdaemon/+filebug 并重试。
头像
到处看看
论坛版主
帖子: 8483
注册时间: 2010-01-17 13:05
系统: ubuntu
送出感谢: 0
接收感谢: 28 次

Re: 关于MLdonkey的编译

#4

帖子 到处看看 » 2010-12-04 22:21

下载的软件包不对吧,是那个mldonkey-3.0.6.tar.bz2。
然后
sudo apt-get install ocaml zlib1g-dev

解压文件
cd进目录
运行
./configure
make
头像
sainthsu
帖子: 14
注册时间: 2010-03-01 11:20
送出感谢: 0
接收感谢: 0

Re: 关于MLdonkey的编译

#5

帖子 sainthsu » 2010-12-05 7:02

:em11 支持一下
wykzly
帖子: 224
注册时间: 2010-05-20 13:45
送出感谢: 0
接收感谢: 0

Re: 关于MLdonkey的编译

#6

帖子 wykzly » 2010-12-05 9:56

jsntyyl 写了:
下载完成后直接点击安装出现下列文字,无法安装。

发生了一个无法处理的错误
这似乎是 aptdaemon 的程序错误,aptdaemon 允许您添加或删除软件,并可执行其他与包管理有关的工作。请报告此错误到 http://launchpad.net/aptdaemon/+filebug 并重试。
是你系统的问题 , 很多人装了我的deb包没问题的,我自己也是用他的
jsntyyl
帖子: 45
注册时间: 2009-02-25 22:29
送出感谢: 0
接收感谢: 0

Re: 关于MLdonkey的编译

#7

帖子 jsntyyl » 2010-12-05 10:06

到处看看 写了:下载的软件包不对吧,是那个mldonkey-3.0.6.tar.bz2。
然后
sudo apt-get install ocaml zlib1g-dev

解压文件
cd进目录
运行
./configure
make
“sudo apt-get install ocaml zlib1g-dev”也是装过的,官网的两个我都下过,你说的这个和一个带“tool”的,两个都试过,configure的时候都提示错误,说明是没这个文件嘛。
jsntyyl
帖子: 45
注册时间: 2009-02-25 22:29
送出感谢: 0
接收感谢: 0

Re: 关于MLdonkey的编译

#8

帖子 jsntyyl » 2010-12-05 10:10

wykzly 写了:
jsntyyl 写了:
下载完成后直接点击安装出现下列文字,无法安装。

发生了一个无法处理的错误
这似乎是 aptdaemon 的程序错误,aptdaemon 允许您添加或删除软件,并可执行其他与包管理有关的工作。请报告此错误到 http://launchpad.net/aptdaemon/+filebug 并重试。
是你系统的问题 , 很多人装了我的deb包没问题的,我自己也是用他的
系统问题什么的就不知道了,也不敢瞎装了,源里自带的3.0.1凑合着用用算了,上次装个声卡驱动却把系统搞得没声音了。
回复

回到 “因特网相关软件”